Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456684 - media-gfx/shotwell-0.13.1-r2: opening preferences window causes segfault in gnome-shell-3.6.2-r1 + mutter-3.6.2
Summary: media-gfx/shotwell-0.13.1-r2: opening preferences window causes segfault in g...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal critical (vote)
Assignee: Markos Chandras (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 18:28 UTC by Clemente Aguiar
Modified: 2013-04-21 14:03 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Shotwell crach 20130212 11:43 - abrt log (shotwell-201302121143.log,159.12 KB, text/plain)
2013-02-12 12:06 UTC, Clemente Aguiar
Details
Shotwell crash 20130212 17:56 - abrt log (abrt.log,160.25 KB, text/plain)
2013-02-12 18:05 UTC, Clemente Aguiar
Details
output of glxinfo -l (glxinfo-l.txt,27.26 KB, text/plain)
2013-02-12 19:40 UTC, Clemente Aguiar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemente Aguiar 2013-02-10 18:28:19 UTC
I am reporting this problem now but I have had this problem since I first installed shotwel (version 12.3).

Basically shotwell crashes, and brings down the gnome session, when I try to open the preferences window. All I do is, I go to menu Edit, select Preferences, and the whole thing crashes.

If I start the gnome session from the command line (with startx) I can see some warnings and errors but I don't know if they are relevant:

...
Aviso do gestor de janelas: CurrentTime used to choose focus window; focus window may not be correct.
Aviso do gestor de janelas: Got a request to focus 0x1c00004 (Área de T) with a timestamp of 0.  This shouldn't happen!
** Message: Stopping applet secret agent because GNOME Shell appeared
Aviso do gestor de janelas: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1a00003 (Shotwell)
Aviso do gestor de janelas: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
gnome-session[19496]: WARNING: Application 'gnome-shell.desktop' killed by signal 11
...

Please let me know how to proceed to give you the required information to figure out the problem.

Reproducible: Always




$ emerge -pv shotwell

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] media-gfx/shotwell-0.13.1-r2  LINGUAS="pt -ar -ast -bg -bn -ca -cs -da -de -el -en_GB -es -et -eu -fi -fr -gl -he -hi -hr -hu -ia -id -it -ja -kk -ko -lt -lv -mk -nb -nl -pa -pl -pt_BR -ro -ru -sk -sl -sr -sv -ta -ta_IN -te -te_IN -th -tr -uk -vi -zh_CN -zh_TW" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


$ emerge --info
Portage 2.1.11.50 (default/linux/amd64/13.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i3-2100_CPU_@_3.10GHz-with-gentoo-2.1
KiB Mem:     4033076 total,   2961572 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Sun, 10 Feb 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo wirelay sunrise my_local_overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pt_PT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/wirelay /var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli colord consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gimp gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 java jpeg lame lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib musepack nautilus ncurses networkmanager nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 quicktime readline scanner sdl session smp socialweb spell sse sse2 ssl ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vorbis wavpack wmf wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pt_PT pt en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-10 19:36:23 UTC
Can I see your /var/log/Xorg.0.log that contains the crash please? You might need to look in one of the older logs, numbered 1 to 5. It would give some lines starting with (EE) near the end, giving you a backtrace of why it crashed.
Comment 2 Clemente Aguiar 2013-02-10 21:28:51 UTC
shotwell crashes every time I try to go to preferences, so I can easily reproduce.

Actualy there is no error (EE) messages in Xorg.0.log

The last message is:
[   197.815] Server terminated successfully (0). Closing log file.

However I looked at the /vat/log/messages and there seems to have some error messages related to the crash.

......
Feb 10 21:10:33 caguiar-home kernel: gnome-shell[18313]: segfault at 0 ip 00007f5b6fd9a8a0 sp 00007fff7fd4bfc8 error 4 in libcogl.so.9.1.2[7f5b6fd76000+84000]
Feb 10 21:10:33 caguiar-home polkitd[17679]: Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.40, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale pt_PT.utf8) (disconnected from bus)
Feb 10 21:10:33 caguiar-home gnome-session[18190]: WARNING: Application 'gnome-shell.desktop' killed by signal 11
Feb 10 21:10:34 caguiar-home dbus[17576]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.47" (uid=1000 pid=18724 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=17591 comm="/usr/sbin/console-kit-daemon ")
Feb 10 21:10:34 caguiar-home polkitd[17679]: Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.47 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale pt_PT.utf8)
Feb 10 21:10:34 caguiar-home dbus[17576]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.47" (uid=1000 pid=18724 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=17591 comm="/usr/sbin/console-kit-daemon ")
Feb 10 21:10:34 caguiar-home kernel: gnome-shell[18724]: segfault at 0 ip 00007f9a6d3b38a0 sp 00007fff42b24268 error 4 in libcogl.so.9.1.2[7f9a6d38f000+84000]
Feb 10 21:10:34 caguiar-home polkitd[17679]: Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.47, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale pt_PT.utf8) (disconnected from bus)
Feb 10 21:10:34 caguiar-home gnome-session[18190]: WARNING: Application 'gnome-shell.desktop' killed by signal 11
Feb 10 21:10:34 caguiar-home gnome-session[18190]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Feb 10 21:10:47 caguiar-home gnome-session[18190]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
Feb 10 21:10:47 caguiar-home gnome-session[18190]: Gtk-CRITICAL: gtk_main_quit: assertion `main_loops != NULL' failed
.......
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-10 22:10:55 UTC
Thank you, I was checking if you were experiencing bug #456682, it appears you don't. Therefore, I have assigned this bug to the maintainers of shotwell.
Comment 4 Justin Lecher gentoo-dev 2013-02-11 09:41:55 UTC
Please start

SHOTWELL_LOG=1 SHOTWELL_INFO=1 SHOTWELL_DEBUG=1 SHOTWELL_MESSAGE=1 shotwell

from a console and attach 

~/.cache/shotwell/shotwell.log

and if something is in .xsession-errors, also the bits from there.
Comment 5 Clemente Aguiar 2013-02-11 19:59:56 UTC
Since I updated the system in early Jan. that I no longer have .xsession-errors file (???).

I started

SHOTWELL_LOG=1 SHOTWELL_INFO=1 SHOTWELL_DEBUG=1 SHOTWELL_MESSAGE=1 shotwell

from a console, and here are the contents of:

~/.cache/shotwell/shotwell.log

----
L 19442 2013-02-11 19:54:09 [MSG] main.vala:372: Shotwell Gestor de fotos 0.13.1
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:316: Searching /home/clemente/.gnome2/shotwell/plugins for plugins ...
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:135: Unable to search directory /home/clemente/.gnome2/shotwell/plugins for plugins: No such file or directory
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:316: Searching /usr/lib64/shotwell/plugins for plugins ...
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:316: Searching /usr/lib64/shotwell/plugins/builtin for plugins ...
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:424: Loaded SPIT module "Transições principais 0.13.1" (org.yorba.shotwell.transitions) [/usr/lib64/shotwell/plugins/builtin/shotwell-transitions.so]
L 19442 2013-02-11 19:54:09 [WRN] Resources.vala:42: couldn't load icon set from /usr/lib64/shotwell/plugins/builtin/tumblr.png.
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:424: Loaded SPIT module "Shotwell Extra Publishing Services 0.13.1" (org.yorba.shotwell.publishing.extras) [/usr/lib64/shotwell/plugins/builtin/shotwell-publishing-extras.so]
L 19442 2013-02-11 19:54:09 [DBG] Plugins.vala:424: Loaded SPIT module "Serviços principais de publicação 0.13.1" (org.yorba.shotwell.publishing.core_services) [/usr/lib64/shotwell/plugins/builtin/shotwell-publishing.so]
L 19442 2013-02-11 19:54:10 [DBG] Plugins.vala:424: Loaded SPIT module "Serviços de importação de dados 0.13.1" (org.yorba.shotwell.data_imports.core_services) [/usr/lib64/shotwell/plugins/builtin/shotwell-data-imports.so]
L 19442 2013-02-11 19:54:10 [MSG] main.vala:43: Verifying database ...
L 19442 2013-02-11 19:54:10 [DBG] Db.vala:40: Database schema version 16 created by app version 0.13.1
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: LibraryPhoto.init (0/6013)
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: Video.init (2837/6013)
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: Upgrades.execute (2860/6013)
L 19442 2013-02-11 19:54:10 [DBG] Upgrades.vala:82: Could not delete mimics: /home/clemente/.local/share/shotwell/mimics is not a directory
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: Event.init (2860/6013)
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: Tag.init (3172/6013)
L 19442 2013-02-11 19:54:10 [DBG] util.vala:162: next step: LibraryWindow (3172/6013)
L 19442 2013-02-11 19:54:11 [DBG] ConfigurationInterfaces.vala:303: ConfigurationFacade: engine reports property 'DISPLAY_BASIC_PROPERTIES' changed.
L 19442 2013-02-11 19:54:11 [DBG] ConfigurationInterfaces.vala:303: ConfigurationFacade: engine reports property 'EVENTS_SORT_ASCENDING' changed.
L 19442 2013-02-11 19:54:11 [DBG] LibraryWindow.vala:268: on_library_monitor_installed: /home/clemente/Imagens
L 19442 2013-02-11 19:54:11 [DBG] util.vala:162: next step: done (3172/6013)
L 19442 2013-02-11 19:54:11 [DBG] ConfigurationInterfaces.vala:303: ConfigurationFacade: engine reports property 'SHOW_WELCOME_DIALOG' changed.
L 19442 2013-02-11 19:54:11 [DBG] main.vala:187: 1,711850 seconds to Gtk.main()
----
Comment 6 Clemente Aguiar 2013-02-11 20:45:24 UTC
As per instructions in 

http://redmine.yorba.org/projects/shotwell/wiki/ShotwellFAQ#I-found-a-bug-in-Shotwell-How-can-I-report-it

I "installed" debug symbols for GLib, GTK+ and Shotwell.

I the run

$ SHOTWELL_LOG=1 gdb shotwell 2>&1 | tee shotwell.gdb

from within a terminal inside gnome. Here is the contents of 

$ cat shotwell.gdb 
GNU gdb (Gentoo 7.5 p1) 7.5
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/shotwell...Reading symbols from /usr/lib64/debug/usr/bin/shotwell.debug...done.
done.
(gdb) run
Starting program: /usr/bin/shotwell 
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffea371700 (LWP 10170)]
[New Thread 0x7fffcf3c1700 (LWP 10171)]
[New Thread 0x7fffcebc0700 (LWP 10172)]
[New Thread 0x7fffce3bf700 (LWP 10173)]
[New Thread 0x7fffcdbbe700 (LWP 10174)]
[New Thread 0x7fffcd3bd700 (LWP 10175)]

The problem is that the whole gnome session crashes, so even the information of gdb does not get logged, and I cannot backtrace.

Any ideas?
Comment 7 Justin Lecher gentoo-dev 2013-02-12 07:59:39 UTC
(In reply to comment #6)
> As per instructions in 
> 
> http://redmine.yorba.org/projects/shotwell/wiki/ShotwellFAQ#I-found-a-bug-in-
> Shotwell-How-can-I-report-it
> 
> I "installed" debug symbols for GLib, GTK+ and Shotwell.
> 
> I the run
> 
> $ SHOTWELL_LOG=1 gdb shotwell 2>&1 | tee shotwell.gdb
> 
> from within a terminal inside gnome. Here is the contents of 
> 
> $ cat shotwell.gdb 
> GNU gdb (Gentoo 7.5 p1) 7.5
> Copyright (C) 2012 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-pc-linux-gnu".
> For bug reporting instructions, please see:
> <http://bugs.gentoo.org/>...
> Reading symbols from /usr/bin/shotwell...Reading symbols from
> /usr/lib64/debug/usr/bin/shotwell.debug...done.
> done.
> (gdb) run
> Starting program: /usr/bin/shotwell 
> warning: Could not load shared library symbols for linux-vdso.so.1.
> Do you need "set solib-search-path" or "set sysroot"?
> [Thread debugging using libthread_db enabled]
> Using host libthread_db library "/lib64/libthread_db.so.1".
> [New Thread 0x7fffea371700 (LWP 10170)]
> [New Thread 0x7fffcf3c1700 (LWP 10171)]
> [New Thread 0x7fffcebc0700 (LWP 10172)]
> [New Thread 0x7fffce3bf700 (LWP 10173)]
> [New Thread 0x7fffcdbbe700 (LWP 10174)]
> [New Thread 0x7fffcd3bd700 (LWP 10175)]
> 
> The problem is that the whole gnome session crashes, so even the information
> of gdb does not get logged, and I cannot backtrace.
> 
> Any ideas?

please install abrt. with that you can catch segf even when the complete session crashes.

Another try would be, move away all files from your picture folder and restart shottwell.
Comment 8 Clemente Aguiar 2013-02-12 12:06:40 UTC
Created attachment 338682 [details]
Shotwell crach 20130212 11:43 - abrt log

I installed abrt (lateste version: 2.0.12-r1
This is the log created after a shotwell crash.
Comment 9 Clemente Aguiar 2013-02-12 12:12:26 UTC
(In reply to comment #7)

> Another try would be, move away all files from your picture folder and
> restart shottwell.

Deleted .local/share/shotwell directory (deletes shotwell data base).
No files in Photos and Images directories.

Started Shotwell, and is blank, go to preferences still crashes.
Comment 10 Justin Lecher gentoo-dev 2013-02-12 12:21:08 UTC
@gnome
the shell crashes. Any idea why?
Comment 11 Clemente Aguiar 2013-02-12 12:35:49 UTC
(In reply to comment #10)
> @gnome
> the shell crashes. Any idea why?

No. This is what I have mentioned since my first report.
All I do is:
1. From a terminal run startx
2. Open Shotwell
3. Go to Edit -> Preferences

And I the whole gnome session crashes and I am back at the terminal.

At the office, I have a similar configured PC (i.e. Gentoo AMD64 with Gnome 3.6) and this does not happen. It only happens on my home PC. And that is what is weird.

For the record, to try to solve this mystery, I recently emerged -e world, with minimum CFLAGS, i.e. CFLAGS="-O2 -pipe".  
Made no difference. I am still keeping these CFLAGS until problem solved.
Comment 12 Justin Lecher gentoo-dev 2013-02-12 12:39:48 UTC
(In reply to comment #11)
> No. This is what I have mentioned since my first report.

it does, look at your abrt.log. It's about a gnome-shell crash.
Comment 13 Clemente Aguiar 2013-02-12 13:21:34 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > No. This is what I have mentioned since my first report.
> 
> it does, look at your abrt.log. It's about a gnome-shell crash.

There seem to be a misunderstanding, I was saying no to your question "Any idea why?" in comment 10, which only later that I figure out that the question was not intended for me.

Sorry for the confusion.
Comment 14 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-12 17:30:02 UTC
(In reply to comment #8)
> Created attachment 338682 [details]
> Shotwell crach 20130212 11:43 - abrt log
> 
> I installed abrt (lateste version: 2.0.12-r1
> This is the log created after a shotwell crash.

Thanks for the log. Unfortunately, it looks like you didn't have some of the debugging information that abrt needed to generate a complete backtrace for the crash.

Please re-emerge the following packages with -ggdb in CFLAGS and splitdebug in FEATURES (see http://www.gentoo.org/proj/en/qa/backtraces.xml for more information):

media-libs/cogl, media-libs/clutter, x11-wm/mutter

and then please crash gnome-shell with shotwell again, and attach the resulting abrt log.

In addition, please say what versions (and with what USE flags) of media-libs/cogl, media-libs/clutter, x11-wm/mutter, gnome-base/gnome-shell, x11-libs/libwnck, and media-libs/mesa you are using.
Comment 15 Clemente Aguiar 2013-02-12 18:05:56 UTC
Created attachment 338714 [details]
Shotwell crash 20130212 17:56 - abrt log

Here is the abrt log as requested, after building media-libs/cogl, media-libs/clutter, x11-wm/mutter with debug symbols.

And here is the versions and USE flags of the different packages as requested.

$ emerge -pv media-libs/cogl media-libs/clutter x11-wm/mutter gnome-base/gnome-shell x11-libs/libwnck

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] media-libs/cogl-1.10.4:1.0/9  USE="introspection opengl pango -debug -doc -examples -gles2 {-test}" 0 kB
[ebuild   R   ~] x11-libs/libwnck-3.4.4:3  USE="introspection startup-notification -tools" 0 kB
[ebuild   R   ~] media-libs/clutter-1.12.2:1.0  USE="gtk introspection -debug -doc {-test}" 0 kB
[ebuild   R   ~] x11-wm/mutter-3.6.2  USE="introspection -debug {-test}" 0 kB
[ebuild   R   ~] gnome-base/gnome-shell-3.6.2-r1  USE="bluetooth i18n networkmanager -systemd" PYTHON_TARGETS="python2_7 -python2_6" 0 kB
Comment 16 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-12 19:04:33 UTC
(In reply to comment #15)
> Created attachment 338714 [details]
> Shotwell crash 20130212 17:56 - abrt log

Thanks. It's possible that mutter is for some reason creating textures that are too large for your video card.

Please attach the output of "glxinfo -l" (if you don't have glxinfo, you will need to emerge x11-apps/mesa-progs first).
Comment 17 Clemente Aguiar 2013-02-12 19:40:08 UTC
Created attachment 338724 [details]
output of glxinfo -l
Comment 18 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-13 02:29:33 UTC
(In reply to comment #17)

Thanks.

>     GL_MAX_TEXTURE_SIZE = 2048

seems quite low; I am guessing this is an old video card?

When I open the preferences window in shotwell-0.13.1, I notice the screen blink a bit. This is only a guess, but maybe shotwell is initially creating a very large window, over 2048 pixels on one side, and then immediately resizing it down? Mutter would try to allocate a GL texture large enough for the window's initial size, which would fail, and the fallout might be the crash that you are seeing.
Comment 19 Gilles Dartiguelongue gentoo-dev 2013-02-13 10:20:34 UTC
This is definitively a really low value. Even my old PCI Radeon 9000 (r200) had 4096 here. It couldn't run gnome-shell because of the dual monitor setup exceeding that limit (1280x1024 x 2).

What is the size of your monitor ?
Comment 20 Clemente Aguiar 2013-02-13 11:47:53 UTC
Yes, its not a new card, its a Radeon X800 GTO.

Here is what "lspci -v" says

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI R480 [Radeon X800 GTO (PCIE)] (prog-if 00 [VGA controller])
	Subsystem: Hightech Information System Ltd. Device 2046
	Flags: bus master, fast devsel, latency 0, IRQ 45
	Memory at f0000000 (64-bit, prefetchable) [size=128M]
	Memory at fe630000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at e000 [size=256]
	Expansion ROM at fe600000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Express Endpoint, MSI 00
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Advanced Error Reporting
	Kernel driver in use: radeon
	Kernel modules: radeon

My display is a LG 20" (Wide) with a resolution of 1650x1050.
Comment 21 Clemente Aguiar 2013-04-21 14:03:26 UTC
I installed the latest version (0.14.0-r1), and with this version I am now able to open the Preferences window.

So for me the problem is resolved.