Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 456682 - x11-base/xorg-server-1.13.2 with x11-drivers/xf86-video-nouveau-1.0.6 crashes when displaying larger images in applications like Firefox and Ristretto.
Summary: x11-base/xorg-server-1.13.2 with x11-drivers/xf86-video-nouveau-1.0.6 crashes...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 18:19 UTC by Vladimir
Modified: 2015-02-22 22:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dmesg output (file_456682.txt,54.67 KB, text/plain)
2013-02-10 19:26 UTC, woddfellow2
Details
/var/log/Xorg.0.log (file_456682.txt,30.66 KB, text/plain)
2013-02-10 19:27 UTC, woddfellow2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2013-02-10 18:19:56 UTC
media-gfx/ristretto-0.6.3 makes X-server to crash when I try to view this image:

http://ftp.wombat.org.ua/Solar_eclips_1999_4.jpg    (3,1M)

This is a very strange thing that had never happened on my machine before, so I decided to report it here, however I am not sure about the source of the problem.

Reproducible: Always





The end of /var/log/Xorg.0.log is this:

[ 22563.609] (EE) Backtrace:
[ 22563.609] (EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x591724]
[ 22563.609] (EE) 1: /usr/bin/X (0x400000+0x195419) [0x595419]
[ 22563.609] (EE) 2: /lib64/libpthread.so.0 (0x7f9e9ffd9000+0x10a10) [0x7f9e9ffe9a10]
[ 22563.609] (EE) 3: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f9e9d8bc000+0x752e) [0x7f9e9d8c352e]
[ 22563.609] (EE) 4: /usr/lib64/xorg/modules/libexa.so (0x7f9e9d276000+0x9746) [0x7f9e9d27f746]
[ 22563.609] (EE) 5: /usr/bin/X (0x400000+0x11d374) [0x51d374]
[ 22563.610] (EE) 6: /usr/bin/X (0x400000+0x3782e) [0x43782e]
[ 22563.610] (EE) 7: /usr/bin/X (0x400000+0x3aba9) [0x43aba9]
[ 22563.610] (EE) 8: /usr/bin/X (0x400000+0x29b35) [0x429b35]
[ 22563.610] (EE) 9: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f9e9ec6b90d]
[ 22563.610] (EE) 10: /usr/bin/X (0x400000+0x29e81) [0x429e81]
[ 22563.610] (EE) 
[ 22563.610] (EE) Segmentation fault at address 0x24c7000
[ 22563.610] 
Fatal server error:
[ 22563.610] Caught signal 11 (Segmentation fault). Server aborting
[ 22563.610] 
[ 22563.610] (EE) 

Here is a link to a complete X-server log: http://bpaste.net/show/76453/
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-10 19:17:50 UTC
Please don't increase the importance field, this is for the maintainer. We have had someone with this issue earlier, and he also used nouveau; as a result, I am generalizing this bug against xorg-server and xf86-video-nouveau.
Comment 2 woddfellow2 2013-02-10 19:26:33 UTC
Created attachment 338542 [details]
dmesg output
Comment 3 woddfellow2 2013-02-10 19:27:16 UTC
Created attachment 338544 [details]
/var/log/Xorg.0.log
Comment 4 woddfellow2 2013-02-10 19:28:43 UTC
I have the same problem. If I attempt to view a large image in Firefox,
the next thing I see is tty1. If I start X again, and then attempt to
start Firefox again, it freezes, followed by a garbled display. I must
then do a physical reboot.

Portage 2.1.11.50 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.7.6-gentoo-gnu x86_64)
=================================================================
System uname: Linux-3.7.6-gentoo-gnu-x86_64-AMD_Sempron-tm-_Processor_LE-1300-with-gentoo-2.1
KiB Mem:     3015584 total,   2721808 free
KiB Swap:    6291452 total,   6291452 free
Timestamp of tree: Sat, 09 Feb 2013 10:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE freedist"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.hoobly.com/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net http://gentoo.osuosl.org/ http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ http://mirror.iawnet.sandia.gov/gentoo/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.llarian.net/ ftp://gentoo.mirrors.tds.net/gentoo rsync://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.lug.udel.edu/pub/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ rsync://gentoo.cs.uni.edu/gentoo-distfiles http://gentoo.cs.uni.edu/ http://mirror.usu.edu/mirrors/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="256-color X acl alsa amd64 apng berkdb bzip2 cli cracklib crypt curl cxx deblob dri fbcondecor fortran gdbm gif gpg gpm gtk iconv imap imlib ipv6 iso14755 jpeg kdrive mmx modules mudflap multilib ncurses nls nptl ogg openmp pam pcre perl php png python readline ruby session sse sse2 ssl tcpd tiff udevlibkms unicode vim-syntax webp xa zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-10 22:30:27 UTC
I have seen reports that nouveau has sometimes problems with images which are too large (uncompressed) to fit in video memory. But it is probably best if you report this bug upstream at https://bugs.freedesktop.org/

You might be asked to submit a proper backtrace, http://wiki.x.org/wiki/Development/Documentation/ServerDebugging has instructions how to obtain it.
Comment 6 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-04-25 13:51:52 UTC
- Does this still happen with the latest version of both packages?

- Have you reported this upstream?

  If so, can you link us to that bug such that we can track it?
Comment 7 Vladimir 2013-04-25 15:11:12 UTC
(In reply to comment #6)
> - Does this still happen with the latest version of both packages?
> 
> - Have you reported this upstream?
> 
>   If so, can you link us to that bug such that we can track it?
Currenlty I have x11-base/xorg-server-1.14.1 and x11-drivers/xf86-video-nouveau-1.0.7 packages installed, and I can open the mentioned example images with Ristretto with no crashes.

I did not report it upstream, but here is a similar bugreport: https://bugs.freedesktop.org/show_bug.cgi?id=61069
Comment 8 Matt Turner gentoo-dev 2015-02-22 22:00:42 UTC
Hopefully long since fixed. If not please file a bug upstream.