Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455576 - dev-haskell/vty with sys-libs/ncurses[tinfo] - /usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4et_info': (.text+0x5fe): undefined reference to `tigetnum'
Summary: dev-haskell/vty with sys-libs/ncurses[tinfo] - /usr/lib64/terminfo-0.3.2.5/gh...
Status: RESOLVED DUPLICATE of bug 454216
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-05 10:18 UTC by Maciej Piechotka
Modified: 2013-02-21 21:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2013-02-05 10:18:09 UTC
Loading package parallel-3.2.0.3 ... linking ... done.
Loading object (static) dist/build/vty-interactive-terminal-test/vty-interactive-terminal-test-tmp/cbits/gwinsz.o ... done
Loading object (static) dist/build/vty-interactive-terminal-test/vty-interactive-terminal-test-tmp/cbits/set_term_timing.o ... done
Loading object (static) dist/build/vty-interactive-terminal-test/vty-interactive-terminal-test-tmp/cbits/mk_wcwidth.o ... done
final link ... done
Linking dist/build/vty-interactive-terminal-test/vty-interactive-terminal-test ...
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4et_info':
(.text+0x5fe): undefined reference to `tigetnum'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4fL_info':
(.text+0x7be): undefined reference to `tigetflag'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4h3_info':
(.text+0x976): undefined reference to `tigetstr'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4if_info':
(.text+0xb1a): undefined reference to `tputs'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4xI_info':
(.text+0x1d28): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yh_info':
(.text+0x1f34): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yi_info':
(.text+0x200a): undefined reference to `setupterm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yk_info':
(.text+0x20b1): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yt_info':
(.text+0x2268): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yv_info':
(.text+0x22e0): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4ye_info':
(.text+0x2322): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4yn_info':
(.text+0x23f0): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4Lm_info':
(.text+0x2d72): undefined reference to `set_curterm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4Lp_info':
(.text+0x2ec8): undefined reference to `set_curterm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4Lp_info':
(.text+0x2f95): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s4RE_info':
(.text+0x35eb): undefined reference to `tparm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s5dt_info':
(.text+0x518e): undefined reference to `set_curterm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s5df_info':
(.text+0x53ec): undefined reference to `set_curterm'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `s5dh_info':
(.text+0x54cc): undefined reference to `cur_term'
/usr/lib64/terminfo-0.3.2.5/ghc-7.6.2/libHSterminfo-0.3.2.5.a(Base.o): In function `r3Rk_closure':
(.data+0x88): undefined reference to `del_curterm'
collect2: ld returned 1 exit status
 * ERROR: dev-haskell/vty-4.7.2 failed (compile phase):
 *   setup build failed
 *
Comment 1 Reinis Danne 2013-02-10 19:32:51 UTC
This is a duplicate of bug #454216.
Comment 2 Sergei Trofimovich gentoo-dev 2013-02-13 21:31:48 UTC
How does your

   emerge --info sys-libs/ncurses

look like?
Comment 3 Sergei Trofimovich gentoo-dev 2013-02-21 21:02:33 UTC
Assuming it's a dup of #454216 as Reinis found out.
Maciej was noticed using dev-util/nvidia-cuda-toolkit which requires ncurses[tinfo] :]

*** This bug has been marked as a duplicate of bug 454216 ***