Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454216 - dev-haskell/terminfo with sys-libs/ncurses[tinfo] - configure: error: curses library not found, so this package cannot be built
Summary: dev-haskell/terminfo with sys-libs/ncurses[tinfo] - configure: error: curses ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL: http://hackage.haskell.org/trac/ghc/t...
Whiteboard:
Keywords:
: 455106 455576 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-01-26 21:28 UTC by Reinis Danne
Modified: 2013-02-21 21:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
terminfo-build.log.gz (terminfo-build.log.gz,3.15 KB, application/x-gzip)
2013-01-26 21:29 UTC, Reinis Danne
Details
terminfo config.log (terminfo-config.log,17.00 KB, text/plain)
2013-02-10 07:39 UTC, Reinis Danne
Details
fix build against ncurses[tinfo] (terminfo-0.3.2.5-ncurses_tinfo.patch,600 bytes, patch)
2013-02-10 09:30 UTC, Reinis Danne
Details | Diff
fix build and linking against ncurses[tinfo] (terminfo-0.3.2.5-ncurses_tinfo.patch,822 bytes, patch)
2013-02-10 11:35 UTC, Reinis Danne
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Reinis Danne 2013-01-26 21:28:23 UTC
With ncurses[tinfo] it fails to configure while with ncurses[-tinfo] it configures and builds successfully.

Reproducible: Always

Steps to Reproduce:
1. USE=tinfo emerge -1 sys-libs/ncurses
2. emerge -1 dev-haskell/terminfo

Actual Results:  
Fails to configure terminfo claiming that curses library could not be found.


Portage 2.1.11.50 (default/linux/amd64/10.0/desktop/gnome, gcc-4.7.2, glibc-2.16.0, 3.7.2-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-2630QM_CPU_@_2.00GHz-with-gentoo-2.2
KiB Mem:     8078892 total,    925080 free
KiB Swap:    2047996 total,   2017944 free
Timestamp of tree: Sat, 26 Jan 2013 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 science gamerlay bumblebee slyfox-gentoo dmol local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=""
FCFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -mtune=native -O3 -pipe -ggdb"
GENTOO_MIRRORS="http://gentoo.tups.lv/source/ "
LANG="lv_LV.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /var/lib/layman/gamerlay /var/lib/layman/bumblebee /var/lib/layman/slyfox /var/lib/layman/dmol /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 avx bash-completion berkdb bluetooth branding bzip2 cairo cdda cdio cdr cjk cleartype cli colord consolekit cracklib crypt cups cxx dbus dirac djvu dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg fftw firefox flac fontconfig fortran gdbm gif gnome gnome-keyring gnome-online-accounts gphoto2 gpm gsm gstreamer gtk gtk3 iconv idn ipv6 jpeg kate lcms ldap libcaca libnotify live mad matroska mmx mng modules mp3 mp4 mpeg mtp mudflap multilib musepack nautilus ncurses networkmanager nls nptl ogg openexr opengl openmp opus pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 raw readline schroedinger sdl session smp socialweb speex spell sse sse2 sse41 sse4_1 ssl ssse3 startup-notification svg system-sqlite tcpd theora tiff truetype udev udisks unicode upower usb v4l v4l2 vaapi vorbis vpx wmf wxwidgets x264 xcb xetex xml xmp xpm xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1018" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="lv en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="dummy fbdev i965 intel nouveau nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-libs/ncurses-5.9-r2 was built with the following:
USE="cxx gpm (multilib) tinfo unicode -ada -debug -doc -minimal -profile -static-libs -trace"
Comment 1 Reinis Danne 2013-01-26 21:29:18 UTC
Created attachment 336940 [details]
terminfo-build.log.gz
Comment 2 Sergei Trofimovich gentoo-dev 2013-01-28 18:10:35 UTC
> configure: error: in `/var/tmp/portage/dev-haskell/terminfo-0.3.2.5/work/terminfo-0.3.2.5':
> configure: error: curses library not found, so this package cannot be built
See `config.log' for more details

It's likely due to USE=-unicode.

May I ask you to attach config.log to make sure?
Comment 3 Jeroen Roovers gentoo-dev 2013-02-05 12:44:08 UTC
*** Bug 455106 has been marked as a duplicate of this bug. ***
Comment 4 Reinis Danne 2013-02-10 07:39:21 UTC
Created attachment 338474 [details]
terminfo config.log
Comment 5 Reinis Danne 2013-02-10 09:30:08 UTC
Created attachment 338482 [details, diff]
fix build against ncurses[tinfo]

Proper fix would probably to use pkg-config, but I don't know enough of autofoo to fix it. Also would need to check if the package builds and links correctly, I have just tested that it configures and builds.
Comment 6 Reinis Danne 2013-02-10 11:35:27 UTC
Created attachment 338488 [details, diff]
fix build and linking against ncurses[tinfo]

Updated the patch, now Darcs builds successfully. Still, the proper fix would be to use pkg-config.
Comment 7 Sergei Trofimovich gentoo-dev 2013-02-10 13:51:23 UTC
[CCed base-system@]

In light of USE=tinfo description looks like failure to export the same symbols
is ncurses bug?

        <flag name='tinfo'>
                Build curses library (libncurses) sep from the low-level terminfo
                library (libtinfo) -- usually needed only for binary packages -- but
                it is binary compatible in either mode
        </flag>
Comment 8 Sergei Trofimovich gentoo-dev 2013-02-10 14:01:42 UTC
I don't see how pkg-config will help to save the system from breakage
when you rebuild from USE=-tinfo ncurses to USE=tinfo ncurses.

It does not change .so's ABI on that action, does it?
Comment 9 Reinis Danne 2013-02-10 16:40:48 UTC
With ncurses[-tinfo] all the symbols from libtinfo.so are in libncurses.so, so one needs to link just with -lncurses, but with ncurses[tinfo] the symbols are in two libraries and have to link with -lncurses -ltinfo. pkg-config gives needed values:
With ncurses[-tinfo]
$ pkg-config --libs ncurses
-lncurses

With ncurses[tinfo]
$ pkg-config --libs ncurses
-lncurses -ltinfo

This way the right libs are linked. Moreover, pkg-config is supposed to be preferred over AC_CHECK_LIB:
http://blog.flameeyes.eu/2008/04/i-consider-ac_check_lib-harmful
Comment 10 Sergei Trofimovich gentoo-dev 2013-02-13 21:28:26 UTC
(In reply to comment #9)
> With ncurses[-tinfo] all the symbols from libtinfo.so are in libncurses.so,
> so one needs to link just with -lncurses, but with ncurses[tinfo] the
> symbols are in two libraries and have to link with -lncurses -ltinfo.
> pkg-config gives needed values:
> With ncurses[-tinfo]
> $ pkg-config --libs ncurses
> -lncurses
> 
> With ncurses[tinfo]
> $ pkg-config --libs ncurses
> -lncurses -ltinfo
> 
> This way the right libs are linked. Moreover, pkg-config is supposed to be
> preferred over AC_CHECK_LIB:
> http://blog.flameeyes.eu/2008/04/i-consider-ac_check_lib-harmful

What will happen with your binaries if you build a program
against 'USE=tinfo ncurses' and then rebuild 'USE=-tinfo ncurses' in system?

One state is more fragile for building/distributing binaries,
than another.

Anyways, picked upstream patch.

> 13 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
>  +files/terminfo-0.3.2.5-tinfo.patch, -terminfo-0.3.1.1.ebuild,
>  -terminfo-0.3.1.3.ebuild, terminfo-0.3.2.5.ebuild:
>  Fixed build failure against 'USE=tinfo ncurses' in bug #454216 by Reinis
>  Danne.

Thanks for the report and explanation!
Comment 11 Sergei Trofimovich gentoo-dev 2013-02-21 21:02:33 UTC
*** Bug 455576 has been marked as a duplicate of this bug. ***