Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455320 - net-wireless/blueman-1.23-r2 - blueman crashes when theme misses icon gtk-missing-image
Summary: net-wireless/blueman-1.23-r2 - blueman crashes when theme misses icon gtk-mis...
Status: RESOLVED DUPLICATE of bug 445966
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 17:04 UTC by tbartdev
Modified: 2014-12-07 19:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tbartdev 2013-02-03 17:04:19 UTC
starting blueman-applet on an e17 system without gnome icon themes installed is impossible. it errors out because of missing icons.

this should not happen. a system-wide fallback for icons that cannot be found to the ones corresponding in the installed icon theme would be perfect and needed anyhow. maybe there exists a solution for this already, but none that i know of. the motivation for using blueman over gnome or kde specific stuff often might be because of avoiding bloat. installing gnome icons for blueman to run is somewhat .. er .. counterproductive.
if this is indeed necessary, a RDEPEND has to be added to the ebuild.

upstream bug:
https://bugs.launchpad.net/blueman/+bug/1037216

debian seems to already have fixed this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631838



tbart@blackknight ~ $ blueman-applet
Loading configuration plugins
blueman-applet version 1.23 starting
Stale PID, overwriting
Using file config backend
_________
Load (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:68)
['NetUsage', 'Networking', 'SerialManager', 'DiscvManager', 'Menu', 'ExitItem', 'PPPSupport', 'AuthAgent', 'StatusIcon', 'DBusService', 'Headset', 'ShowConnected', 'NMDUNSupport', 'PulseAudio', 'StandardItems', 'TransferService', 'KillSwitch', 'DhcpClient', 'RecentConns', 'AppIndicator', 'NMPANSupport', 'PowerManager'] 
Using file config backend
_________
Load (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:68)
Unable to load plugin module AppIndicator
No module named appindicator 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.StatusIcon.StatusIcon'> 
Using file config backend
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.DBusService.DBusService'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.Headset.Headset'> 
Using file config backend
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.Networking.Networking'> 
Using file config backend
_________
load_nap_settings (/usr/lib64/python2.7/site-packages/blueman/plugins/applet/Networking.py:47)
Loading NAP settings 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.NMDUNSupport.NMDUNSupport'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.Menu.Menu'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.NMPANSupport.NMPANSupport'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.PowerManager.PowerManager'> 
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/BasePlugin.py", line 65, in _load
    self.on_load(parent)
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/applet/PowerManager.py", line 53, in on_load
    self.item = create_menuitem(_("<b>Bluetooth Off</b>"), get_icon("gtk-stop", 16))
  File "/usr/lib64/python2.7/site-packages/blueman/Functions.py", line 183, in get_icon
    icon = ic.load_icon("gtk-missing-image", size, 0)
GError: Icon 'gtk-missing-image' not present in theme
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Failed to load PowerManager
Icon 'gtk-missing-image' not present in theme 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Icon 'gtk-missing-image' not present in theme 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.AuthAgent.AuthAgent'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.ShowConnected.ShowConnected'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Not loading DhcpClient because it's conflict has higher priority 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.TransferService.TransferService'> 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.DiscvManager.DiscvManager'> 
Using file config backend
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/BasePlugin.py", line 65, in _load
    self.on_load(parent)
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/applet/DiscvManager.py", line 46, in on_load
    self.item = create_menuitem(_("_Make Discoverable"), get_icon("gtk-find", 16))
  File "/usr/lib64/python2.7/site-packages/blueman/Functions.py", line 183, in get_icon
    icon = ic.load_icon("gtk-missing-image", size, 0)
GError: Icon 'gtk-missing-image' not present in theme
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Failed to load DiscvManager
Icon 'gtk-missing-image' not present in theme 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.RecentConns.RecentConns'> 
Using file config backend
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Not loading PPPSupport because it's conflict has higher priority 
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.applet.StandardItems.StandardItems'> 
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/BasePlugin.py", line 65, in _load
    self.on_load(parent)
  File "/usr/lib64/python2.7/site-packages/blueman/plugins/applet/StandardItems.py", line 38, in on_load
    self.new_dev = create_menuitem(_("_Setup New Device")+"...", get_icon("gtk-new", 16))
  File "/usr/lib64/python2.7/site-packages/blueman/Functions.py", line 183, in get_icon
    icon = ic.load_icon("gtk-missing-image", size, 0)
GError: Icon 'gtk-missing-image' not present in theme
_________
__load_plugin (/usr/lib64/python2.7/site-packages/blueman/main/PluginManager.py:142)
Failed to load StandardItems
Icon 'gtk-missing-image' not present in theme
Comment 1 tbartdev 2013-02-03 17:43:10 UTC
Just as a FYI for users being affected:

I also use gtk-engines-qtcurve, so if you do so as well, you'll have to adapt it to include some theme containing gtk-* icon names...

for example

$ cat ~/.gtkrc.mine 
gtk-icon-theme-name="<your theme that contains gtk-* icons>"

This might help to just change it for one application (blueman, that is..):

# cat /usr/local/share/themes/mybluemangtkrc 
gtk-icon-theme-name = "<your theme that contains gtk-* icons>"
gtk-fallback-icon-theme="<your theme that contains gtk-* icons>"

# cat /usr/local/bin/bluemanwrapper 
GTK2_RC_FILES=/usr/local/share/themes/mybluemangtkrc /usr/bin/$(basename $0)

# for app in blueman-adapters blueman-assistant blueman-manager blueman-services blueman-applet blueman-browse blueman-sendto; do ln -s /usr/local/bin/bluemanwrapper /usr/bin/$app; done

Now you can start blueman-* apps by using /usr/local/bin/blueman-*
(Strange: "Real" files in /usr/local/bin have precedence over those in /usr/bin if your PATH is configured correctly, but links do not..)
Comment 2 Jan Buecken 2013-02-25 22:22:15 UTC
This is a dublicate of 445966 (Reported: 2012-12-04). But this bug is more detailed. 

I can confirm this problem (xfce user with tango-icon-theme).

My opinion:
Until this is fixed upstream gnome-icon-theme should be a runtime dependency.
Comment 3 michal.halenka 2014-07-19 12:56:37 UTC
Confirming and agree
Comment 4 Gino McCarty 2014-10-12 03:23:21 UTC
FYI

I'm on the dev team, tracking this upstream here:

https://github.com/blueman-project/blueman/issues/112
Comment 5 Maxim Koltsov gentoo-dev 2014-12-07 19:13:19 UTC

*** This bug has been marked as a duplicate of bug 445966 ***