Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445966 - net-wireless/blueman should unconditionally depend on x11-themes/gnome-icon-theme?
Summary: net-wireless/blueman should unconditionally depend on x11-themes/gnome-icon-t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tiziano Müller (RETIRED)
URL:
Whiteboard:
Keywords:
: 455320 496324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-04 19:11 UTC by davepiiiiii
Modified: 2014-12-07 19:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davepiiiiii 2012-12-04 19:11:05 UTC
I emerged bluman on kde desktop profile with kde and -gnome use flags and i couldn't launch it due to lack of icons. I had to manually emerge gnome-icon-theme package to launch it. So in my opinion you should add this package to runtime dependecy section in ebuilds. Version of blueman and gnome-icon-theme:

--> =net-wireless/blueman-1.23-r2
--> =x11-themes/gnome-icon-theme-3.4.0


-->output of emerge --info:

Portage 2.1.11.31 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo x86_64)
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-2670QM_CPU_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Tue, 04 Dec 2012 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.6
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo poly-c
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.po.opole.pl ftp://ftp.vectranet.pl/gentoo/  http://ftp.heanet.ie/pub/gentoo/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ ftp://mirror.cambrium.nl/pub/os/linux/gentoo/ ftp://mirror.opteamax.de/gentoo/ http://ftp.heanet.ie/pub/gentoo/"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/poly-c"
SYNC="rsync://rsync.pl.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi aes alsa amd64 amr apache2 aperfmperf apic arat arch_perfmon avx bash-completion bcmath berkdb bluetooth bluray branding bsf bts bzip2 cairo calendar cdda cddb cdr cjk clamav clflush cli cmov consolekit constant_tsc cracklib crypt css ctype cups cx16 cx8 cxx dbus de declarative dga djvu dri ds_cpl dtes64 dtherm dts dv dvb dvd dvdr ebook emboss encode enscript epb ept est examples exif expat fam fbcon ffmpg firefox flac flexpriority fontconfig foomaticdb fortran fpu ftp fxsr g3dvl gadu gcj gd gdbm gif gimp git glamor gpg gphoto2 gpm graphviz gsl gstreamer gtk gtkstyle gzip handbook hddtemp hscolour ht iconv icq icu ida idn imap inifile inotify ipv6 jack javascript jpeg kde kerberos kipi lahf_lm lame lcms ldap libcaca libnotify libwww lm mad matroska matrox mca mce mime mmap mms mmx mng modules monitor mp3 mp4 mpeg mplayer msql msr mtrr mudflap multilib mysql mysqli nas ncurses nls nocd nonstop_tsc nopl nptl nsplugin nss nx ogg opencl opengl openmp pae pam pango pat pbe pch pcid pclmulqdq pcmcia pcre pda pdcm pdf pebs perl pge phonon php plasma pln png pni policykit popcnt posix ppds pppd pse pse36 pts pulseaudio python qt3support qt4 raw rdesktop rdtscp readline rep_good rss ruby samba sasl scanner sdl semantic-desktop sep session smartcard smp snmp sockets sound source spell ss sse sse2 sse4_1 sse4_2 ssl ssse3 startup-notification startup-notofication subversion svg symlink syscall syslog tcpd threads tidy tiff tls tm tm2 tpr_shadow truetype tsc tsc_deadline_timer udev udisks unicode upower usb uxa v4l vcd videos vim-syntax vme vmx vnmi vorbis vpid wavpack wifi wxwidgets x264 x2apic xcb xcomposite xine xinerama xml xmp xmpp xsave xsaveopt xscreensaver xtopology xtpr xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en en_US en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="i386 x86_64 unicore32" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel nvidia i965 i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jan Buecken 2013-02-25 22:23:10 UTC
plz see bug 455320 too
Comment 2 Gino McCarty 2014-05-05 17:22:34 UTC
this bug is invalid IMHO..

deferentially operates fine with just hicolor theme..
the other referenced bug issue has already been patched upstream..

been working with blueman for some time without gnome themes without any issues.
Comment 3 Gino McCarty 2014-05-05 17:23:20 UTC
*definitely.. uggg sry
Comment 4 Maxim Koltsov gentoo-dev 2014-12-07 19:13:19 UTC
*** Bug 455320 has been marked as a duplicate of this bug. ***
Comment 5 Maxim Koltsov gentoo-dev 2014-12-07 19:13:29 UTC
*** Bug 496324 has been marked as a duplicate of this bug. ***
Comment 6 Maxim Koltsov gentoo-dev 2014-12-07 19:19:39 UTC
Fix is merged to master some days ago, yay. Until it gets into release I've added gnome-icon-theme as runtime dependency.