Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455288 - kde-base/kdm: please provide a systemd service file
Summary: kde-base/kdm: please provide a systemd service file
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on: 391339
Blocks: install-systemd-unit
  Show dependency tree
 
Reported: 2013-02-03 15:09 UTC by Mario Kicherer
Modified: 2013-04-29 18:04 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kdm.service (kdm.service,262 bytes, text/plain)
2013-02-15 17:35 UTC, RedEyedMan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Kicherer 2013-02-03 15:09:19 UTC
It would be nice if kdm would provide a systemd service file. I currently use the one from systemd-overlay [1] and it works fine. As I learned, gentoo-kde people are not excited about systemd but afaik it only requires this one file, it would help people that like to test systemd and it should not interfere with startup on non-systemd systems.

[1] http://git.overlays.gentoo.org/gitweb/?p=user/systemd.git;a=blob;f=sys-apps/systemd-units/files/services-desktop/kdm.service;h=412ffa394ff565432a3a8eb63c2db303af0aee42;hb=HEAD

Reproducible: Always
Comment 1 Michael Palimaka (kensington) gentoo-dev 2013-02-06 06:21:43 UTC
Which package should install this file and where should it be installed to?
If it is working for you we could send it upstream.
Comment 2 Mario Kicherer 2013-02-06 10:04:24 UTC
It would be nice if kde-base/kdm would install http://git.overlays.gentoo.org/gitweb/?p=user/systemd.git;a=blob;f=sys-apps/systemd-units/files/services-desktop/kdm.service;h=412ffa394ff565432a3a8eb63c2db303af0aee42;hb=HEAD as "kdm.service" into the default directory "/usr/lib/systemd/system/".

There is a related bug #391339 but I can not confirm this behavior on my AMD64 system. Here, it works fine.

Thank you!
Comment 3 Henry Gebhardt 2013-02-06 22:47:38 UTC
Generally, it should be kde-base/kdm that provides its own service file, installed with the systemd eclass.

Now, since I don't use kdm myself, I don't know how correct or current the service file in the systemd-overlay is, but you are welcome to submit it upstream.
Comment 4 RedEyedMan 2013-02-15 17:35:02 UTC
Created attachment 339000 [details]
kdm.service

Added from Unoficial Gentoo Wiki
Comment 5 Dennis Schridde 2013-04-03 01:16:27 UTC
(In reply to comment #4)
> Created attachment 339000 [details]
> kdm.service
> 
> Added from Unoficial Gentoo Wiki

That is exactly the one available in sys-apps/systemd-units-5 from the systemd-overlay.
Comment 6 David Heidelberg (okias) 2013-04-08 21:31:02 UTC
Hey guys.

Could be great if kdm-4.10.2 had this file included. It doesn't require much work and it fixes actual issue (and maintain all kdm files together).

So, please do it.

David
Comment 7 Fabio Erculiani (RETIRED) gentoo-dev 2013-04-15 16:42:04 UTC
FYI, the systemd-love overlay has a kde-base/kdm ebuild containing kdm.service.
Comment 8 Andreas K. Hüttel gentoo-dev 2013-04-29 18:04:30 UTC
This file added in 4.10.2-r1 and later. Please file new bugs if problems occur.