Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 391339 - =kde-base/kdm-4.10.2-r1 - systemd service takes long to stop waiting for ssh-agent
Summary: =kde-base/kdm-4.10.2-r1 - systemd service takes long to stop waiting for ssh-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: fixed in 4.11?
Keywords:
: 415365 (view as bug list)
Depends on:
Blocks: 455288
  Show dependency tree
 
Reported: 2011-11-22 07:49 UTC by Maksim 'max_posedon' Melnikau
Modified: 2013-08-21 07:06 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim 'max_posedon' Melnikau 2011-11-22 07:49:30 UTC
systemd don't stops kdm succesffully
most time it kills kdm after 30s timeout
Because of this reboot too long.

I don't know to correctly collect systemd logs, plz help with with instructions which can help you.

Reproducible: Always

Steps to Reproduce:
1. install systemd
2. enable kdm.service
3. KMenu-Restart
Actual Results:  
reboot takes too long

Expected Results:  
reboot should be very fast

 # emerge --info
Portage 2.1.10.36 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.1, glibc-2.13-r4, 3.1.1-gentoo x86_64)
=================================================================
System uname: Linux-3.1.1-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_M_430_@_2.27GHz-with-gentoo-2.1
Timestamp of tree: Sat, 19 Nov 2011 11:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.4-r2, 4.5.3-r1, 4.6.1-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise systemd qting-edge local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -Os -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -Os -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/systemd /var/lib/layman/qting-edge /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups curl cxx dbus declarative djvu dri dts dv dvd dvdr emboss encode exif fam ffmpeg firefox flac ftp gdbm gdu gif gnome-keyring gnutls gpm gps gsm gstreamer iconv icu imagemagick ios ipod ipv6 jingle jpeg jpeg2k kde kipi lame latex lcms ldap libcaca libnotify lm_sensors lzma lzo mad mmx mng modules mp3 mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses netboot networkmanager nls nptl nptlonly ogg openal opengl openmp oscar pam pango pcre pdf phonon plasma png policykit portaudio postgres ppds pppd pulseaudio qt3support qt4 rdesktop readline ruby samba sdl semantic-desktop session smp speex spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs taglib tcpd theora tiff truetype udev unicode usb v4l v4l2 vaapi vim-syntax vnc vorbis wifi x264 xcb xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid zeroconf zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon dummy fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dennis Schridde 2012-05-10 12:48:37 UTC
(copied from bug #415365)
When I try to reboot, X (KDM) will shutdown and I will only see a blinking cursor on the VT afterwards - no reboot happens.

I am using an initramfs generated by sys-kernel/dracut-018.

Please tell me which additional information is helpful/required, since I am new to systemd.

Portage 2.2.0_alpha103 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r1, 3.3.4-gentoo x86_64)                                                                                                                            [16/83]
=================================================================
System uname: Linux-3.3.4-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.1
Timestamp of tree: Thu, 10 May 2012 11:15:01 +0000
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo systemd local kde sunrise g-ctan
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep
-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check n --with-bdeps y --keep-going"
FEATURES="assume-digests binpkg-logs compressdebug distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch
 userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/layman/systemd /var/cache/portage/local /var/cache/portage/overlays/kde /var/cache/portage/overlays/sunrise /var/lib/g-ctan"
[...]
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Dennis Schridde 2012-05-10 12:48:46 UTC
*** Bug 415365 has been marked as a duplicate of this bug. ***
Comment 3 Henry Gebhardt 2012-05-10 19:04:17 UTC
I don't use kdm, so I need some more info on how to stop it.

Does kdm have a specific binary such as /usr/sbin/kdm-stop (like gdm)?
Or does it need a specific signal (KillSignal=SIGQUIT, like lightdm)?

Christian, since you added it to the overlay, feel free to take over.
Comment 4 Dennis Schridde 2012-05-10 19:17:43 UTC
(In reply to comment #3)
> Does kdm have a specific binary such as /usr/sbin/kdm-stop (like gdm)?
> Or does it need a specific signal (KillSignal=SIGQUIT, like lightdm)?
There exists a binary named "kdmctl" which appears to do the required job ("suicide"): http://manpages.ubuntu.com/manpages/jaunty/man1/kdmctl.1.html
Comment 5 Dennis Schridde 2012-05-11 09:48:23 UTC
(In reply to comment #1)
> (copied from bug #415365)
> When I try to reboot, X (KDM) will shutdown and I will only see a blinking
> cursor on the VT afterwards - no reboot happens.
(Good?) News: It appears that KDM shutdown broke completely now. When I select "shutdown" from the KDE logout/shutdown/reboot menu (when logged in), it will only log me out. However, when I select shutdown from the KDM menu (i.e. when not logged in), the computer initiates the shutdown immediately.

Notable changes since last time: I moved pam_systemd from system-login to system-auth in pam.d, since KDM (using kde and kde-np pam.d files) does not honor system-login.
Comment 6 Dennis Schridde 2012-05-21 07:35:46 UTC
(In reply to comment #5)
> (In reply to comment #1)
> > (copied from bug #415365)
> > When I try to reboot, X (KDM) will shutdown and I will only see a blinking
> > cursor on the VT afterwards - no reboot happens.
> (Good?) News: It appears that KDM shutdown broke completely now. When I
> select "shutdown" from the KDE logout/shutdown/reboot menu (when logged in),
> it will only log me out.
This is correct, and still reproducible.

> However, when I select shutdown from the KDM menu
> (i.e. when not logged in), the computer initiates the shutdown immediately.
This appears to have been a one-time effect. Now, when I select shutdown from the KDM menu, the computer still waits for tens of seconds with a console prompt before it actually shuts down.
Comment 7 Henry Gebhardt 2012-05-21 12:16:31 UTC
(In reply to comment #4)
> There exists a binary named "kdmctl" which appears to do the required job
> ("suicide"): http://manpages.ubuntu.com/manpages/jaunty/man1/kdmctl.1.html

Where is kdmctl located? I am guessing /usr/sbin/kdmctl?

I just pushed a change for this to the overlay. Please test.
Comment 8 Dennis Schridde 2012-05-21 13:00:33 UTC
(In reply to comment #7)
> (In reply to comment #4)
> > There exists a binary named "kdmctl" which appears to do the required job
> > ("suicide"): http://manpages.ubuntu.com/manpages/jaunty/man1/kdmctl.1.html
> 
> Where is kdmctl located? I am guessing /usr/sbin/kdmctl?
$ which kdmctl
/usr/bin/kdmctl
Comment 9 Henry Gebhardt 2012-05-21 16:18:28 UTC
(In reply to comment #8)
> /usr/bin/kdmctl

Thanks, corrected.
Comment 10 Dennis Schridde 2012-05-25 00:18:35 UTC
(In reply to comment #7)
> I just pushed a change for this to the overlay. Please test.
That didn't change anything. :( Please reopen.

Behaviour is still as follows:
1) I click shutdown within KDE
2) KDE exits to KDM, but does not shut down
3) I click shutdown within KDM
4) KDM exits (?) and I am brought to an empty screen with just the prompt cursor blinking
5) For maybe a minute nothing happens
6) Some unmounting-this-and-that messages appear (probably Dracut)
7) System is shut down

How do I properly debug this, to find out what is actually going on while I see the prompt?
Comment 11 Henry Gebhardt 2012-05-25 21:28:46 UTC
(In reply to comment #10)
> How do I properly debug this, to find out what is actually going on while I
> see the prompt?

What is the output of "systemctl status kdm@tty7.service" ?

Also, you can check the output of

    sudo systemd-journalctl _SYSTEMD_UNIT=kdm@tty7.service

You need to create /var/log/journal/ before so that the messages persist after the reboot.

It is also possible that kdm has a log file like /var/log/kdm.log that you could check.

Is the man-page of comment #4 up-to-date?

Instead of ExecStop=... you could experiment with "KillSignal=SIGQUIT". See "man 7 signal" for more possible signals.

Sorry, pretty much guess-work on my part. HTH.
Comment 12 Dennis Schridde 2012-05-28 18:48:37 UTC
One general request: Could you make sys-apps/systemd-units versioned? That would make updating it easier and allow one to see when there were changes. In addition it would be possible to refer to a specific version when reporting bugs.

(In reply to comment #11)
> (In reply to comment #10)
> > How do I properly debug this, to find out what is actually going on while I
> > see the prompt?
> 
> What is the output of "systemctl status kdm@tty7.service" ?
# systemctl status kdm@tty7.service
kdm@tty7.service - KDE Display Manager on tty7
          Loaded: loaded (/usr/lib/systemd/system/kdm@.service; enabled)
          Active: active (running) since Mon, 28 May 2012 20:03:46 +0200; 14min ago
        Main PID: 2446 (kdm)
          CGroup: name=systemd:/system/kdm@.service/tty7
                  ├ 2446 /usr/bin/kdm -nodaemon tty7
                  ├ 2460 /usr/bin/X -br -novtswitch -quiet :0 vt7 -nolisten tcp -auth /var/run/xauth/A:0-gOatpc
                  └ 2561 ssh-agent -s

May 28 20:03:54 HHH kdm[2484]: :0[2484]: pam_unix(kde-np:session): session opened for user UUU by (uid=0)
May 28 20:03:54 HHH kdm[2484]: :0[2484]: pam_systemd(kde-np:session): Asking logind to create session: uid=1000 pid=2484 service=kde-np type=x11 seat=seat0 vtnr=7 tty= display=:0 remote=no remote_user= remote_host=

> Also, you can check the output of
> 
>     sudo systemd-journalctl _SYSTEMD_UNIT=kdm@tty7.service
The part for the last session:
---
May 28 11:02:30 HHH kdm[2438]: :0[2438]: pam_unix(kde-np:session): session opened for user UUU by (uid=0)
May 28 11:02:30 HHH kdm[2438]: :0[2438]: pam_systemd(kde-np:session): Asking logind to create session: uid=1000 pid=2438 service=kde-np type=x11 seat=seat0 vtnr=7 tty= display=:0 remote=no remote_user= remote_host=
May 28 12:32:14 HHH shutdown[6684]: shutting down for system halt
---

> You need to create /var/log/journal/ before so that the messages persist
> after the reboot.
> 
> It is also possible that kdm has a log file like /var/log/kdm.log that you
> could check.
The XKEYBOARD keymap compiler (xkbcomp) reports: 
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
The last part seems to be:
---
Errors from xkbcomp are not fatal to the X server
klauncher(6678) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(6670)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

kdmgreet(6670)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
Server terminated successfully (0). Closing log file.
---
There are no timestamps, so knowing when one session ended is a bit difficult.

> Is the man-page of comment #4 up-to-date?
No idea. There is no manpage for it on my system.

> Instead of ExecStop=... you could experiment with "KillSignal=SIGQUIT". See
> "man 7 signal" for more possible signals.
> 
> Sorry, pretty much guess-work on my part. HTH.
systemd-journalctl:
---
[...]
May 28 12:32:07 HHH polkitd(authority=local)[2418]: Unregistered Authentication Agent for unix-session:c1 (system bus name :1.41, object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
May 28 12:32:09 HHH kdm[2438]: :0[2438]: pam_unix(kde-np:session): session closed for user UUU
May 28 12:32:09 HHH systemd-logind[2393]: Removed session c1.
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBu...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DB...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Er...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DB...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Er...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop....26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBu...26': no such name
May 28 12:32:09 HHH NetworkManager[2392]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedeskto...26': no such name
May 28 12:32:09 HHH acpid[2415]: client connected from 6665[0:0]
May 28 12:32:09 HHH acpid[2415]: 1 client rule loaded
[...]
May 28 12:32:14 HHH shutdown[6684]: shutting down for system halt
May 28 12:32:17 HHH systemd-initctl[6693]: Received environment initctl request. This is not implemented in systemd.
May 28 12:32:17 HHH fcron[2391]: SIGTERM signal received
May 28 12:32:17 HHH acpid[2415]: exiting
May 28 12:32:17 HHH NetworkManager[2392]: <info> caught signal 15, shutting down normally.
May 28 12:32:17 HHH NetworkManager[2392]: <warn> quit request received, terminating...
May 28 12:32:17 HHH NetworkManager[2392]: <info> (eth0): now unmanaged
May 28 12:32:17 HHH NetworkManager[2392]: <info> (eth0): device state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
May 28 12:32:17 HHH NetworkManager[2392]: <info> (eth0): cleaning up...
May 28 12:32:17 HHH NetworkManager[2392]: <info> (eth0): taking down device.
May 28 12:32:17 HHH fcron[2391]: Exiting with code 0
May 28 12:32:17 HHH dhcpcd[2426]: received SIGTERM, stopping
May 28 12:32:17 HHH dhcpcd[2426]: eth1: removing interface
May 28 12:32:17 HHH NetworkManager[2392]: <info> caught signal 15, shutting down normally.
May 28 12:32:17 HHH NetworkManager[2392]: <info> Clearing nscd hosts cache.
May 28 12:32:17 HHH NetworkManager[2392]: <info> exiting (success)
May 28 12:32:21 HHH fcron[2391]: 12:32:17 SIGTERM signal received
May 28 12:32:21 HHH fcron[2391]: 12:32:17 Exiting with code 0
May 28 12:32:21 HHH avahi-daemon[2423]: Got SIGTERM, quitting.
May 28 12:32:21 HHH avahi-daemon[2423]: Leaving mDNS multicast group on interface eth1.IPv6 with address III.
May 28 12:32:21 HHH avahi-daemon[2423]: Leaving mDNS multicast group on interface eth1.IPv4 with address III.
May 28 12:32:21 HHH avahi-daemon[2423]: avahi-daemon 0.6.30 exiting.
May 28 12:32:21 HHH kernel: zcache: destroyed pool id=5, cli_id=65535
May 28 12:32:21 HHH NetworkManager[2392]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
May 28 12:32:17 HHH systemd[1]: kdm@tty7.service: control process exited, code=exited status=1
May 28 12:32:21 HHH kdmctl[6695]: Cannot connect socket '/var/run/xdmctl/dmctl/socket'.
May 28 12:33:47 HHH systemd[1]: kdm@tty7.service stopping timed out (2). Killing.
May 28 12:33:47 HHH systemd[1]: Unit kdm@tty7.service entered failed state.
May 28 12:33:48 HHH umount[6735]: umount: /usr: device is busy.
May 28 12:33:48 HHH umount[6735]: (In some cases useful info about processes that use
May 28 12:33:48 HHH umount[6735]: the device is found by lsof(8) or fuser(1))
[...]
---

Notable lines:
May 28 12:32:17 HHH systemd-initctl[6693]: Received environment initctl request. This is not implemented in systemd.
[...]
May 28 12:32:17 HHH systemd[1]: kdm@tty7.service: control process exited, code=exited status=1
May 28 12:32:21 HHH kdmctl[6695]: Cannot connect socket '/var/run/xdmctl/dmctl/socket'.
May 28 12:33:47 HHH systemd[1]: kdm@tty7.service stopping timed out (2). Killing.

The kdmctl line probably means that kdmctl does not work in this case (maybe because the socket has another name?). This log is from an earlier run, where no ExecStop was set (kdmctl was not used):
---
May 23 17:47:57 HHH kdm[2319]: Cannot execute 'grub-reboot': not in $PATH.
May 23 17:47:58 HHH polkitd(authority=local)[2342]: Unregistered Authentication Agent for unix-session:c1 (system bus name :1.43, object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
May 23 17:47:59 HHH spideroak_inotify[2930]: Parent process gone: stopping
May 23 17:47:59 HHH spideroak_inotify[2930]: Program terminates normally
May 23 17:47:59 HHH kdm[2360]: :0[2360]: pam_unix(kde-np:session): session closed for user UUU
May 23 17:47:59 HHH systemd-logind[2314]: Removed session c1.
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBu...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBu...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DB...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Er...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DB...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Er...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop....26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBu...26': no such name
May 23 17:47:59 HHH NetworkManager[2313]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedeskto...26': no such name
May 23 17:47:59 HHH kdm[2319]: Server terminated successfully (0). Closing log file.
May 23 17:47:59 HHH acpid[2337]: client connected from 6467[0:0]
May 23 17:47:59 HHH acpid[2337]: 1 client rule loaded
May 23 17:47:59 HHH kernel: radeon 0000:03:00.0: evergreen_cs_track_validate_texture:796 texture bo too small (layer size 7526400, offset 0, max layer 1, depth 1, bo size 7299072) (1792 1050)
May 23 17:47:59 HHH kernel: [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
May 23 17:47:59 HHH kdm[2319]: The XKEYBOARD keymap compiler (xkbcomp) reports:
May 23 17:47:59 HHH kdm[2319]: > Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
May 23 17:47:59 HHH kdm[2319]: >                   Ignoring extra symbols
May 23 17:47:59 HHH kdm[2319]: Errors from xkbcomp are not fatal to the X server
May 23 17:48:00 HHH kdm[2319]: klauncher(6478) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
May 23 17:48:00 HHH kdm[2319]: kdeinit4: Communication error with launcher. Exiting!
May 23 17:48:00 HHH kdm[2319]: kdmgreet(6472)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"
May 23 17:48:00 HHH kdm[2319]: kdmgreet(6472)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
May 23 17:48:14 HHH kdm[2319]: Cannot execute 'grub-reboot': not in $PATH.
May 23 17:48:15 HHH kdm[2319]: Cannot execute 'grub-reboot': not in $PATH.
May 23 17:48:15 HHH kdm[2319]: Server terminated successfully (0). Closing log file.
May 23 17:48:15 HHH shutdown[6484]: shutting down for system halt
May 23 17:48:17 HHH systemd-initctl[6493]: Received environment initctl request. This is not implemented in systemd.
May 23 17:48:17 HHH fcron[2312]: SIGTERM signal received
May 23 17:48:17 HHH fcron[2312]: 17:48:17 SIGTERM signal received
May 23 17:48:17 HHH avahi-daemon[2346]: Got SIGTERM, quitting.
May 23 17:48:17 HHH avahi-daemon[2346]: Leaving mDNS multicast group on interface eth1.IPv6 with address III.
May 23 17:48:17 HHH avahi-daemon[2346]: Leaving mDNS multicast group on interface eth1.IPv4 with address III.
May 23 17:48:17 HHH acpid[2337]: exiting
May 23 17:48:17 HHH NetworkManager[2313]: <warn> disconnected by the system bus.
May 23 17:48:17 HHH NetworkManager[2313]: <info> caught signal 15, shutting down normally.
May 23 17:48:17 HHH NetworkManager[2313]: <warn> quit request received, terminating...
May 23 17:48:17 HHH NetworkManager[2313]: <info> (eth0): now unmanaged
May 23 17:48:17 HHH NetworkManager[2313]: <info> (eth0): device state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
May 23 17:48:17 HHH NetworkManager[2313]: <info> (eth0): cleaning up...
May 23 17:48:17 HHH NetworkManager[2313]: <info> (eth0): taking down device.
May 23 17:48:17 HHH fcron[2312]: Exiting with code 0
May 23 17:48:17 HHH NetworkManager[2313]: <info> Clearing nscd hosts cache.
May 23 17:48:17 HHH fcron[2312]: 17:48:17 Exiting with code 0
May 23 17:48:17 HHH NetworkManager[2313]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
May 23 17:48:17 HHH NetworkManager[2313]: <info> exiting (success)
May 23 17:48:17 HHH avahi-daemon[2346]: avahi-daemon 0.6.30 exiting.
May 23 17:48:17 HHH dhcpcd[2348]: received SIGTERM, stopping
May 23 17:48:17 HHH dhcpcd[2348]: eth1: removing interface
May 23 17:49:47 HHH systemd[1]: kdm@tty7.service stopping timed out (2). Killing.
May 23 17:49:47 HHH systemd[1]: Unit kdm@tty7.service entered failed state.
May 23 17:49:47 HHH sudo[3089]: pam_unix(sudo:session): session closed for user root
May 23 17:49:48 HHH umount[6524]: umount: /usr: device is busy.
May 23 17:49:48 HHH umount[6524]: (In some cases useful info about processes that use
May 23 17:49:48 HHH umount[6524]: the device is found by lsof(8) or fuser(1))
---
Comment 13 Jan Essert 2012-05-30 13:00:35 UTC
IMHO, this bug report mixes two issues, one of which I am also seeing:

The first one is that trying to shutdown the machine from a KDE session will only drop you back to kdm. I see that also, and it is probably related to pam_systemd. Any help on this would be really welcome, btw :)

The other issue is that shutting down from kdm afterwards takes really long for you. I do not see this.

Shall I open a different bug report for the first issue? (The problem here being of course, that I added pam_systemd manually to /etc/pam.d/system-auth..)
Comment 14 Dennis Schridde 2012-05-30 16:04:53 UTC
(In reply to comment #13)
> The first one is that trying to shutdown the machine from a KDE session will
> only drop you back to kdm. I see that also, and it is probably related to
> pam_systemd. Any help on this would be really welcome, btw :)
If you remove pam_systemd, this behaviour will be gone and clicking "shutdown" will actually shut down your computer. Obviously not using pam_systemd creates other problems.

> The other issue is that shutting down from kdm afterwards takes really long
> for you. I do not see this.
Interesting. Could you also post logs, kdmrc and whatever might be related? And which versions are you using?

> Shall I open a different bug report for the first issue? (The problem here
> being of course, that I added pam_systemd manually to
> /etc/pam.d/system-auth..)
That would be up to the maintainer - I would vote for it, though.

I do not have it in system-auth, since flameeyes said it was wrong (and that PAM on Gentoo is quite a mess...):
/etc/pam.d/kde:session    optional     pam_systemd.so debug=1
/etc/pam.d/kde-np:session    optional     pam_systemd.so debug=1
/etc/pam.d/system-login:session         optional        pam_systemd.so debug=1

I had it in system-auth earlier, though, and the issue with the slow shutdown was the same.
Comment 15 Jan Essert 2012-05-31 08:56:59 UTC
I will try to post logs, as soon as I have time. Might only be on Sunday, though.

You are right, removing pam_systemd breaks user mounting of removable drives, for instance. With your setup, adding it to kde, kde-np, system-login, do shutdown AND removable drives work?

I will try to open a bug or comment on the existing pam_systemd bug.
Comment 16 Dennis Schridde 2012-05-31 12:10:17 UTC
(In reply to comment #15)
> You are right, removing pam_systemd breaks user mounting of removable
> drives, for instance. With your setup, adding it to kde, kde-np,
> system-login, do shutdown AND removable drives work?
As explained earlier: Clicking shutdown within KDE will drop me to KDM, where shutdown works as expected. I guess that is kinda a "No" on "does shutdown work".

I did not test removable drives - I do not even know what that is supposed to be exactly. If it means the circle icon in the systray informing me about newly plugged in devices which I can then mount and view in Dolphin: Yes, that works.
Comment 17 Dennis Schridde 2012-06-09 12:58:02 UTC
When running systemctl restart kdm@tty7.service I noticed (via htop) that following program runs: systemd-tty-ask-password-agent

Maybe it asks for confirmation via password in some obscure location I cannot see...
Comment 18 Dennis Schridde 2012-06-09 13:09:25 UTC
(In reply to comment #17)
> When running systemctl restart kdm@tty7.service I noticed (via htop) that
> following program runs: systemd-tty-ask-password-agent
> 
> Maybe it asks for confirmation via password in some obscure location I
> cannot see...

One step further:
# systemd-ask-password --no-tty TEST
The message is shown nowhere on my system.

Maybe something systemd wants to do during shutdown on my system requires special privileges and the request for a password times out, because the password request message is shown nowhere?
Comment 19 Dennis Schridde 2013-04-03 01:22:23 UTC
I can still reproduce this - shutting down my system takes ages, when I enable systemd.

(In reply to comment #18)
> # systemd-ask-password --no-tty TEST
> The message is shown nowhere on my system.
This is also still reproducible. I enter this on a console and after a while it says "Timed out" and exits.
Comment 20 Henry Gebhardt 2013-04-03 02:48:59 UTC
Hm, seems like fedora and opensuse also have this problem:

    https://bugzilla.redhat.com/show_bug.cgi?id=913820
    https://bugzilla.novell.com/show_bug.cgi?id=727246

Anyone want to test the opensuse solution?
Comment 21 Dennis Schridde 2013-04-03 11:19:04 UTC
(In reply to comment #20)
> Hm, seems like fedora and opensuse also have this problem:
Thanks for those links!

So that means that the password thing is not actually the root cause? I still wonder why I don't get a dialogue and neither an error that no dialogue could be displayed...
Comment 22 Franz Trischberger 2013-04-16 08:24:10 UTC
I had this issue now. After putting systemd to my USE-Flags and "-systemd" to use.mask (+ rebuild packages with changed USE-Flags) and

session         optional        pam_loginuid.so
session         optional        pam_systemd.so

into /etc/pam.d/system-auth

everything is fine. (Though I did not test without the changes in system-auth)
Comment 23 Ulenrich 2013-04-16 14:26:01 UTC
@Franz
session         optional        pam_systemd.so kill-session-processes=1

isn't this kill setting needed anymore?
Comment 24 Dennis Schridde 2013-05-01 12:58:22 UTC
When the service file was moved to kde-base/kdm-4.10.2-r1, this bug got also moved. Please adjust the summary to:
kde-base/kdm-4.10.2-r1 - systemd service takes long to stop
Comment 25 Dennis Schridde 2013-05-01 12:59:57 UTC
(In reply to comment #23)
> @Franz
> session         optional        pam_systemd.so kill-session-processes=1
> 
> isn't this kill setting needed anymore?

I tried it and it does not help against the ssh-agent issue. Apparently "kill" there means SIGTERM, not SIGKILL.

What should help a little, though, is putting the following into kdm.service:
[Service]
TimeoutStopSec=15
Comment 26 Henry Gebhardt 2013-05-04 13:33:31 UTC
Before I reassign this bug, can you confirm that this bug is really with the unit file from the kdm package?
Comment 27 Dennis Schridde 2013-05-04 14:58:57 UTC
(In reply to comment #26)
> Before I reassign this bug, can you confirm that this bug is really with the
> unit file from the kdm package?

Yes, if I set TimeoutStopSecs=15 in kdm.service, the computer will shutdown after 15s instead of 90.
Comment 28 Henry Gebhardt 2013-05-04 16:00:56 UTC
Reassign please, as it now affects the kdm package in the main tree. I think the bug from opensuse sums it up, see comment #20.

Thanks,
Henry

(In reply to comment #28)
> Yes, if I set TimeoutStopSecs=15 in kdm.service, the computer will shutdown
> after 15s instead of 90.

Unfortunately, that is just an ugly workaround.
Comment 29 Johannes Huber gentoo-dev 2013-06-23 14:07:18 UTC
Can't reproduce this with kde-live (9999). So maybe it is fixed in 4.11?! Can somebody please confirm this with KDE 4.11 beta1 (>=4.10.80) from kde overlay?
Comment 30 Michael Palimaka (kensington) gentoo-dev 2013-08-15 16:20:34 UTC
4.11 is now in the tree, please test.
Comment 31 Dennis Schridde 2013-08-20 22:50:08 UTC
Seems to work now. Actually it seems to work since a while longer - 4.10.5 maybe, or maybe since systemd-206.
Comment 32 Michael Palimaka (kensington) gentoo-dev 2013-08-21 07:06:24 UTC
(In reply to Dennis Schridde from comment #31)
> Seems to work now. Actually it seems to work since a while longer - 4.10.5
> maybe, or maybe since systemd-206.

Thanks for testing!