Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454572 - www-apps/phpsysinfo-3.2.2 stable request
Summary: www-apps/phpsysinfo-3.2.2 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Web Application Packages Maintainers
URL:
Whiteboard: Was: www-apps/phpsysinfo-3.1.0: .htac...
Keywords: STABLEREQ
: 476060 (view as bug list)
Depends on: 550988
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2013-01-29 19:09 UTC by Toralf Förster
Modified: 2015-08-09 18:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2013-01-29 19:09:39 UTC
the .htaccess seems not to be ready for the unstable apache :

==> /var/log/apache2/ssl_error_log <==
[Tue Jan 29 20:06:44.372421 2013] [core:alert] [pid 1172:tid 1136929600] [client 192.168.0.254:44789] /var/www/localhost/htdocs/phpsysinfo/.htaccess: Invalid command 'order', perhaps misspelled or defined by a module not included in the server configuration

==> /var/log/apache2/ssl_access_log <==
192.168.0.254 - - [29/Jan/2013:20:06:44 +0100] "GET /phpsysinfo/ HTTP/1.1" 500 586

==> /var/log/apache2/ssl_request_log <==
[29/Jan/2013:20:06:44 +0100] 192.168.0.254 TLSv1 ECDHE-RSA-AES256-SHA "GET /phpsysinfo/ HTTP/1.1" 586



Here's the conten :
# cat /var/www/localhost/htdocs/phpsysinfo/.htaccess
<files phpsysinfo.ini>
  order deny,allow
  deny from all
</files>




And if I moved away the .htaccess file I get :


phpsysinfo.ini does not exist or is not readable by the webserver in the phpsysinfo directory or is misunderstood.

Generated by phpSysInfo - 3.1.0
Comment 1 Tim Harder gentoo-dev 2013-01-30 05:35:22 UTC
This seems like something to report upstream; or even better fork their git repo, fix it, and submit a pull request.
Comment 2 Pacho Ramos gentoo-dev 2014-06-09 11:39:17 UTC
Was this reported to upstream? (if still valid with latest versions)
Comment 3 Toralf Förster gentoo-dev 2014-06-09 11:53:59 UTC
yes, IIRC I wrote an email (last year however) to upstream ...
Comment 4 Tomáš Mózes 2014-11-12 08:35:12 UTC
I checked the master branch and it still has the old syntax. Wouldn't it be better to require access_compat?
Comment 5 Pacho Ramos gentoo-dev 2014-12-16 09:46:31 UTC
I cannot find any patch on any other distribution using apache 2.4 for this :(
Comment 6 Pacho Ramos gentoo-dev 2014-12-16 09:47:39 UTC
*** Bug 476060 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2015-05-08 19:08:38 UTC
Still the same with 3.2? Maybe they should be "Order" and "Deny"... if still valid it should be reported to upstream
Comment 8 Tomáš Mózes 2015-05-08 21:12:59 UTC
https://github.com/phpsysinfo/phpsysinfo/issues/85
Comment 9 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-05-09 11:12:57 UTC
This .htaccess file works with both apache 2.2 and 2.4.

<IfModule !mod_authz_core.c>
  Order deny,allow
  Deny from all
</IfModule>
<IfModule mod_authz_core.c>
  Require all denied
</IfModule>

We should start "replacing" simple .htaccess files like this and sending them upstream. So in this case

(In reply to Toralf Förster from comment #0)
> # cat /var/www/localhost/htdocs/phpsysinfo/.htaccess
> <files phpsysinfo.ini>
>   order deny,allow
>   deny from all
> </files>

should be replaced with

<files phpsysinfo.ini>
  <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
  </IfModule>
  <IfModule mod_authz_core.c>
    Require all denied
  </IfModule>
</files>
Comment 10 Pacho Ramos gentoo-dev 2015-05-09 11:35:01 UTC
OK, thanks

This is the upstream patch:
https://github.com/phpsysinfo/phpsysinfo/commit/dfd704d35de1a34c4cca869037778c1ac453fa17.patch

Should we apply it to ALL slots? Or do you have plans of dropping some of them soon :/
Comment 11 Tomáš Mózes 2015-06-02 09:01:06 UTC
Version 3.2.2 was released, it has the fix for Apache 2.4:
https://github.com/phpsysinfo/phpsysinfo/releases/tag/v3.2.2
Comment 12 Tomáš Mózes 2015-06-02 09:02:56 UTC
Version bump:
https://bugs.gentoo.org/show_bug.cgi?id=550988
Comment 13 Tomáš Mózes 2015-06-02 09:09:07 UTC
(In reply to Pacho Ramos from comment #10)
> OK, thanks
> 
> This is the upstream patch:
> https://github.com/phpsysinfo/phpsysinfo/commit/
> dfd704d35de1a34c4cca869037778c1ac453fa17.patch
> 
> Should we apply it to ALL slots? Or do you have plans of dropping some of
> them soon :/

I think no. Let's do a version bump and stabilize that one. If anybody will urgently require an old version (maybe?) then we can backport the .htaccess.
Comment 14 Pacho Ramos gentoo-dev 2015-06-02 18:39:57 UTC
3.2.2 in the tree
Comment 15 Jeroen Roovers gentoo-dev 2015-07-09 06:53:56 UTC
Stable for HPPA PPC64.
Comment 16 Pacho Ramos gentoo-dev 2015-07-23 20:34:50 UTC
ppc stable
Comment 17 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-29 15:46:23 UTC
amd64 stable
Comment 18 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-08-09 18:43:46 UTC
x86 stable