Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453304 - media-libs/mesa - unmask USE=wayland
Summary: media-libs/mesa - unmask USE=wayland
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on: 403015 475480
Blocks:
  Show dependency tree
 
Reported: 2013-01-21 09:19 UTC by jannis
Modified: 2014-01-30 17:25 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2013-01-21 09:19:36 UTC
Now we have a a bumped wayland-version in tree (see http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/wayland/ChangeLog?view=markup thanks to Matt Turner), I would like to emerge mesa again with the wayland USE-flag but it has been masked by chithanh.

If it's not possible since mesa-9.0.1 is stable and wayland-1.0.3 is not, can the USE-flag please be removed from mesa-9.0.1 and a new unstable mesa-9.0.1-r1 with the USE-flag be added? thanks!

Reproducible: Always
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2013-01-21 09:37:41 UTC
Meanwhile you can do the following:

  echo "media-libs/mesa -wayland" >> /etc/portage/profile/package.use.mask
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-21 13:00:32 UTC
Recently, 13.0 profiles were introduced with support for use.stable.mask
This might be used for mesa/wayland.
Comment 4 Sergey Popov gentoo-dev 2013-09-12 18:10:18 UTC
(In reply to Nikoli from comment #3)
> Seems this bug is fixed:
> http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/profiles/eapi-5-
> files/use.stable.mask?r1=1.5&r2=1.6

Your commit link is wrong, but yeah, wayland USE is now in use.stable.mask, so , yeah, probably we should close this bug. @x11, what's your opinion?
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-09-15 15:47:54 UTC
wayland will be removed from use.stable.mask too once bug 475480 is fixed.
Comment 6 Andrius Štikonas 2013-11-02 00:00:56 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #5)
> wayland will be removed from use.stable.mask too once bug 475480 is fixed.

Ping?
Comment 7 Sergey Popov gentoo-dev 2013-12-11 09:41:46 UTC
Not unmasking on mips due to problems in testing, adding keywordreq bug to dependencies
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-30 17:25:54 UTC
Wayland flag was removed for mesa-8.0.4-r1 as that caused repoman to complain.

wayland entry was dropped from use.stable.mask.