Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 450560 - dev-python/setuptools-0.8-r1 test failure
Summary: dev-python/setuptools-0.8-r1 test failure
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Python Gentoo Team
URL: https://bitbucket.org/tarek/distribut...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-06 16:29 UTC by Agostino Sarubbo
Modified: 2015-11-23 10:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
a diff -u from cvs + skip-test.patch (setuptools.patch,2.39 KB, patch)
2013-05-23 16:43 UTC, Ian Delaney (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-01-06 16:29:06 UTC
$summary
Comment 1 Patrick Lauer gentoo-dev 2013-01-11 08:18:50 UTC
test_test (setuptools.tests.test_test.TestTestTest) ... warning: build_py: byte-compiling is disabled, skipping.

test_test (name.space.tests.TestTest) ... ok

----------------------------------------------------------------------
Ran 1 test in 0.000s

OK
ok
test_create_zipfile (setuptools.tests.test_upload_docs.TestUploadDocsTest) ... ok

======================================================================
FAIL: test_setup_requires_honors_fetch_params (setuptools.tests.test_easy_install.TestSetupRequires)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/setuptools-0.6.34/work/distribute-0.6.34-python3_2/build/src/setuptools/tests/test_easy_install.py", line 367, in test_setup_requires_honors_fetch_params
    self.assertTrue(2 <= len(p_index.requests) <= 3)
AssertionError: False is not true

----------------------------------------------------------------------
Ran 83 tests in 2.792s

FAILED (failures=1)
Error in atexit._run_exitfuncs:
TypeError: 'NoneType' object is not callable
 * ERROR: dev-python/setuptools-0.6.34 failed (test phase):
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-01-11 09:58:58 UTC
I can confirm that it still happens with hg tip.
Comment 3 Dirkjan Ochtman gentoo-dev 2013-01-11 10:05:02 UTC
Filed upstream.
Comment 4 Dirkjan Ochtman gentoo-dev 2013-01-11 20:19:41 UTC
Arfrever, in the upstream bug, was unable to reproduce.

Maybe one of you can bisect it?
Comment 5 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-01-11 23:47:46 UTC
Hmm, wait, I'm having a different issue [1]. So I can't reproduce this one either.

[1]:https://bitbucket.org/tarek/distribute/issue/345/test-failure-with-python31-and-lc_all-c
Comment 6 Dirkjan Ochtman gentoo-dev 2013-05-03 12:50:21 UTC
Tried 0.6.36, still messed up, getting this:

======================================================================
ERROR: test_install_site_py (setuptools.tests.test_easy_install.TestEasyInstallTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/setuptools/tests/test_easy_install.py", line 70, in test_install_site_py
    cmd.install_site_py()
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/setuptools/command/easy_install.py", line 1291, in install_site_py
    source = resource_string(Requirement.parse("distribute"), "site.py")
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/pkg_resources.py", line 928, in resource_string
    self, resource_name
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/pkg_resources.py", line 1201, in get_resource_string
    return self._get(self._fn(self.module_path, resource_name))
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/pkg_resources.py", line 1328, in _get
    stream = open(path, 'rb')
IOError: [Errno 2] No such file or directory: '/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/site.py'

In addition to the one from comment 1:

======================================================================
FAIL: test_setup_requires_honors_fetch_params (setuptools.tests.test_easy_install.TestSetupRequires)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/src/setuptools/tests/test_easy_install.py", line 367, in test_setup_requires_honors_fetch_params
    self.assertTrue(2 <= len(p_index.requests) <= 3)
AssertionError: False is not true
Comment 7 Ian Delaney (RETIRED) gentoo-dev 2013-05-23 15:35:59 UTC
IOError: [Errno 2] No such file or directory: '/var/tmp/portage/dev-python/setuptools-0.6.36/work/distribute-0.6.36-python3_2/build/site.py'

well that one's easy.  By use of in source build it goes looking in  
distribute-0.6.36-python3_2/build/ for site.py.

Without it, it goes looking in distribute-0.6.36-python3_2/site.py which is where it is with the in source build.  For 1 the test is totally trivial, but you can get it to pass by taking the eclass out of the equation.

        pushd "${BUILD_DIR}"/../
        "${PYTHON}" setup.py test || die


dev-python/setuptools $ PYTHON_TARGETS=python3_2 ebuild setuptools-0.6.36.ebuild clean test
================================================
----------------------------------------------------------------------
Ran 83 tests in 47.438s

FAILED (failures=1)
Error in atexit._run_exitfuncs:
TypeError: 'NoneType' object is not callable

As for 
test_setup_requires_honors_fetch_params (setuptools.tests.test_easy_install.TestSetupRequires)

well it's testing easy_install which correct me if I'm wrong is out o' step with gentoo installs, and as the u/s dev said, 
< It's not even clear that the issue has any implications other than tests fail>

Does this one really not qualify for being just @skipped or disabled by virtue of being nothing but a point to trip over with no feasible moral?
Comment 8 Ian Delaney (RETIRED) gentoo-dev 2013-05-23 16:43:46 UTC
Created attachment 349008 [details, diff]
a diff -u from cvs + skip-test.patch

since this is distibute by another name and pertains to ALL 'impls',

dev-python/setuptools $ PYTHON_TARGETS=python2_5 ebuild setuptools-0.6.36.ebuild clean test

======================================================================
ERROR: Regression test for issue #318
----------------------------------------------------------------------

The following error occurred while trying to add or remove files in the
installation directory:

    [Errno 13] Permission denied: '/usr/lib64/python2.5/site-packages/test-easy-install-18699.write-test'

Oh ok. The test failed because it couldn't add or remove files in the installed instance of py2.5. and this is a failure!!!!

Well setuptools-0.6.32 also fails on test_setup_requires_honors_fetch_params, however I'm most uncertain what benefit a bisect analysis supplies given that it's inconsistent even between gentoo systems.
Comment 9 ahudson.news 2013-08-26 13:00:11 UTC
Just for the record, the "test_setup_requires_honors_fetch_params" failure still occurs with dev-python/setuptools-0.8-r1 .
Comment 10 Justin Lecher gentoo-dev 2015-11-23 10:08:43 UTC
commit bea1f6190d0aca59a83db41435f992f0cb97e1ca
Author: Justin Lecher <jlec@gentoo.org>
Date:   Mon Nov 23 10:42:05 2015 +0100

    dev-python/setuptools: Drop old

    obsoletes:

    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=447144
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=450560
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=468628
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=519956
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=537122
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=522456

    Package-Manager: portage-2.2.25
    Signed-off-by: Justin Lecher <jlec@gentoo.org>

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bea1f6190d0aca59a83db41435f992f0cb97e1ca