Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522456 - please unmask python_targets_python3_2 for dev-python/setuptools
Summary: please unmask python_targets_python3_2 for dev-python/setuptools
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-09 20:01 UTC by ahudson.news
Modified: 2015-11-23 10:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ahudson.news 2014-09-09 20:01:14 UTC
...because otherwise it is impossible to upgrade from python:3.2 to python:3.3 on a "FEATURES=test"-enabled system.

Reasoning: test-enabled systems need to resolve the circular dependency between dev-python/py and dev-python/pytest, for each update, via "FEATURES=-test emerge -v1 dev-python/py && emerge -v1 dev-python/py dev-python/pytest"

Now, in order to upgrade from python:3.2 to python:3.3, the above step has to be done, building exactly these two packages. In order to be able to do so, dev-python/setuptools needs to be build with the new python3_3 target -- but at the same time, it still has to provide the old python3_2 target for all the other packages which will be updated *after* resolving the circular dependency. Thus, for the time of the upgrade, dev-python/setuptools has to be rebuild first with both python targets (plus python2_7, if required), then all the update/rebuilds take place, then finally dev-python/setuptools can be rebuilt without the python3_2 target. (Or at least that's the most sane way I have come up with so far.)

After the masking of python3_2 on September 6th, this has become (afaik) impossible without rebuilding major parts of the system with tests disabled just to make "emerge world" happy with all the dependencies, *or* emerge with --nodeps which also isn't really helpful for having stable systems.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2014-09-10 08:52:28 UTC

*** This bug has been marked as a duplicate of bug 516550 ***
Comment 2 Justin Lecher gentoo-dev 2015-11-23 10:09:03 UTC
commit bea1f6190d0aca59a83db41435f992f0cb97e1ca
Author: Justin Lecher <jlec@gentoo.org>
Date:   Mon Nov 23 10:42:05 2015 +0100

    dev-python/setuptools: Drop old

    obsoletes:

    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=447144
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=450560
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=468628
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=519956
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=537122
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=522456

    Package-Manager: portage-2.2.25
    Signed-off-by: Justin Lecher <jlec@gentoo.org>

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bea1f6190d0aca59a83db41435f992f0cb97e1ca