Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 450402 - www-servers/apache-2.4.*: doesn't build module proxy_http
Summary: www-servers/apache-2.4.*: doesn't build module proxy_http
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2013-01-05 14:58 UTC by Hanno Böck
Modified: 2014-05-22 12:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2013-01-05 14:58:26 UTC
apache ebuild seems to ignore if one enables the proxy_http module.
This is what the ebuild passes to ./configure:
--enable-proxy_http=static
But according to ./configure --help it must be --enable-proxy-http. This is the same in 2.2, but it seems back then apache configure was more tolerant and worked anyway, which is no longer the case.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2014-05-22 12:02:49 UTC
I've tested this with apache-2.4.9-r2 and the module was built.
Are you sure this is still an issue?
Comment 2 Hanno Böck gentoo-dev 2014-05-22 12:26:43 UTC
No, just checked, I can't reproduce it any more right now.

This report is 1,5 years old, probably something changed inbetween that fixed this, I think we can close.