Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449418 - media-video/xbmc with >=net-libs/libmicrohttpd 0.9.23 - WebServer.cpp:(.text+0x2e79): undefined reference to `MHD_post_process'
Summary: media-video/xbmc with >=net-libs/libmicrohttpd 0.9.23 - WebServer.cpp:(.text+...
Status: RESOLVED DUPLICATE of bug 449082
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-31 09:47 UTC by Wojciech Myrda
Modified: 2012-12-31 20:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Myrda 2012-12-31 09:47:20 UTC
Rcently in net-libs/libmicrohttpd package from 0.9.23 and up the options have been enabled "--enable-bauth --enable-dauth" that lead to xbmc fail to compile with webserver flag or stop working properly when that flag for xbmc have been presiously turned on and libmicrohttpd package have been updated in the mean time.

XBMC upstream is yet to look in to those new features that seem to change the behaviour as even git version does not iclude work for it so for the time being. 

I propose those features disabled for now or hide them behind use flag so others not hit with similar compile error still may benefit from those new options

very welcome addion would also be to the xbmc ebuild checking for appropriate use flag being disabled within libmicrohttpd

more on the issue:
http://forums.gentoo.org/viewtopic-t-946134-highlight-xbmc.html
http://trac.xbmc.org/ticket/13583
Comment 1 SpanKY gentoo-dev 2012-12-31 20:11:35 UTC

*** This bug has been marked as a duplicate of bug 449082 ***