Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449082 - media-tv/xbmc-12.0_rc2[webserver] should depend on net-libs/libmicrohttpd[messages]
Summary: media-tv/xbmc-12.0_rc2[webserver] should depend on net-libs/libmicrohttpd[mes...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords:
: 443968 449418 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-28 19:50 UTC by Ben Kohler
Modified: 2012-12-31 20:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,282.63 KB, text/plain)
2012-12-28 19:50 UTC, Ben Kohler
Details
xbmc-9999-r1.ebuild (xbmc-9999-r1.ebuild,6.33 KB, text/plain)
2012-12-29 17:56 UTC, Lukas Elsner
Details
xbmc-12.0_rc2-r1.ebuild (xbmc-12.0_rc2-r1.ebuild,6.33 KB, text/plain)
2012-12-29 17:56 UTC, Lukas Elsner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Kohler gentoo-dev 2012-12-28 19:50:29 UTC
Created attachment 333614 [details]
build.log

media-tv/xbmc-12.0_rc2[webserver] does not build against <net-libs/libmicrohttpd-0.9.24, the dep should be adjusted to reflect this.  I have attached the build log from an attempt to build against 0.9.23.  Build against 0.9.24 succeeds.
Comment 1 Alastair Murray 2012-12-29 03:50:01 UTC
For me building against both 0.9.23 and 0.9.24 give the error in the submitter's build log.  Building against 0.9.21 works.

Ben: Did 0.9.24 definitely work for you?

This XBMC bug is relevant:
http://trac.xbmc.org/ticket/13583
Comment 2 Ben Kohler gentoo-dev 2012-12-29 04:14:26 UTC
Yes sir.  It sounds like you're building some version of xbmc older than 12.0_rc2, like the upstream bug report.  Whatever was current a few weeks ago probably did want older libmicrohttpd.  In any case, we need some version restrictions on this dep.
Comment 3 SpanKY gentoo-dev 2012-12-29 04:39:45 UTC
should be all set now in the tree; thanks for the report!

Commit message: Require a recent libmicrohttpd version
http://sources.gentoo.org/media-tv/xbmc/xbmc-12.0_rc2.ebuild?r1=1.3&r2=1.4
http://sources.gentoo.org/media-tv/xbmc/xbmc-9999.ebuild?r1=1.127&r2=1.128
Comment 4 Lukas Elsner 2012-12-29 15:06:03 UTC
Maybe I am wrong, but I cannot confirm this.

All my xbmc ebuilds failing against newer libmicrohttpd. (also tried manual compiling with latest git tree)

12rc and 9999 should not depend on the most recent version, because it prevents to be emerged at all. 

I reverted back to the older xbmc ebuilds in my overlay (luman). They are compiling fine, while newest libmicrohttpd packages are masked.
Comment 5 Ben Kohler gentoo-dev 2012-12-29 15:08:59 UTC
This issue seems to be more complicated than I thought.  Those who are seeing failures with xbmc-12.0_rc2/9999 & libmicrohttpd-0.9.24, are you fully up to date on ~x86/~amd64, or mixing stable/unstable?
Comment 6 Ben Kohler gentoo-dev 2012-12-29 16:49:44 UTC
It looks like what's actually needed is USE="messages" on libmicrohttpd.  Somehow I was able to build without it earlier, but now I consistently get the following results:

xbmc-12.0_rc2 + libmicrohttpd-0.9.23[-messages] FAIL
xbmc-12.0_rc2 + libmicrohttpd-0.9.23[messages]	SUCCESS
xbmc-12.0_rc2 + libmicrohttpd-0.9.24[-messages] FAIL
xbmc-12.0_rc2 + libmicrohttpd-0.9.24[messages]  SUCCESS

Can anyone else confirm what I'm seeing?  Sorry for the confusion, I know the forced 0.9.24 made things worse for a few of you.

I suppose the best dep would now be net-libs/libmicrohttpd[messages+]
Comment 7 Alastair Murray 2012-12-29 17:36:14 UTC
I came here to post that XBMC really was broken with libmicrohttpd-0.9.24, but it seems that you're already ahead of me.  Setting USE="message" on libmicrohttpd fixes the XBMC build for me.

(In reply to comment #6)
> xbmc-12.0_rc2 + libmicrohttpd-0.9.24[-messages] FAIL
> xbmc-12.0_rc2 + libmicrohttpd-0.9.24[messages]  SUCCESS

I can confirm these two (I didn't try 0.9.23).
Comment 8 Lukas Elsner 2012-12-29 17:55:35 UTC
net-libs/libmicrohttpd[messages+] or net-libs/libmicrohttpd[messages] ?

I think there is a typo in there?


I updated my ebuilds!
Comment 9 Ben Kohler gentoo-dev 2012-12-29 17:55:59 UTC
I'm not sure how I came to the conclusion last night that 0.9.24 was to blame... USE=messages was disabled in all of my tests and I was seeing some success on 0.9.24 still, somehow.

But now that the dust has settled, it looks like the proper dep is net-libs/libmicrohttpd[messages(+)] (fixed minor syntax issue from last comment).  Unless anyone else sees a case that doesn't match the results in comment #6.
Comment 10 Lukas Elsner 2012-12-29 17:56:22 UTC
Created attachment 333688 [details]
xbmc-9999-r1.ebuild
Comment 11 Lukas Elsner 2012-12-29 17:56:44 UTC
Created attachment 333690 [details]
xbmc-12.0_rc2-r1.ebuild
Comment 12 Lukas Elsner 2012-12-29 18:08:27 UTC
confirm proper emerging on two boxes here
Comment 13 SpanKY gentoo-dev 2012-12-29 20:09:42 UTC
Comment on attachment 333688 [details]
xbmc-9999-r1.ebuild

post diffs, not entire files
Comment 14 SpanKY gentoo-dev 2012-12-29 20:09:48 UTC
Comment on attachment 333690 [details]
xbmc-12.0_rc2-r1.ebuild

post diffs, not entire files
Comment 16 Craig Andrews gentoo-dev 2012-12-30 02:34:45 UTC
This was reported at the XBMC bug tracker: http://trac.xbmc.org/ticket/13583

I added a comment pointing to this bug report and the solution.
Comment 17 SpanKY gentoo-dev 2012-12-31 20:11:18 UTC
*** Bug 443968 has been marked as a duplicate of this bug. ***
Comment 18 SpanKY gentoo-dev 2012-12-31 20:11:35 UTC
*** Bug 449418 has been marked as a duplicate of this bug. ***