Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448354 - sys-fs/lvm2-2.02.97-r1 fails to crosscompile: configure: error: thin_check not found in path
Summary: sys-fs/lvm2-2.02.97-r1 fails to crosscompile: configure: error: thin_check no...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: PATCH
: 491746 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-24 00:35 UTC by Dennis Schridde
Modified: 2014-02-04 02:46 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix thin tool path check (lvm2-fix-thin-tool-check.patch,1.64 KB, patch)
2013-12-05 01:29 UTC, mike@marineau.org
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2012-12-24 00:35:04 UTC
checking for thin_check... no
configure: error: thin_check not found in path /usr/lib64/portage/bin/ebuild-helpers:/usr/local/sbin:/usr/local/bin:...

It should not check for thin_check, when crosscompiling.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2012-12-25 16:46:13 UTC

*** This bug has been marked as a duplicate of bug 436332 ***
Comment 2 Jeroen Roovers gentoo-dev 2013-11-20 15:22:35 UTC
*** Bug 491746 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen Roovers gentoo-dev 2013-11-20 15:23:41 UTC
Either it should DEPEND on sys-block/thin-provisioning-tools or the check should be removed (if it's pointless anyway).
Comment 4 mike@marineau.org 2013-12-05 01:29:54 UTC
Created attachment 364634 [details, diff]
Fix thin tool path check

This issue is not specific to cross compiling but crops up any time you build lvm2 with an alternate $ROOT value and sys-block/thin-provisioning-tools is not installed on the host system.

Instead of letting the configure script scan $PATH for the tools just set the path explicitly. Both 103 and 104 build now with this fix.

Patched versions committed to my overlay: https://github.com/marineam/misc-overlay/commit/b80265052d31e43ddab5c864b3d8584ba60d9c66
Comment 5 Colin Shorts 2013-12-10 13:07:15 UTC
Shouldn't the sys-block/thin-provisioning-tools package be pulled in as a dependency by the 'thin' use flag? I would also suggest that thin should not be selected by default.
Comment 6 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2014-02-04 02:46:13 UTC
InCVS of .105-r2.