Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447622 - app-crypt/gcr does not respect CC
Summary: app-crypt/gcr does not respect CC
Status: RESOLVED DUPLICATE of bug 447612
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2012-12-17 17:56 UTC by Agostino Sarubbo
Modified: 2012-12-18 08:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2012-12-17 17:56:50 UTC
You receive this bug because this package does not respect my system's CC ( x86_64-pc-linux-gnu-gcc - /usr/bin/x86_64-pc-linux-gnu-gcc ) and calls directly gcc -/usr/bin/gcc
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can
2)inherit toolchain-funcs and use tc-export CC
3)inherit toolchain-funcs and use emake CC="$(tc-getCC)"


g-ir-scanner: compile: gcc -Wall -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include 
-I/usr/include/p11-kit-1 -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes 
-Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -O2 -pipe -mtune=itanium2 
-Wno-strict-aliasing -Wno-sign-compare -I.. -I.. -I/usr/include/p11-kit-1 
-I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -c -o 
/var/tmp/portage/app-crypt/gcr-3.4.1-r2/work/gcr-3.4.1/gck/tmp-introspectfpEa2E/Gck-1.o 
/var/tmp/portage/app-crypt/gcr-3.4.1-r2/work/gcr-3.4.1/gck/tmp-introspectfpEa2E/Gck-1.c
Comment 1 Gilles Dartiguelongue gentoo-dev 2012-12-18 08:28:16 UTC
This same problem has been reported a few times already, this is due to g-ir-scanner integration.

*** This bug has been marked as a duplicate of bug 447612 ***
Comment 2 Gilles Dartiguelongue gentoo-dev 2012-12-18 08:30:40 UTC
FTR, bug #447612 is another occurence of this problem.