Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447612 - app-crypt/libsecret does not respect CC
Summary: app-crypt/libsecret does not respect CC
Status: RESOLVED DUPLICATE of bug 463846
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 447622 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2012-12-17 16:43 UTC by Agostino Sarubbo
Modified: 2013-05-10 22:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2012-12-17 16:43:39 UTC
You receive this bug because this package does not respect my system's CC ( x86_64-pc-linux-gnu-gcc - /usr/bin/x86_64-pc-linux-gnu-gcc ) and calls directly gcc -/usr/bin/gcc
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can
2)inherit toolchain-funcs and use tc-export CC
3)inherit toolchain-funcs and use emake CC="$(tc-getCC)"


g-ir-scanner: compile: gcc -Wall -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -O2 -pipe -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
-I/usr/include/gio-unix-2.0/ -Wall -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wdeclaration-after-statement -Wformat=2 -Winit-self 
-Waggregate-return -Wmissing-format-attribute -Wmissing-include-dirs -Wundef -Wno-error -g -I.. -I.. -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 
-I/usr/lib64/glib-2.0/include -c -o /var/tmp/portage/app-crypt/libsecret-0.12/work/libsecret-0.12/libsecret/tmp-introspectq7msaG/Secret-1.o 
/var/tmp/portage/app-crypt/libsecret-0.12/work/libsecret-0.12/libsecret/tmp-introspectq7msaG/Secret-1.c
Comment 1 Gilles Dartiguelongue gentoo-dev 2012-12-18 08:28:16 UTC
*** Bug 447622 has been marked as a duplicate of this bug. ***
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-05-10 22:20:48 UTC

*** This bug has been marked as a duplicate of bug 463846 ***