Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444004 - app-portage/g-cpan-0.16.4-r1 should use default $PORTDIR
Summary: app-portage/g-cpan-0.16.4-r1 should use default $PORTDIR
Status: RESOLVED DUPLICATE of bug 432992
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 09:21 UTC by mephinet
Modified: 2014-12-20 18:07 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of emerge --info (emerge-info.txt,5.13 KB, text/plain)
2012-11-20 09:21 UTC, mephinet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mephinet 2012-11-20 09:21:31 UTC
Created attachment 330032 [details]
Output of emerge --info

If the PORTDIR variable is commented out in /etc/make.conf or /etc/portage/make.conf, g-cpan fails with the following error message:

 * ERROR READING /profiles/arch.list: No such file or directory

Adding the line PORTDIR=/usr/portage into make.conf solves the issue. As the line is commented out by default, this is an issue to most first-time users, I guess...
Comment 1 cono 2012-11-20 13:07:15 UTC
As for me even uncommented line doesn't help, because the make.conf moved to portage dir. I fixed by this:

50c50
< foreach my $file ( "$ENV{HOME}/.gcpanrc", "/etc/make.conf", "/etc/make.globals" ) {
---
> foreach my $file ( "$ENV{HOME}/.gcpanrc", "/etc/make.conf", "/etc/make.globals", "/etc/portage/make.conf" ) {
Comment 2 mephinet 2012-11-20 13:44:39 UTC
cono, this is what the g-cpan-0.16.4-r1 ebuild fixes already.
Comment 3 Raphael Bastos 2013-02-15 13:12:08 UTC
This bug is not fixed on ebuild g-cpan-0.16.4-r1

See my problem:




cloud ~ # genlop -s g-cpan|tail -2
     Fri Feb 15 10:54:15 2013 >>> app-portage/g-cpan-0.16.4-r1

cloud ~ # rm -rf /root/.cpan/

cloud ~ # g-cpan --upgrade
 * No CPAN Config found, auto-generating a basic one
mkdir /root/.cpan
mkdir /root/.cpan/CPAN
 * ERROR READING /profiles/arch.list: No such file or directory





Fixed manually:

cloud ~ # echo 'PORTDIR="/usr/portage"' >> /etc/portage/make.conf

cloud ~ # g-cpan --upgrade
Use of uninitialized value $overlay in split at /usr/bin/g-cpan line 435.
 * Everything was up to date, nothing to do!
Comment 4 nilburn 2013-04-28 16:34:56 UTC
I got same bug, now.
Comment 5 Andreas K. Hüttel gentoo-dev 2014-12-20 18:07:49 UTC
Yeah, this is another effect of the moved make.globals

*** This bug has been marked as a duplicate of bug 432992 ***