Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432992 - app-portage/g-cpan-0.16.4-r1: uses /etc/make.globals, should use /usr/share/portage/config/make.globals
Summary: app-portage/g-cpan-0.16.4-r1: uses /etc/make.globals, should use /usr/share/p...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Ebuild Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard: fixed in 0.16.7
Keywords:
: 444004 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-27 17:05 UTC by Peter Fox
Modified: 2016-05-12 10:25 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info for alpha123 which also shows g-cpan broken behaviour (emergeinfo1,5.85 KB, text/plain)
2012-08-27 17:08 UTC, Peter Fox
Details
emerge --info for alpha120 which shows correct g-cpan -l behaviour (emergeinfo2,5.85 KB, text/plain)
2012-08-27 17:17 UTC, Peter Fox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fox 2012-08-27 17:05:39 UTC
for >=sys-apps/portage-2.2.0_alpha121, g-cpan -l just outputs:

ERROR READING /profiles/arch.list: No such file or directory

Reproducible: Always

Actual Results:  
ERROR READING /profiles/arch.list: No such file or directory

Expected Results:  
A listing of generated perl-gcpan ebuilds
Comment 1 Peter Fox 2012-08-27 17:08:27 UTC
Created attachment 322382 [details]
emerge --info for alpha123 which also shows g-cpan broken behaviour
Comment 2 Peter Fox 2012-08-27 17:17:12 UTC
Created attachment 322384 [details]
emerge --info for alpha120 which shows correct g-cpan -l behaviour
Comment 3 Zac Medico gentoo-dev 2012-08-27 17:39:26 UTC
It's probably broken because new portage doesn't install the /etc/make.globals symlink. It should be fixed to use /usr/share/portage/config/make.globals directly. As a temporary workaround, you can do this:

  ln -s /usr/share/portage/config/make.globals /etc/make.globals
Comment 4 Andreas K. Hüttel gentoo-dev 2014-12-20 17:44:55 UTC
Fixed in git master. Keeping the bug open until next release.
Comment 5 Andreas K. Hüttel gentoo-dev 2014-12-20 18:07:49 UTC
*** Bug 444004 has been marked as a duplicate of this bug. ***