Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 443924 - net-misc/remmina-1.0.0_p20121004 - When connecting to a RDP server, the icons appear white.
Summary: net-misc/remmina-1.0.0_p20121004 - When connecting to a RDP server, the icons...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tristan Heaven (RETIRED)
Depends on:
Reported: 2012-11-19 14:30 UTC by Bruno Santos
Modified: 2014-07-14 20:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Screenshot of Remmina RDP with icons white (Screenshot.png,44.49 KB, image/png)
2012-11-19 14:30 UTC, Bruno Santos
Top-left image only (Screenshot-SAM-1.png,24.41 KB, image/png)
2012-11-21 09:35 UTC, Bruno Santos

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Santos 2012-11-19 14:30:19 UTC
Created attachment 329952 [details]
Screenshot of Remmina RDP with icons white

I'm having this issue with remmina on Gentoo -

Every time i connect to a server with RDP, all the icons appear white. The same doesn't happen when using xfreerdp from the command line... 

I'm using Gentoo Linux with Remmina 1.0.0_p20121004 from the Portage

Remmina has been compiled with the following options:

net-misc/remmina-1.0.0_p20121004  USE="avahi crypt freerdp nls ssh vte (-ayatana) -debug -gnome-keyring -telepathy"


Bruno Santos
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-11-19 19:50:10 UTC
Please post your `emerge --info' output in a comment.
Comment 2 Bruno Santos 2012-11-20 09:09:24 UTC
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 3.6.2-ck x86_64)
System uname: Linux-3.6.2-ck-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Mon, 19 Nov 2012 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo zugaina x11 virtualization php kvm dustin ikelos sabayon sunrise seden gnome dev-zero x-portage
CFLAGS="-mtune=core2 -march=native -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-mtune=core2 -march=native -O2 -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/x11 /var/lib/layman/virtualization /var/lib/layman/php /var/lib/layman/kvm /var/lib/layman/dustin /var/lib/layman/ikelos /var/lib/layman/sabayon /var/lib/layman/sunrise /var/lib/layman/seden /var/lib/layman/gnome /var/lib/layman/dev-zero /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 apache2 apm avahi berkdb bluetooth branding bzip2 cairo cdda cdparanoia cdr cli colord consolekit cracklib crypt css cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gd gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 gzip iconv icu imap java java6 jpeg lame lcms ldap libnotify lm_sensors mad matroska mms mmx mng modules mono mp3 mp4 mpeg mplayer mudflap multilib mysql mysqli nautilus ncurses networkmanager nls nptl nsplugin nvidia ogg opengl openmp pam pango pcntl pcre pdf perl php png policykit posix ppds pppd pulseaudio python qt3support quicktime rdesktop readline rss samba sasl sdl session smp socialweb spell sse sse2 ssl startup-notification subversion svg tcpd theora threads tidy tiff truetype udev udisks unicode upower usb vaapi vdpau vim-syntax vorbis wxwidgets x264 xattr xcb xcomposite xine xml xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Mike Gilbert gentoo-dev 2012-11-20 15:05:31 UTC
What version of net-misc/freerdp is installed?
Comment 4 Bruno Santos 2012-11-20 16:09:48 UTC
Here it is:

net-misc/freerdp-1.1.0_pre20121004-r1  USE="X alsa channels client cups ffmpeg gstreamer jpeg pulseaudio sse2 xv -debug -directfb -doc -smartcard {-test} -xinerama"
Comment 5 Mike Gilbert gentoo-dev 2012-11-21 04:30:16 UTC
What version of Windows is the server running? Can you give me the client settings you are using?
Comment 6 Bruno Santos 2012-11-21 09:34:54 UTC
Hi !

this happens with all the windows servers:

2008 R2
2000 SP4 (here the background appears brown - despite 24bpp )
2003 R2 SP2

I don't know if it's relevant, but sometimes i need to press the button "resize the window to fit remote resolution" (first button from left in remote desktop window) because i only get an image in the top left part of the window (latest attachment).

Thank you !
Comment 7 Bruno Santos 2012-11-21 09:35:22 UTC
Created attachment 330115 [details]
Top-left image only
Comment 8 Bruno Santos 2012-11-21 10:25:43 UTC
Hi ! 

Don't know why, but i solved the mystery ! 

I remember that i had pulseaudio use flag added a few weeks ago and it was when it started to go white...

I've removed the pulseaudio USE flag, and now it works without all the white icons and labels.

I've checked the use flags, and only freerdp has it, not remmina. but the issue was with remmina and not freerdp...

The thing is it's working... But the top-left image issue remains.. should i open a new bug ?


Bruno Santos
Comment 9 Mike Gilbert gentoo-dev 2012-11-22 03:52:51 UTC
Heh, I'm not going to install pulseaudio just to recreate this. I have no idea why that would make a difference.

FYI, this is quite similar to bug 437918. That specific issue was resolved in the version of freerdp you are using, however.

Can you try to reproduce the problem with the live ebuilds? That's freerdp-9999.1 and remmina-9999.

If the problem still persists, please file a bug upstream, and post a link to it here.
Comment 10 Bruno Santos 2012-11-22 08:23:54 UTC
I'll try and post any results.
Comment 11 Bruno Santos 2012-11-22 14:24:10 UTC
Hi !

I've tried with the live ebuilds and was unable to reproduce the bug...

Using pulseaudio USE flag (just testing) with freerdp-9999.1, the same didn't happen again...

I guess it's solved. !
Comment 12 Mike Gilbert gentoo-dev 2012-11-22 16:50:19 UTC
Yeah, sounds that way.

If you can find the commit(s) that fixed the issue, I'm happy to back-port them. Otherwise, this issue will probably remain until freerdp.1.1.0 is released or I take a new snapshot.
Comment 13 Bruno Santos 2012-11-23 10:07:39 UTC
I've tried the same ebuild I had before, using the pulseaudio useflag:

[ebuild  N     ] media-sound/pulseaudio-2.1-r1  USE="X alsa asyncns avahi bluetooth caps dbus gdbm glib gnome gtk orc ssl tcpd udev webrtc-aec -doc -equalizer -ipv6 -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) (-systemd) {-test} -xen" 1,324 kB
[ebuild   R    ] media-plugins/alsa-plugins-1.0.25-r1  USE="ffmpeg pulseaudio* -debug -jack -libsamplerate -speex" 0 kB
[ebuild   R    ] net-misc/freerdp-1.1.0_pre20121004-r1  USE="X alsa channels client cups ffmpeg gstreamer jpeg pulseaudio* sse2 xv -debug -directfb -doc -smartcard {-test} -xinerama"

And it didn't happen again...

Don't know if pulseaudio had ever anything to do with it !

Best regards,

Bruno Santos
Comment 14 Ben Kohler gentoo-dev 2013-01-13 18:05:07 UTC
I think this bug should be closed and a new one opened for the "top left corner" issue.  I am still experiencing that issue.
Comment 15 Ben Kohler gentoo-dev 2013-01-13 20:16:53 UTC
This one should probably be marked dupe of bug #437918, even though it didn't initially seem so.

New bug #451910 for the "top left" issue.