Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442372 - mail-mta/courier : init.d file lacks "checkpath --directory /var/run/courier" for openrc-0.11.5
Summary: mail-mta/courier : init.d file lacks "checkpath --directory /var/run/courier"...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
: 447016 (view as bug list)
Depends on:
Blocks: keepdir-var-run_lock
  Show dependency tree
 
Reported: 2012-11-08 18:46 UTC by Toralf Förster
Modified: 2013-03-08 00:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to add checkpath. (courier-init-r3.patch,318 bytes, text/plain)
2013-02-23 22:06 UTC, Brian Beardall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2012-11-08 18:46:05 UTC
otherwise this happens :
n22_uml ~ # /etc/init.d/courier start 
 * Starting mysql ...                                                                                     [ ok ]
 * Starting rpcbind ...                                                                                   [ ok ]
 * Starting famd ...                                                                                      [ ok ]
 * Starting courier-authlib: authdaemond ...                                                              [ ok ]
 * Starting Courier mail server: ...
/var/run/courier/esmtpd.pid.lock: No such file or directory
/var/run/courier/esmtpd-msa.pid.lock: No such file or directory
 *  Starting courierfilterd ...
/var/run/courier/sqwebmaild.pid.lock: No such file or directory
ll_daemon_start: Resource temporarily unavailable
 *  Starting courierd ...
 *  Starting esmtpd ...
 *  courier-imapd ...
/var/run/courier/imapd.pid.lock: No such file or directory
ll_daemon_start: Resource temporarily unavailable                                                         [ ok ]
Comment 1 Alexander Tsoy 2012-11-13 08:01:00 UTC
courier ebuild should not keep dir /var/run/courier. Instead init.d script should create this directory as needed.

This bug should block Bug 332633
Comment 2 Jeroen Roovers gentoo-dev 2012-12-12 15:30:37 UTC
*** Bug 447016 has been marked as a duplicate of this bug. ***
Comment 3 Brian Beardall 2013-02-22 02:28:48 UTC
This bug is easy. I'll post a patch to get this fixed.
Comment 4 Brian Beardall 2013-02-23 22:06:14 UTC
Created attachment 339866 [details]
Patch to add checkpath.
Comment 5 Hanno Böck gentoo-dev 2013-03-08 00:43:48 UTC
fixed with courier 0.70 bump