Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 440572 - dev-lang/php-5.3.15: some elog messages should only be shown when upgrading from an old enough package.
Summary: dev-lang/php-5.3.15: some elog messages should only be shown when upgrading f...
Status: RESOLVED DUPLICATE of bug 440574
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 11:29 UTC by poletti.marco
Modified: 2012-10-31 12:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 11:29:33 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package dev-lang/php-5.3.15, the following elog messages are displayed:

 * Installing php.ini for cli into /etc/php/cli-php5.3
 * 
 * Make sure that PHP_TARGETS in /etc/make.conf includes php5-3 in order
 * to compile extensions for the 5.3 ABI
 * 
 * 
 * This ebuild installed a version of php.ini based on php.ini-development version.
 * You can chose which version of php.ini to install by default by setting PHP_INI_VERSION to either
 * 'production' or 'development' in /etc/make.conf
 * Both versions of php.ini can be found in /usr/share/doc/php-5.3.15
 * 
 * For more details on how minor version slotting works (PHP_TARGETS) please read the upgrade guide:
 * http://www.gentoo.org/proj/en/php/php-upgrading.xml

Such messages should only be displayed when the package is upgraded from an old enough package (and possibly for new installs).
These situations can be checked in the ebuild as follows:

if has_version '<dev-lang/php-1.0'; then

Or, if the message should also be displayed for new installs:

if !has_version 'dev-lang/php' || has_version '<dev-lang/php-1.0'; then

Remember to replace 1.0 with the right version number.

See the tracker bug 440214 for more details.
Comment 1 Ole Markus With (RETIRED) gentoo-dev 2012-10-31 12:30:24 UTC

*** This bug has been marked as a duplicate of bug 440574 ***