Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 43816 - Pro-forma request for monodevelop ebuild
Summary: Pro-forma request for monodevelop ebuild
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-05 10:39 UTC by AJ Armstrong
Modified: 2004-07-02 19:04 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gtksourceview-sharp-cvs-20040307.ebuild (gtksourceview-sharp-cvs-20040307.ebuild,751 bytes, text/plain)
2004-03-07 05:49 UTC, Tim Rädisch
Details
monodevelop-0.1.ebuild (monodevelop-0.1.ebuild,768 bytes, text/plain)
2004-03-07 05:50 UTC, Tim Rädisch
Details
monodevelop-0.1-r1.ebuild (monodevelop-0.1-r1.ebuild,1.02 KB, text/plain)
2004-03-08 04:28 UTC, Tim Rädisch
Details
gtksourceview-sharp-cvs-0.1.0.ebuild (gtksourceview-sharp-cvs-0.1.0.ebuild,804 bytes, text/plain)
2004-03-08 04:28 UTC, Tim Rädisch
Details
gtk-sharp-0.17.ebuild (gtk-sharp-0.17.ebuild,2.05 KB, text/plain)
2004-03-08 15:04 UTC, Tim Rädisch
Details
gtksourceview-sharp-cvs-0.1.0-r1.ebuild (gtksourceview-sharp-cvs-0.1.0-r1.ebuild,757 bytes, text/plain)
2004-03-14 23:02 UTC, Tim Rädisch
Details
monodevelop-0.1-r2.ebuild (monodevelop-0.1-r2.ebuild,1.04 KB, text/plain)
2004-03-14 23:02 UTC, Tim Rädisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AJ Armstrong 2004-03-05 10:39:42 UTC
I would be deeply surprised if tberman and others were not already working on this, but there seems to be no bugs filed against ebuilds for the newly released monodevelop 0.1 and its dependancies.  So, I am requesting it for myself and the people in the forums that I can now give a bugreport number to.

Conratulations to tberman and the others working on this project.

Reproducible: Always
Steps to Reproduce:
Comment 1 Tim Rädisch 2004-03-07 05:49:02 UTC
Hi!

I've create two eBuilds which seem to work. 


Tim
Comment 2 Tim Rädisch 2004-03-07 05:49:38 UTC
Created attachment 26982 [details]
gtksourceview-sharp-cvs-20040307.ebuild
Comment 3 Tim Rädisch 2004-03-07 05:50:08 UTC
Created attachment 26983 [details]
monodevelop-0.1.ebuild
Comment 4 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-03-07 06:21:44 UTC
Tracking.
Comment 5 Nicolas Mommaerts 2004-03-08 00:56:26 UTC
tracking.
Comment 6 Hinrik Örn Sigurðsson 2004-03-08 03:28:58 UTC
I installed Monodevelop 0.1 manually a few days ago, and I noticed that it needs mozilla. But since I use Firefox, i tried doing "ln -s /usr/bin/firefox /usr/bin/mozilla" and it worked like a charm.

So, is there way to hack to source to look for firefox if mozilla is missing?
Comment 7 Tim Rädisch 2004-03-08 03:34:41 UTC
I supposed that it's no difference beetwenn mozilla and firefox for monodevelop, but I didn't test it myself.

I will try do modify the eBuild. Hints are welcome :)

Tim
Comment 8 Tim Rädisch 2004-03-08 04:27:56 UTC
Ok, now the eBuild should work work with mozilla and firefox. I also corrected the gtksourceview-sharp-ebuild, becaus I've forgotten to install the docs and found out the version-number :)
Comment 9 Tim Rädisch 2004-03-08 04:28:26 UTC
Created attachment 27019 [details]
monodevelop-0.1-r1.ebuild
Comment 10 Tim Rädisch 2004-03-08 04:28:55 UTC
Created attachment 27020 [details]
gtksourceview-sharp-cvs-0.1.0.ebuild
Comment 11 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-03-08 04:44:03 UTC
There seems to be a bug in monodevelop:

It recognizes and completes syntax correctly. It compiles using mcs correctly. But, it doesn't run correctly the programs (neither uses mono nor mint to run them, so it throws an exception error when running apps from inside monodevelop, but running them manually does work).
There is also another bug where, if you double click on the GTK references, monodevelop crashes and 'exits' to desktop.
Comment 12 Tim Rädisch 2004-03-08 05:09:18 UTC
I've the same problem. But you can run the programm from command line. I can't find a bug-section on monodevelop.com to check out, if it is a monodevelop problem. After all it's just 0.1 
Comment 13 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-03-08 14:54:24 UTC
As x11-libs/gtk-sharp-0.17 doesn't exist in the current tree, I think it would be useful to know where to get it from:
http://bugs.gentoo.org/show_bug.cgi?id=43789
Comment 14 Tim Rädisch 2004-03-08 15:03:58 UTC
Hi!

Sorry, my fault! I add it, but it' simply a copy of the existing 0.16-eBuild. 
Comment 15 Tim Rädisch 2004-03-08 15:04:49 UTC
Created attachment 27057 [details]
gtk-sharp-0.17.ebuild
Comment 16 cyber mans 2004-03-08 15:25:44 UTC
In the monodevelop ebuild icu 2.8 is required. gtk-sharp needs a file from icu-2.6 ( libicui18n.so.26 )
Comment 17 Nicolas Mommaerts 2004-03-08 15:39:32 UTC
Mono needs it, not gtk-sharp. You've probably updated icu after emerging mono. Re-emerge mono and you should be fine (just had the same problem and that solved it for me)
Comment 18 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-03-08 16:09:47 UTC
Another bug:
File >> New >> File >> C# >> Typed C# Collection
Crashes the program.
Comment 19 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-03-08 16:22:02 UTC
I opened a bug report here:
http://bugzilla.ximian.com/show_bug.cgi?id=55332
Comment 20 Todd Berman (RETIRED) gentoo-dev 2004-03-08 16:47:23 UTC
As the author, maintainer, whatnot of MonoDevelop, I'd like to let you guys know that this will be in the tree asap.

I am currently on vacation in boston (attended a mono summit, some other stuff), so i am not at a computer I can commit with.

I should be back next week, and able to get to pushing this stuff into the tree.

As for bugs, please file them upstream on our bugzilla at bugzilla.ximian.com

Thanks for all your interest, it is nice :)
Comment 21 aent 2004-03-14 18:51:05 UTC
Both of your ebuilds should inherit mono so it stops that warning...
Comment 22 Tim Rädisch 2004-03-14 23:02:09 UTC
Created attachment 27390 [details]
gtksourceview-sharp-cvs-0.1.0-r1.ebuild
Comment 23 Tim Rädisch 2004-03-14 23:02:46 UTC
Created attachment 27391 [details]
monodevelop-0.1-r2.ebuild
Comment 24 Tim Rädisch 2004-03-14 23:03:49 UTC
Your wish is my command ... this time ;)

But seriously, thanks for the hint
Comment 25 M Guzman 2004-03-19 12:14:21 UTC
Hi,

Cool :) I've been wanting to try out monodevelop for a while but have been too busy.  Just have a comment about the ebuilds that have been posted though - they don't seem to work with syntax highlighting.  I've reemerged everything, thinking it may have been a problem in cvs, but for the past few days, there's been no syntax highlighting at all.  gnome-file-types-properties shows that *.cs files are recognized as text/x-csharp.  Maybe there's something different with the libraries in GNOME 2.6rc1 that the ebuild's configure process doesn't recognize? (sorry, I can't tell myself as I'm pretty new to mono-related stuff).
Comment 26 Srepfler Srgjan 2004-03-21 07:59:17 UTC
I've downloaded the gtksourceview-sharp-cvs and monodevelop ebuilds, and tried
emerge nameof.ebuild in my home directory
I'm getting:

Calculating dependencies \!!! aux_get(): ebuild for '/monodevelop-0.1-r2' does not exist at:
!!!            /usr/portage//monodevelop/monodevelop-0.1-r2.ebuild
emerge: create(): aux_get() error on /monodevelop-0.1-r2; aborting...

are they supposed to be in the /usr/portage... ? if so, where exactly?
As far as the gtk-sharp 0.17, it's in the official portage tree right?
Comment 27 Srepfler Srgjan 2004-03-21 08:09:54 UTC
I've put them in /usr/portage/dev-dotnet/ is it ok?
Comment 28 Tim Rädisch 2004-03-21 08:25:54 UTC
Yes,

that's the position I choosed, and there it should work.


Tim
Comment 29 Srepfler Srgjan 2004-03-21 09:25:43 UTC
Thanks Tim!
I managed to compile it but I'm getting this run-time error
----
Unhandled Exception: System.DllNotFoundException: libgdk-win32-2.0-0.dll
in <0x00053> (wrapper managed-to-native) Gdk.Threads:gdk_threads_init ()
in <0x00007> Gdk.Threads:Init ()
in [0x0001c] (at /var/tmp/portage/monodevelop-0.1-r2/work/monodevelop-0.1/src/Main/StartUp/SharpDevelopMain.cs:55) ICSharpCode.SharpDevelop.SharpDevelopMain:Main (string[])
----
I'm running mono 0.31.0 and gtk-sharp 0.17

To Todd Berman, we are expecting the latest builds for gentoo and the getting up on-line of the subversion anonymous server :)
Comment 30 Tim Rädisch 2004-03-21 09:42:06 UTC
I suppose that's a gtk-sharp problem. That's a little curious programm, because it just builds the DLLs for which the original libraries are available and the othters not and just gave a little "No" and no real error or warning.

These are the DLLs which my gtk-sharp has made:
/usr/lib/art-sharp.dll
/usr/lib/gtkhtml-sharp.dll
/usr/lib/gtk-sharp.dll
/usr/lib/glib-sharp.dll
/usr/lib/vte-sharp.dll
/usr/lib/gconf-sharp.dll
/usr/lib/gconf-sharp-peditors.dll
/usr/lib/atk-sharp.dll
/usr/lib/pango-sharp.dll
/usr/lib/gnome-sharp.dll
/usr/lib/glade-sharp.dll
/usr/lib/gdk-sharp.dll

But I have nowhere a "libgdk-win32-2.0-0.dll", so I guess you are missing the gdk-sharp.dll. But if you have installed gnome, there should be gtk and gdk. Perhaps try do recompile gtk-sharp.


Tim
Comment 31 Srepfler Srgjan 2004-03-21 12:50:13 UTC
I have all of the libraries you have (plus I make some symlinks to /usr/local/lib using this script:
ls -l | grep dll | awk '{ print $9 }' | sed "s/\(.*\)/ln -sf \"\/usr\/lib\/\0\" \/usr\/local\/lib\//" | grep \" > /root/do && chmod +x /root/do
&& /root/do && rm /root/do
since if my mono libs are not there the compilation processes doesn't goes well, I must have messed up using the cvs-s or the build scripts availible on go-mono.
Anyhow, I'm inclined to think is something in the sources (it's not something you can invent like "libgdk-win32-2.0-0.dll")
Comment 32 Srepfler Srgjan 2004-03-24 03:55:53 UTC
I've recompiled gtk-sharp (having added new gtk libs) and now the libgdk-win32-2.0-0.dll error has changed to
----
Unhandled Exception: System.DllNotFoundException: gtksharpglue
in <0x00053> (wrapper managed-to-native) Gnome.Program:gtksharp_gnome_program_init (string,string,Gnome.ModuleInfo&,int,string[],int,Gnome.Program/PropertyArg[])
in <0x002ad> Gnome.Program:.ctor (string,string,Gnome.ModuleInfo,string[],object[])
in [0x00016] (at /var/tmp/portage/monodevelop-0.1-r2/work/monodevelop-0.1/src/Main/StartUp/SharpDevelopMain.cs:55) ICSharpCode.SharpDevelop.SharpDevelopMain:Main (string[])
-----

gtksharpglue?
Comment 33 Tim Rädisch 2004-03-24 04:42:10 UTC
I have the libraries libgtksharpglue.{la,so,a} and according to qpkg they're part of gtk-sharp. 

But perhabs monodevelop.com could help you more. I am in the lucky position, that it compiled without errors on my system, so I just can guess why it does not compile on your system.
Comment 34 Srepfler Srgjan 2004-03-24 05:34:39 UTC
Thanks Tim, one more question, does your gtk-sharp differ from the one in the official gentoo tree?
Comment 35 Tim Rädisch 2004-03-24 05:41:44 UTC
No, I use the 0.17-ebuild which is just a copy of 0.16. But I think the problem with gtk-sharp is, that after a successful compile, the range of function is not even the same, because it only wrapps what currently is installed.
Comment 36 Todd Berman (RETIRED) gentoo-dev 2004-04-01 19:32:02 UTC
closing this, as latexer (latexer@gentoo.org) has put monodevelop 0.2 and all its deps into portage.

To thank him, please send him an email telling him how much he rocks.
Comment 37 Cagnulein 2004-06-30 11:50:20 UTC
tracking...
Comment 38 Cagnulein 2004-06-30 22:05:16 UTC
when i try to emerge gtksourceview-sharp-cvs-0.1.0-r1.ebuild, it return the following result:

usr/bin/gapi-codegen --include /usr/share/gapi/atk-api.xml /usr/share/gapi/gdk-api.xml /usr/share/gapi/gdk-symbols.xml /usr/share/gapi/gnome-api.xml /usr/share/gapi/gtk-api.xml /usr/share/gapi/gtk-symbols.xml /usr/share/gapi/pango-api.xml --generate gtksourceview-api.xml \
--outdir=generated --customdir=. --assembly-name=gtksourceview-sharp && touch generated-stamp
Property has unknown Type unichar in Object GtkSourceView.SourceBuffer
rettype: gunichar method in Object GtkSourceView.SourceLanguage
Ellipsis parameter in ctor in Object Gtk.Widget
Ellipsis parameter in ctor in Object Gtk.Object

Generation Summary:
  Enums: 3  Structs: 1  Boxed: 1  Opaques: 2  Interfaces: 1  Objects: 11  Callbacks: 0
  Properties: 26  Signals: 12  Methods: 95  Constructors: 13  Throttled: 4
Total Nodes: 169

/usr/bin/mcs --unsafe --target library /pkg:gtk-sharp /pkg:gnome-sharp \
generated/*.cs ./GtkSourceView.cs ./AssemblyInfo.cs -o gtksourceview-sharp.dll
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/glib-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/pango-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/atk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gdk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gtk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gnome-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/glib-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/pango-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/atk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gdk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gtk-sharp.dll'
Log:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/art-sharp.dll'
Log:

Compilation failed: 12 error(s), 0 warnings
make[1]: *** [gtksourceview-sharp.dll] Error 1
make[1]: Leaving directory `/var/tmp/portage/gtksourceview-sharp-cvs-0.1.0-r1/work/gtksourceview-sharp/gtksourceview'
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/gtksourceview-sharp-cvs-0.1.0-r1 failed.
!!! Function src_compile, Line 35, Exitcode 2
!!! (no error message)
Comment 39 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-06-30 23:55:20 UTC
Did you emerge x11-libs/gtk-sharp?
Comment 40 Cagnulein 2004-07-01 03:38:26 UTC
yes

*  x11-libs/gtk-sharp
      Latest version available: 1.0
      Latest version installed: 1.0
      Size of downloaded files: 1,391 kB
      Homepage:    http://gtk-sharp.sourceforge.net/
      Description: Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries
      License:     LGPL-2.1
Comment 41 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-07-01 09:07:46 UTC
See Comment #13
Comment 42 Ed Catmur 2004-07-02 19:04:59 UTC
I think this may be relevant.

http://bugs.gentoo.org/show_bug.cgi?id=39048#c21

> This was a bug in the gtk-sharp ebuild. It's since been fixed. Please rsync and 
> re-emerge gtk-sharp. that should solve your problem.