Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39048 - muine ebuild - please
Summary: muine ebuild - please
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Low enhancement (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on: 35077 39676
Blocks:
  Show dependency tree
 
Reported: 2004-01-22 09:57 UTC by Dale K Dicks
Modified: 2004-12-27 05:41 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Muine 0.3.0 ebuild (muine-0.3.0.ebuild,921 bytes, text/plain)
2004-01-28 09:24 UTC, Ed Catmur
Details
0.3.2 with IUSE="flac" (muine-0.3.2.ebuild,983 bytes, patch)
2004-02-05 13:32 UTC, Ed Catmur
Details | Diff
muine-0.5.0.ebuild (muine-0.5.0.ebuild,974 bytes, text/plain)
2004-02-27 15:12 UTC, Vaclav Slavik
Details
Muine 0.5.0 ebuild with updated dependencies (muine-0.5.0.ebuild,901 bytes, text/plain)
2004-03-01 13:25 UTC, Robert Moss (RETIRED)
Details
muine-0.5.3.ebuild (muine-0.5.3.ebuild,959 bytes, text/plain)
2004-04-13 14:16 UTC, aent
Details
muine-0.5.3.ebuild (muine-0.5.3.ebuild,1.19 KB, text/plain)
2004-04-17 22:32 UTC, Joe McCann (RETIRED)
Details
muine-0.5.3.ebuild (muine-0.5.3.ebuild,1.19 KB, text/plain)
2004-04-17 22:41 UTC, Joe McCann (RETIRED)
Details
muine-0.6.1.ebuild (muine-0.6.1.ebuild,1.19 KB, text/plain)
2004-05-14 12:28 UTC, Hendrik Brandt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dale K Dicks 2004-01-22 09:57:25 UTC
I would like to see a muine ebuild.

I tried to make my own but unfortunately the version of mono in gentoo at the moment is too low for muine.

I tried to bump the version of mono up but the build failed.

http://people.nl.linux.org/~jorn/Muine/
Comment 1 Ed Catmur 2004-01-28 09:24:44 UTC
Created attachment 24544 [details]
Muine 0.3.0 ebuild

Depends include dev-dotnet/mono-0.29 and x11-libs/gtk-sharp-0.15. Neither of
these are in Portage yet. woohoo! - OTOH this is an absolutely gorgeous app and
well worth the effort.

I've dep'd gstreamer-0.6.0 and related gst stuff; it works fine for me with
0.6.4 but I have discouraging reports against 0.7.3. However it sounds like
0.7.4 works again.
Comment 3 Ed Catmur 2004-02-05 12:45:33 UTC
Latest version is 0.3.2, but a direct version bump works fine.
Good to see that gtk# 0.15 is in Portage, now we're just waiting for mono...
Comment 4 Ed Catmur 2004-02-05 13:32:07 UTC
Created attachment 25032 [details, diff]
0.3.2 with IUSE="flac"

It has flac now... :)
Comment 5 Brad Laue (RETIRED) gentoo-dev 2004-02-19 10:21:03 UTC
Mono 0.30 is now in portage. Is this a recent enough version? This looks like an excellent music player.
Comment 6 Dale K Dicks 2004-02-19 10:26:12 UTC
it should work with 0.30

Comment 7 Todd Berman (RETIRED) gentoo-dev 2004-02-19 12:39:49 UTC
Id love to put this into portage, but im a bit overloaded with non-gentoo stuff (MonoDevelop's release date in 8 days is kicking my ass :) ). If brad wants to put it in portage and handle that stuff, he can put it underneath the dotnet herd, and I will attempt to maintain it as best I can.
Comment 8 Vaclav Slavik 2004-02-27 15:12:55 UTC
Created attachment 26488 [details]
muine-0.5.0.ebuild

Upgraded to latest upstream release. I changed homepage URL to new one. New
requirements are mono >= 0.30.1 and gtk-sharp >= 0.17 (not yet in Portage, but
simple rename of 0.16 is sufficient).
Comment 9 Robert Moss (RETIRED) gentoo-dev 2004-03-01 13:25:08 UTC
Created attachment 26681 [details]
Muine 0.5.0 ebuild with updated dependencies

This ebuild contains the dependencies specified by configure.in as well as
those already noted, and cleans out unnecessary cruft from the ebuild.

Tested and working here. And it's very nice too!
Comment 10 foser (RETIRED) gentoo-dev 2004-03-06 05:36:13 UTC
the deps are not very correct.

It's a cool app, but this has no immediate priority in that it still is very much in development and has known bugs.
Comment 11 foser (RETIRED) gentoo-dev 2004-03-06 06:26:19 UTC
on request i'll be a little more verbose on the deps

these are observations without looking @ the source, so they are most likely incomplete.

* i happen to know muine doesn't work with gst dev releases atm, so those deps are better defined as =<gst>-0.6* . It doesn't really matter at this point, but the next major release isn't too far off.
* gdk-pixbuf dep is gtk1 pixbuf, so should be removed. gdk-pixbuf is part of gtk2
* flac dep, but no corresponding gst-flac dep
* likely missing intltool dep
* likely missing gettext dep (arguable base dep though)
* afaik muine doesn't have user docs yet, so the scrollkeeper dep seems unneeded (?)

Comment 12 aent 2004-04-13 14:16:07 UTC
Created attachment 29225 [details]
muine-0.5.3.ebuild

Updated to 0.5.3, added inherit mono and intltool/gst-plugins-flac deps and a
couple other things... builds and works for me :)
Comment 13 foser (RETIRED) gentoo-dev 2004-04-16 08:28:37 UTC
still crash-prone with the gst backend
Comment 14 Joe McCann (RETIRED) gentoo-dev 2004-04-17 22:32:59 UTC
Created attachment 29535 [details]
muine-0.5.3.ebuild

Here is an ebuild for 0.5.3 with proper and complete deps. Not just a bump of a
bump. Also seems as stable as any other gstreamer enabled application.
Comment 15 Joe McCann (RETIRED) gentoo-dev 2004-04-17 22:41:08 UTC
Created attachment 29536 [details]
muine-0.5.3.ebuild

fixed typo
Comment 16 Robert Moss (RETIRED) gentoo-dev 2004-04-19 19:53:06 UTC
I'm having crashing problems with 0.5.3, particularly with large amounts of music being loaded. I'll suggest to Joe that BMG keeps hold of this for a while longer.
Comment 17 Hendrik Brandt 2004-05-14 12:28:27 UTC
Created attachment 31437 [details]
muine-0.6.1.ebuild

depends on mono & gtk-sharp >= 0.91
Comment 18 Peter Johanson (RETIRED) gentoo-dev 2004-06-20 18:44:00 UTC
Okay, this puppy is in!

It uses the xine backend only if you have USE="xine", otherwise it uses gstreamer. It's the latest one, so it deps on the beta3 mono stuff. Marking TEST-REQUEST, please comment with success/failures.
Comment 19 Christopher Sachs 2004-06-22 21:42:28 UTC
Muine compiles and runs great on PPC. Please add ~ppc to the keywords of this ebuild. Thanks!

P.S. I hope somebody actually sees this comment here because it seems so overboard to open a new bug just to add four letters to an ebuild. There needs to be a good, low overhead way for people to notify the gentoo developers which packages compile on their arch that aren't listed in portage.
Comment 20 Rob Hudson 2004-06-30 13:50:29 UTC
muine-0.6.3 fails for me on x86.  It cannot find the libraries it is looking for.  Just installed mono-1.0 and gtk-sharp-1.0 this morning so the bug might be with those instead (not sure).  These libraries are located at 
/usr/lib/mono/gac/ on my system.

Tail end of failed compile:

error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/glib-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/pango-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/atk-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gdk-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gtk-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gnome-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/art-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/glade-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gconf-sharp.dll'
Log:
 
error CS0006: Cannot find assembly `/usr/lib/mono/gtk-sharp/gconf-sharp-peditors.dll'
Log:
 
Compilation failed: 10 error(s), 0 warnings
make[2]: *** [muine.exe] Error 1
make[2]: Leaving directory `/var/tmp/portage/muine-0.6.3/work/muine-0.6.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/muine-0.6.3/work/muine-0.6.3'
make: *** [all] Error 2
 
!!! ERROR: media-sound/muine-0.6.3 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure
Comment 21 Peter Johanson (RETIRED) gentoo-dev 2004-06-30 13:57:10 UTC
This was a bug in the gtk-sharp ebuild. It's since been fixed. Please rsync and re-emerge gtk-sharp. that should solve your problem.
Comment 22 Yo'av Moshe 2004-12-27 05:41:00 UTC
Muine 0.7 is out, now require Gtk# 1.9.1 or higher.