Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 437258 - media-video/vlc-9999 - Failed Patch: 300_all_pic.patch !
Summary: media-video/vlc-9999 - Failed Patch: 300_all_pic.patch !
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-05 04:17 UTC by bergelin
Modified: 2014-02-22 13:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
300_all_pic.patch.out (file_437258.txt,10.18 KB, text/plain)
2012-10-05 04:17 UTC, bergelin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bergelin 2012-10-05 04:17:08 UTC
Created attachment 325698 [details]
300_all_pic.patch.out

Live version of vlc fails while applying 300_all_pic.patch.

Emerge output below and file requested to be included as an attachment.


hedonia # emerge vlc
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-video/vlc-9999
 * vlc-patches-108.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                     [ ok ]
>>> Unpacking source...
>>> Unpacking vlc-patches-108.tar.bz2 to /var/tmp/portage/media-video/vlc-9999/work
GIT update -->
   repository:               git://git.videolan.org/vlc.git
   at the commit:            c311b5fa97b2cc32892a32b4fe578bb70884cc83
   branch:                   master
   storage directory:        "/usr/portage/distfiles/egit-src/vlc.git"
   checkout type:            bare repository
Cloning into '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'...
done.
Branch branch-master set up to track remote branch master from origin.
Switched to a new branch 'branch-master'
 * Starting bootstrap
generating modules/**/Makefile.am
..................................
+ autoreconf --install --force --verbose -I m4
ac-wrapper: warning: invalid WANT_AUTOCONF 'latest'; ignoring.
autoreconf-2.69: Entering directory `.'
autoreconf-2.69: running: autopoint --force
Copying file ABOUT-NLS
Copying file po/Makevars.template
Copying file po/Rules-quot
Copying file po/boldquot.sed
Copying file po/en@boldquot.header
Copying file po/en@quot.header
Copying file po/insert-header.sin
Copying file po/quot.sed
Copying file po/remove-potcdate.sin
autoreconf-2.69: running: aclocal -I m4 --force -I m4
am-wrapper: aclocal: warning: invalid WANT_AUTOMAKE 'latest'; ignoring.
autoreconf-2.69: configure.ac: tracing
autoreconf-2.69: running: libtoolize --copy --force
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `autotools'.
libtoolize: copying file `autotools/ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
am-wrapper: aclocal: warning: invalid WANT_AUTOMAKE 'latest'; ignoring.
autoreconf-2.69: running: /usr/bin/autoconf-2.69 --include=m4 --force
autoreconf-2.69: running: /usr/bin/autoheader-2.69 --include=m4 --force
autoreconf-2.69: running: automake --add-missing --copy --force-missing
am-wrapper: automake: warning: invalid WANT_AUTOMAKE 'latest'; ignoring.
configure.ac:408: warning: The 'AM_PROG_MKDIR_P' macro is deprecated, and will soon be removed.
configure.ac:408: You should use the Autoconf-provided 'AC_PROG_MKDIR_P' macro instead,
configure.ac:408: and use '$(MKDIR_P)' instead of '$(mkdir_p)'in your Makefile.am files.
configure.ac:64: installing 'autotools/compile'
configure.ac:23: installing 'autotools/config.guess'
configure.ac:23: installing 'autotools/config.sub'
configure.ac:27: installing 'autotools/install-sh'
configure.ac:27: installing 'autotools/missing'
bin/Makefile.am: installing 'autotools/depcomp'
autoreconf-2.69: Leaving directory `.'
+ rm -f po/Makevars.template
+ rm -f 'stamp-h*'
+ set +x
Successfully bootstrapped
 * Bootstrap finished
>>> Unpacked to /var/tmp/portage/media-video/vlc-9999/work/vlc-9999
>>> Unpacking vlc-patches-108.tar.bz2 to /var/tmp/portage/media-video/vlc-9999/work
>>> Source unpacked in /var/tmp/portage/media-video/vlc-9999/work
>>> Preparing source in /var/tmp/portage/media-video/vlc-9999/work/vlc-9999 ...
 * Applying various patches (bugfixes/updates) ...
 *   010_all_freetype-font.patch ...                                                                                                [ ok ]
 *   015_all_projectm-font.patch ...                                                                                                [ ok ]
 *   020_all_check_headers_regexps.patch ...                                                                                        [ ok ]
 *   300_all_pic.patch ...

 * Failed Patch: 300_all_pic.patch !
 *  ( /var/tmp/portage/media-video/vlc-9999/work/patches/300_all_pic.patch )
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-video/vlc-9999/temp/300_all_pic.patch.out

 * ERROR: media-video/vlc-9999 failed (prepare phase):
 *   Failed Patch: 300_all_pic.patch!
 * 
 * Call stack:
 *     ebuild.sh, line   89:  Called src_prepare
 *   environment, line 3700:  Called epatch '/var/tmp/portage/media-video/vlc-9999/work/patches'
 *   environment, line 2019:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 * 
 * If you need support, post the output of `emerge --info '=media-video/vlc-9999'`,
 * the complete build log and the output of `emerge -pqv '=media-video/vlc-9999'`.
 * The complete build log is located at '/var/tmp/portage/media-video/vlc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'
 * S: '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'

>>> Failed to emerge media-video/vlc-9999, Log file:

>>>  '/var/tmp/portage/media-video/vlc-9999/temp/build.log'

 * Messages for package media-video/vlc-9999:

 * Failed Patch: 300_all_pic.patch !
 *  ( /var/tmp/portage/media-video/vlc-9999/work/patches/300_all_pic.patch )
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-video/vlc-9999/temp/300_all_pic.patch.out
 * ERROR: media-video/vlc-9999 failed (prepare phase):
 *   Failed Patch: 300_all_pic.patch!
 * 
 * Call stack:
 *     ebuild.sh, line   89:  Called src_prepare
 *   environment, line 3700:  Called epatch '/var/tmp/portage/media-video/vlc-9999/work/patches'
 *   environment, line 2019:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 * 
 * If you need support, post the output of `emerge --info '=media-video/vlc-9999'`,
 * the complete build log and the output of `emerge -pqv '=media-video/vlc-9999'`.
 * The complete build log is located at '/var/tmp/portage/media-video/vlc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'
 * S: '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'
Comment 1 jospezial 2012-10-06 11:31:53 UTC
Duplicate of https://bugs.gentoo.org/show_bug.cgi?id=435102
and reported since 2012-09-15.

There is a new patch attachment 324092 [details, diff] works fine on amd64 but fails on x86-32 at compile phase.

The patch is hard to apply because the live ebuild downloads the patches.
Comment 2 David Heidelberg (okias) 2013-10-19 22:07:40 UTC
still valid?
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-10-21 01:24:09 UTC
Will need to re-evaluate if patching PIC is still needed today.