Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435102 - media-video/vlc-9999 - 300_all_pic.patch fails to apply
Summary: media-video/vlc-9999 - 300_all_pic.patch fails to apply
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-15 08:56 UTC by jospezial
Modified: 2013-10-11 12:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,172.32 KB, text/plain)
2012-09-15 08:56 UTC, jospezial
Details
300_all_pic.patch.out (300_all_pic.patch.out,9.96 KB, text/plain)
2012-09-15 09:02 UTC, jospezial
Details
build all modules with -fPIC (300_all_pic.patch,5.69 KB, patch)
2012-09-17 14:13 UTC, Christian Hagau
Details | Diff
build.log compile with the new patch (324092) failed on x86 (build.log,185.82 KB, text/plain)
2012-09-18 20:17 UTC, jospezial
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jospezial 2012-09-15 08:56:29 UTC
Created attachment 323860 [details]
build.log

>>> Preparing source in /var/tmp/portage/media-video/vlc-9999/work/vlc-9999 ...
 * Applying various patches (bugfixes/updates) ...
 *   010_all_freetype-font.patch ...
 [ ok ]
 *   015_all_projectm-font.patch ...
 [ ok ]
 *   020_all_check_headers_regexps.patch ...
 [ ok ]
 *   300_all_pic.patch ...

 * Failed Patch: 300_all_pic.patch !
 *  ( /var/tmp/portage/media-video/vlc-9999/work/patches/300_all_pic.patch )
 *
Comment 1 jospezial 2012-09-15 09:02:14 UTC
Created attachment 323862 [details]
300_all_pic.patch.out

***** 300_all_pic.patch *****
PWD: /var/tmp/portage/media-video/vlc-9999/work/vlc-9999

=============================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch  < '/var/tmp/portage/media-video/vlc-9999/work/patches/300_all_pic.patch'

=============================
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: vlc/modules/codec/loader/module.c
|===================================================================
|--- vlc.orig/modules/codec/loader/module.c
|+++ vlc/modules/codec/loader/module.c
--------------------------
No file to patch.  Skipping patch.
5 out of 5 hunks ignored
can't find file to patch at input line 56
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: vlc/modules/codec/loader/stubs.s
|===================================================================
|--- vlc.orig/modules/codec/loader/stubs.s
|+++ vlc/modules/codec/loader/stubs.s
--------------------------

and so on
Comment 2 Christian Hagau 2012-09-17 14:13:00 UTC
Created attachment 324092 [details, diff]
build all modules with -fPIC

commit fcc20e9224f621e0267350d4483896520ab57017 deleted modules/codec/loader/Makefile.am, patch builds all modules with -fPIC
It would probably suffice to patch modules/codec/Makefile.am and someone should test this on x86-32.
Comment 3 jospezial 2012-09-18 20:17:27 UTC
Created attachment 324244 [details]
build.log compile with the new patch (324092) failed on x86

The new patch (attachment 324092 [details, diff]) works fine on amd64 but fails on x86 at compile phase:

make[4]: Entering directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999/modules/audio_output'
  CC       libadummy_plugin_la-adummy.lo
  CC       libafile_plugin_la-file.lo
In file included from adummy.c:29:0:
../../config.h:792:0: Warnung: #pragma STDC FENV_ACCESS wird ignoriert [-Wunknown-pragmas]
../../config.h:793:0: Warnung: #pragma STDC FP_CONTRACT wird ignoriert [-Wunknown-pragmas]
  CC       libamem_plugin_la-amem.lo
In file included from file.c:30:0:
../../config.h:792:0: Warnung: #pragma STDC FENV_ACCESS wird ignoriert [-Wunknown-pragmas]
../../config.h:793:0: Warnung: #pragma STDC FP_CONTRACT wird ignoriert [-Wunknown-pragmas]
  CC       liboss_plugin_la-oss.lo
In file included from amem.c:22:0:
../../config.h:792:0: Warnung: #pragma STDC FENV_ACCESS wird ignoriert [-Wunknown-pragmas]
../../config.h:793:0: Warnung: #pragma STDC FP_CONTRACT wird ignoriert [-Wunknown-pragmas]
  CC       liboss_plugin_la-packet.lo
In file included from oss.c:27:0:
../../config.h:792:0: Warnung: #pragma STDC FENV_ACCESS wird ignoriert [-Wunknown-pragmas]
../../config.h:793:0: Warnung: #pragma STDC FP_CONTRACT wird ignoriert [-Wunknown-pragmas]
oss.c: In Funktion »Open«:
oss.c:141:22: Fehler: »AFMT_S32_BE« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:141:22: Anmerkung: jeder nicht deklarierte Bezeichner wird nur einmal für jede Funktion, in der er vorkommt, gemeldet
oss.c:144:22: Fehler: »AFMT_S32_LE« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:261:5: Fehler: unbekannter Typname: »oss_sysinfo«
oss.c:262:20: Fehler: »SNDCTL_SYSINFO« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:269:197: Fehler: Anfrage nach Element »product« in etwas, was keine Struktur oder Variante ist
oss.c:269:209: Fehler: Anfrage nach Element »version« in etwas, was keine Struktur oder Variante ist
oss.c:269:221: Fehler: Anfrage nach Element »versionnum« in etwas, was keine Struktur oder Variante ist
oss.c:269:236: Fehler: Anfrage nach Element »license« in etwas, was keine Struktur oder Variante ist
oss.c:272:31: Fehler: Anfrage nach Element »numaudios« in etwas, was keine Struktur oder Variante ist
oss.c:274:13: Fehler: unbekannter Typname: »oss_audioinfo«
oss.c:274:13: Fehler: Feldname nicht in Datensatz- oder union-Initialisierung
oss.c:274:13: Fehler: (nahe der Initialisierung für »ai«)
oss.c:276:28: Fehler: »SNDCTL_AUDIOINFO« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:281:19: Fehler: Anfrage nach Element »caps« in etwas, was keine Struktur oder Variante ist
oss.c:281:28: Fehler: »PCM_CAP_HIDDEN« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:281:43: Fehler: »PCM_CAP_MODEM« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:283:21: Fehler: Anfrage nach Element »caps« in etwas, was keine Struktur oder Variante ist
oss.c:283:29: Fehler: »PCM_CAP_OUTPUT« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:285:20: Fehler: Anfrage nach Element »enabled« in etwas, was keine Struktur oder Variante ist
oss.c:288:32: Fehler: Anfrage nach Element »devnode« in etwas, was keine Struktur oder Variante ist
oss.c:289:33: Fehler: Anfrage nach Element »name« in etwas, was keine Struktur oder Variante ist
oss.c: In Funktion »Pause«:
oss.c:378:24: Fehler: »SNDCTL_DSP_SILENCE« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c:378:45: Fehler: »SNDCTL_DSP_SKIP« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c: In Funktion »Flush«:
oss.c:391:16: Fehler: »SNDCTL_DSP_HALT_OUTPUT« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c: In Funktion »VolumeSync«:
oss.c:400:20: Fehler: »SNDCTL_DSP_GETPLAYVOL« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c: In Funktion »VolumeSet«:
oss.c:421:34: Fehler: »SNDCTL_DSP_SETPLAYVOL« nicht deklariert (erste Benutzung in dieser Funktion)
oss.c: In Funktion »MuteSet«:
oss.c:438:20: Fehler: »SNDCTL_DSP_SETPLAYVOL« nicht deklariert (erste Benutzung in dieser Funktion)
make[4]: *** [liboss_plugin_la-oss.lo] Fehler 1
make[4]: *** Warte auf noch nicht beendete Prozesse...
In file included from packet.c:22:0:
../../config.h:792:0: Warnung: #pragma STDC FENV_ACCESS wird ignoriert [-Wunknown-pragmas]
../../config.h:793:0: Warnung: #pragma STDC FP_CONTRACT wird ignoriert [-Wunknown-pragmas]
make[4]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999/modules/audio_output'
make[3]: *** [all] Fehler 2
make[3]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999/modules/audio_output'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999/modules'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'
make: *** [all] Fehler 2
 * ERROR: media-video/vlc-9999 failed (compile phase):
Comment 4 jospezial 2013-04-10 14:00:38 UTC
Since Revision 1.184 2013/04/02 (Update to match upstream) of vlc-9999 are the lines for the vlc-patches-${PATCHLEVEL}.tar.bz2 disabled.

So the 300_all_pic.patch is disabled too.


Here you can see the only patches that are used:

[ ok ]
 * Running elibtoolize in: vlc-9999/autotools/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.2 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-video/vlc-9999/work/vlc-9999 ... 

At the moment this bug is not reproduceable cause of the disabled patches.

I don't know if they are enabled in future again. Do we wanna set this bug to fixed?