Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436958 - app-office/projectlibre: the open source replacement of Microsoft Project
Summary: app-office/projectlibre: the open source replacement of Microsoft Project
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://www.projectlibre.org/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 12:39 UTC by sphakka
Modified: 2017-01-08 20:06 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ported openproj ebuild to install ProjectLibre (projectlibre-bin-1.5.2.ebuild,1.53 KB, text/plain)
2013-01-18 18:28 UTC, Dirk Tilger
Details
Updated ebuild for latest version (projectlibre-bin-1.6.1.tar.gz,8.91 KB, application/gzip)
2015-07-19 17:18 UTC, Jeff Sweeney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sphakka 2012-10-02 12:39:00 UTC
According to <http://sourceforge.net/projects/openproj/>, OpenProj (currently in gentoo tree as ~v1.4) has been superseded by ProjectLibre.

It's Java-1.6-based; I'm currently testing release 1_5.beta5 which works out-of-the-box. It'd be nice to have an ebuild.


Reproducible: Always
Comment 1 Dirk Tilger 2013-01-18 18:28:17 UTC
Created attachment 336068 [details]
Ported openproj ebuild to install ProjectLibre
Comment 2 Jason Khanlar 2014-09-20 06:18:46 UTC
The ProjectLibre seems active. I shall try to make an ebuild for this.
Comment 3 Jeff Sweeney 2015-07-19 17:18:00 UTC
Created attachment 407160 [details]
Updated ebuild for latest version

Updated the posted build to match the latest version available for this project. Included .desktop edited from OpenProj to match new program names, and .png application icon extracted from the program .jar since the file downloads in the original version failed.
Icon: projectlibre.jar/com/projity/pm/graphic/images/projectlibre-application.png

Not sure if anyone is still maintaining this, and I've never done any ebuild work before, but it seems to be installing and running ok so hopefully it's not too badly done.
Comment 4 Stephen Bosch 2015-11-19 10:47:22 UTC
I would like to see this in main tree also.
Comment 5 Andreas K. Hüttel gentoo-dev 2016-12-30 16:55:41 UTC
@whoever interested: Please consider becoming proxy-maintainer of the package. 

I.e., head to #gentoo-proxy-maint on IRC, leave a message about the packagage and your ebuild, and get your ebuild reviewed and added to the tree with you as maintainer...
Comment 6 Chris Reffett gentoo-dev Security 2017-01-08 20:06:03 UTC
Sure, I'll maintain it. Added, lastrites for openproj-bin sent to g-d-a.