Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190636 - app-office/openproj-1.4: new ebuild
Summary: app-office/openproj-1.4: new ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on:
Reported: 2007-08-29 12:34 UTC by Robert Buchholz (RETIRED)
Modified: 2012-10-05 13:37 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---

Ebuild for openproj-0.9.3 (openproj-bin-0.9.3.ebuild,880 bytes, text/plain)
2007-09-07 14:16 UTC, Julien Cynober
The CPAL licence, html format (CPAL.html,28.91 KB, text/html)
2007-09-07 14:17 UTC, Julien Cynober
openproj-0.9.3-fix-launcher.patch (openproj-0.9.3-fix-launcher.patch,379 bytes, patch)
2007-09-07 14:19 UTC, Julien Cynober
Details | Diff
openproj-bin-0.9.4.ebuild (openproj-bin-0.9.4.ebuild,886 bytes, text/plain)
2007-09-07 14:43 UTC, Julien Cynober
openproj-0.9.4-fix-launcher.patch (openproj-0.9.4-fix-launcher.patch,335 bytes, patch)
2007-09-07 14:44 UTC, Julien Cynober
Details | Diff
openproj-bin-1.0.ebuild (openproj-bin-1.0.ebuild,1.18 KB, text/plain)
2008-02-11 13:47 UTC, Christian Affolter
openproj-1.0-fix-launcher.patch (openproj-1.0-fix-launcher.patch,343 bytes, patch)
2008-02-11 13:48 UTC, Christian Affolter
Details | Diff
openproj-bin-1.1.ebuild (openproj-bin-1.1.ebuild,1.19 KB, text/plain)
2008-06-06 09:21 UTC, Christian Affolter
openproj-1.1-fix-launcher.patch (openproj-1.1-fix-launcher.patch,351 bytes, patch)
2008-06-06 09:22 UTC, Christian Affolter
Details | Diff
openproj-bin-1.4.ebuild (openproj-bin-1.4.ebuild,1.19 KB, text/plain)
2008-10-09 12:22 UTC, Artem Sidorenko
openproj-1.4-fix-launcher.patch (openproj-1.4-fix-launcher.patch,351 bytes, text/plain)
2008-10-09 12:23 UTC, Artem Sidorenko
=app-office/openproj-1.4 source ;) (openproj-1.4.ebuild,1.81 KB, text/plain)
2009-10-12 08:06 UTC, Oleh Kravchenko
For source ebuild only!! (openproj-1.4-fix-launcher.patch,429 bytes, patch)
2009-10-12 08:07 UTC, Oleh Kravchenko
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Buchholz (RETIRED) gentoo-dev 2007-08-29 12:34:33 UTC
"OpenProj by Projity is a desktop replacement of Microsoft Project. OpenProj has equivalent functionality, a familiar user interface and even opens existing MSProject files. OpenProj is interoperable with Project, with a Gantt Chart and PERT chart etc."

In a press release they stated having Sabayon support, but I couldn't find any ebuild in their overlay.
Comment 1 Julien Cynober 2007-09-07 14:16:16 UTC
Created attachment 130268 [details]
Ebuild for openproj-0.9.3

I wrote an ebuild for the downloadable version of openproj (see attachment). I called it 'openproj-bin' since the source code is not yet available - you can download only a 'jar' archive. The license of openproj, called "Common Public Attribution Licence" is not listed in portage, so it should be included with the ebuild in the 'files' directory. I didn't read it carefully, so I don't know if it is a truly open source licence (I'm not sure since the source code is not provided). I wrote a little patch so that the program can be launched from any directory, and not only from where it is installed (e.g. /opt/openproj/).
Comment 2 Julien Cynober 2007-09-07 14:17:52 UTC
Created attachment 130271 [details]
The CPAL licence, html format
Comment 3 Julien Cynober 2007-09-07 14:19:09 UTC
Created attachment 130272 [details, diff]
Comment 4 Julien Cynober 2007-09-07 14:23:06 UTC
Comment on attachment 130268 [details]
Ebuild for openproj-0.9.3

><HTML><HEAD/><BODY><PRE># Copyright 1999-2007 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>inherit eutils
>DESCRIPTION="OpenProj is a free, open source desktop alternative to Microsoft Project"
>src_unpack() {
>	unpack ${A}
>	cd "${S}"
>	epatch "${FILESDIR}/openproj-${PV}-fix-launcher.patch"
>src_install() {
>	local installDir=/opt/openproj-${PV}
>	insinto /opt
>	doins -r "${S}"
>	fperms a+rx ${installDir}/
>	# Symlink the laucher script
>	dosym ${installDir}/ /usr/bin/openproj
>	# Symlink the directory and the jar to have them without version number
>        dosym ${installDir} /opt/openproj
Comment 5 Julien Cynober 2007-09-07 14:43:54 UTC
Created attachment 130279 [details]

New ebuild
Comment 6 Julien Cynober 2007-09-07 14:44:50 UTC
Created attachment 130281 [details, diff]

New version of the patch, since the launcher script has changed in this new version.
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2007-10-12 11:18:20 UTC
Maybe you can use virtual/jre instead of a hard coded jre.
Comment 8 Julien Cynober 2007-10-13 07:07:30 UTC
According to upstream, openproj is compatible only with sun's jre, that's why I didn't use virtual/jre.
Comment 9 infobox.oleg 2007-11-05 23:38:52 UTC
The ebuild should also look for the sun-jdk and if present, it shouldn't require sun-jre-bin. Tested with sun-jdk. and it works.
Comment 10 Christian Affolter 2008-02-11 13:46:00 UTC
Attached is a version bump (1.0) with the following enhancements:
- RDEPEND virtual/jre instead of the hard coded
- Desktop menu entry and icon
- Patched launcher script

Have fun :)
Comment 11 Christian Affolter 2008-02-11 13:47:11 UTC
Created attachment 143204 [details]

version bump for 1.0 and some minor enhancements
Comment 12 Christian Affolter 2008-02-11 13:48:58 UTC
Created attachment 143206 [details, diff]

Updated launcher patch
Comment 13 Christian Affolter 2008-06-06 09:17:37 UTC
- Version bump 1.0 --> 1.1
- added (and tested) the ~amd64 keyword
- tiny launcher patch modification
Comment 14 Christian Affolter 2008-06-06 09:21:18 UTC
Created attachment 155687 [details]
Comment 15 Christian Affolter 2008-06-06 09:22:22 UTC
Created attachment 155689 [details, diff]
Comment 16 Urs Joss 2008-07-21 19:32:38 UTC
Just a quick note: version 1.2 is out.

renaming both the ebuild and the launcher pad to 1.2 did the job.

HTH, Urs
Comment 17 Donnie Berkholz (RETIRED) gentoo-dev 2008-08-12 03:35:08 UTC
Straight copy still works for 1.3.1.
Comment 18 Matthew Kohn 2008-09-21 15:48:51 UTC
any update on when this will actually be in portage or some other overlay.  They are up to version 1.3.1 Thanks
Comment 19 Marian Kyral 2008-09-24 10:20:13 UTC
I can confirm. The ebuild renamed to 1.3.1 works correctly on amd64.
Comment 20 Matthew Kohn 2008-09-24 15:14:10 UTC
Why can't i find it in my portage overlay... is there a different openlay than the default one that it is in. Sorry this is my first request like this.
Comment 21 Artem Sidorenko 2008-10-09 12:22:02 UTC
Created attachment 167732 [details]

version bump to 1.4
Comment 22 Artem Sidorenko 2008-10-09 12:23:12 UTC
Created attachment 167734 [details]

version bump to 1.4
Comment 23 pip 2008-10-25 10:00:57 UTC
openproj-bin-1.4.ebuild installs openproj twice to /opt. on the one hand it goes to /opt/openproj and on the other hand to /opt/openproj-1.4...
Comment 24 pip 2008-10-25 10:03:56 UTC
(In reply to comment #23)
> openproj-bin-1.4.ebuild installs openproj twice to /opt. on the one hand it
> goes to /opt/openproj and on the other hand to /opt/openproj-1.4...

i am sorry ... one is just a symlink
Comment 25 Christian Schwinn 2008-11-27 11:26:51 UTC
Has anybody looked at the source?
Comment 26 Jason Wigg 2009-04-11 06:27:27 UTC
I notice these ebuilds are all for openproj-bin. Has anyone made a source ebuild?
Comment 27 Oleh Kravchenko 2009-10-12 08:06:23 UTC
Created attachment 206836 [details]
=app-office/openproj-1.4 source ;)
Comment 28 Oleh Kravchenko 2009-10-12 08:07:30 UTC
Created attachment 206837 [details, diff]
For source ebuild only!!
Comment 29 quaerentus 2010-05-24 10:59:00 UTC
If somebody runs into problems with multiple "cannot find symbol"-messages trying to build OpenProj: it seems to require sun-jdk and fail with icedtea6-bin. See and for details.
Comment 30 Florian Berger 2010-06-17 10:20:41 UTC
(In reply to comment #29)

openproj just installed fine. Thanks for the hint.

This maybe should be mentioned in the ebuild output messages?

Comment 31 Nuno Silva 2010-09-18 08:56:02 UTC
I was able to compile openproj after setting sun-jdk as the system VM. It opens (I can't say more as that is all I tried for now).

I tried setting JAVA_PKG_FORCE_VM="sun-jdk-1.6", either in the ebuild itself, either while invoking emerge, and it didn't work, not even when set together with JAVA_PKG_ALLOW_VM_CHANGE="yes".

If there's an option to pick a specific JDK for compilation, the ebuild can just use that. (But this is still an issue, I think icedtea was supposed to be sun-compatible, if openproj is looking for sun-specific non-documented code, it should be fixed.)
Comment 32 Christopher Head 2010-09-26 05:34:48 UTC
As this has been maintainer-wanted for three years now, has anyone thought of adding it to the Sunrise overlay at <>? I'll do it myself, if nobody else wants to.
Comment 33 Attila Fazekas 2010-11-13 10:23:12 UTC
(In reply to comment #32)
> As this has been maintainer-wanted for three years now, has anyone thought of
> adding it to the Sunrise overlay at <>?
> I'll do it myself, if nobody else wants to.

Please add it to the sunrise.
Comment 34 SpanKY gentoo-dev 2010-12-01 13:36:34 UTC
ive cleaned up & merged openproj-bin-1.4 since i needed it.  i'm not about to work on the source one though as i have little java packaging experience.
Comment 35 Christopher Head 2010-12-14 06:23:36 UTC
I also know next to nothing about Gentoo's Java mechanisms, so I'll leave off Sunrising as SpanKY has committed the binary package. It does what I need.
Comment 36 Sergey Popov gentoo-dev 2012-10-02 14:31:36 UTC
As said on homepage - "As of 2012-10-01, this project may now be found at", so i think this bug should be closed as WONTFIX in favor of bug #436958