Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 436282 - media-plugins/gimp-lensfun - Lensfun plugin for GIMP
Summary: media-plugins/gimp-lensfun - Lensfun plugin for GIMP
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Mario Kicherer
URL: http://lensfun.sebastiankraft.net/
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2012-09-26 10:16 UTC by Mario Kicherer
Modified: 2012-09-30 10:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gimp-lensfun-0.2.2.ebuild (gimp-lensfun-0.2.2.ebuild,600 bytes, text/plain)
2012-09-26 10:16 UTC, Mario Kicherer
Details
added license and removed own fault handling (gimp-lensfun-0.2.2.ebuild,576 bytes, text/plain)
2012-09-29 11:08 UTC, Mario Kicherer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Kicherer 2012-09-26 10:16:05 UTC
Gimp-lensfun is a plugin for GIMP that corrects lens distortions using the lensfun database. I wrote an ebuild and it works for me so far. The lensfun library and the other dependencies are already in portage.

Homepage: http://lensfun.sebastiankraft.net/




Reproducible: Always
Comment 1 Mario Kicherer 2012-09-26 10:16:52 UTC
Created attachment 325018 [details]
gimp-lensfun-0.2.2.ebuild
Comment 2 Mario Kicherer 2012-09-26 10:20:29 UTC
Ah, forgot the license, it's GPL-3.
Comment 3 Jeroen Roovers gentoo-dev 2012-09-26 13:35:13 UTC

*** This bug has been marked as a duplicate of bug 373479 ***
Comment 4 Mario Kicherer 2012-09-26 13:47:58 UTC
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 373479 ***

Bug 373479 is an ebuild for the standalone lensfun library that is already in portage. This ebuild builds a GIMP plugin that enables the lensfun functionality in GIMP. Other applications like darktable or digikam have builtin support for lensfun but GIMP doesn't. It seems this plugin is from the same maintainer as the lensfun library.

I don't know the recommended procedure in this case, but I think this bug is not a duplicate and should be reopened. Thank you!
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2012-09-29 10:11:17 UTC
Thank you for your ebuild. If you are interested in maintaining it in portage tree, have a look here[1] and contact proxy-maint@gentoo.org

[1]http://www.gentoo.org/proj/en/qa/proxy-maintainers/index.xml
Comment 6 Mario Kicherer 2012-09-29 10:49:31 UTC
I'm interested in maintaining this package. :)
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2012-09-29 10:52:47 UTC
Thanks. What would the appropriate category for this package be? media-plugins?
Comment 8 Mario Kicherer 2012-09-29 10:54:46 UTC
Yes, the other gimp plugins are also in media-plugins/
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2012-09-29 10:59:15 UTC
The ebuild needs some fixing

The LICENSE variable must NOT be empty. So are you sure that all runtime dependencies are build time dependencies as well? For example, do you really need gimp installed in order to build this package? Also the || die should be removed from the 'doexe' command as it is not needed in EAPI4
Comment 10 Mario Kicherer 2012-09-29 11:08:52 UTC
Created attachment 325296 [details]
added license and removed own fault handling

Ah, I forgot to upload again after adding the license.

The source file includes headers from all three dependencies. Is this sufficient or should I unmerge them to test?
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2012-09-29 11:17:59 UTC
(In reply to comment #10)
> Created attachment 325296 [details]
> added license and removed own fault handling
> 
> Ah, I forgot to upload again after adding the license.
> 
> The source file includes headers from all three dependencies. Is this
> sufficient or should I unmerge them to test?

Then I suspect that all 3 of them are build dependencies as well. If you want to do more testing then you are welcomed to try
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2012-09-30 10:36:15 UTC
+*gimp-lensfun-0.2.2 (30 Sep 2012)
+
+  30 Sep 2012; Markos Chandras <hwoarang@gentoo.org> +gimp-lensfun-0.2.2.ebuild,
+  +metadata.xml:
+  Initial commit. Thanks to Mario <mkarts@empanyc.net> who will proxy-maintain
+  it. Bug #436282