Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 435684 - dev-lang/boo-0.9.4.9 - [exec] .../work/boo-0.9.4.9/default.build(1049,4): [exec] External Program Failed: .../work/boo-0.9.4.9/bin/booi.exe (return code was 127)
Summary: dev-lang/boo-0.9.4.9 - [exec] .../work/boo-0.9.4.9/default.build(1049,4): [e...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: dotnet
URL: http://jira.codehaus.org/browse/BOO-1346
Whiteboard: Pending Removal: 2013-07-15
Keywords: NeedPatch, PMASKED
: 437796 466186 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-20 19:03 UTC by Juergen Rose
Modified: 2013-07-21 07:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/dev-lang/boo-0.9.4.9/temp/build.log (build.log,21.34 KB, text/plain)
2012-09-20 19:03 UTC, Juergen Rose
Details
fix build fail due missing pt directory (boo-0.9.4.9-pt-fail.patch,427 bytes, text/plain)
2013-04-22 08:55 UTC, Kai Korla
Details
fix build fail due missing pt directory (boo-0.9.4.9-pt-fail.patch,428 bytes, patch)
2013-04-22 09:21 UTC, Kai Korla
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-09-20 19:03:24 UTC
Created attachment 324430 [details]
/var/tmp/portage/dev-lang/boo-0.9.4.9/temp/build.log

'emerge boo' fails with:
...
Function platform::is-win32 is deprecated.  Use the is-windows function instead.
     [copy] Copying 1 file to '/var/tmp/portage/dev-lang/boo-0.9.4.9/work/boo-0.9.4.9/build'.
...
     [copy] Copying 1 directory to '/var/tmp/portage/dev-lang/boo-0.9.4.9/image//usr/lib/boo/pt'.

BUILD FAILED - 0 non-fatal error(s), 23 warning(s)

/var/tmp/portage/dev-lang/boo-0.9.4.9/work/boo-0.9.4.9/default.build(623,4):
Cannot copy '/var/tmp/portage/dev-lang/boo-0.9.4.9/work/boo-0.9.4.9/build/pt' to '/var/tmp/portage/dev-lang/boo-0.9.4.9/image/usr/lib/boo/pt'.
    Cannot copy directory: Source Directory /var/tmp/portage/dev-lang/boo-0.9.4.9/work/boo-0.9.4.9/build/pt does not exist





root@leopard:/root(2)# emerge --info '=dev-lang/boo-0.9.4.9'
Portage 2.1.11.18 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.5.4-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
Timestamp of tree: Thu, 20 Sep 2012 14:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.4
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo lisp science sunrise bicatali x11 sage-on-gentoo arcon ibormuth java-overlay x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr ru"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/bicatali /var/lib/layman/x11 /var/lib/layman/sage-on-gentoo /var/lib/layman/arcon /var/lib/layman/ibormuth /var/lib/layman/java-overlay /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 sse4 ssl subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox visio vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-lang/boo-0.9.4.9 was built with the following:
USE="(multilib)"



root@leopard:/root(3)# emerge -pqv '=dev-lang/boo-0.9.4.9'
[ebuild   R   ] dev-lang/boo-0.9.4.9
Comment 1 Pacho Ramos gentoo-dev 2012-09-22 11:13:48 UTC
Yes, I can also reproduce but couldn't find any fix, either was able to register in upstream bug tracker :S, if you are able to and report it to upstream that would be great
Comment 2 Juergen Rose 2012-10-04 06:50:18 UTC
I filed also a bug at http://jira.codehaus.org/browse/BOO-1346.
Comment 3 Pacho Ramos gentoo-dev 2012-10-04 18:39:15 UTC
Thanks
Comment 4 Pacho Ramos gentoo-dev 2012-10-10 06:29:54 UTC
*** Bug 437796 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2013-04-17 16:38:38 UTC
*** Bug 466186 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2013-04-17 16:39:16 UTC
Will treeclean this as looks like no fix is available and upstream don't care
Comment 7 Kai Korla 2013-04-22 08:55:30 UTC
Created attachment 346262 [details]
fix build fail due missing pt directory

Hi,

I have researched a bit and I think the lines can removed from the build file. I have attached an patch file.

More information: https://github.com/bamboo/boo/commit/d5a408987c916fdd5ee04f7dbf56dc69e37322be

regards
Kai
Comment 8 Kai Korla 2013-04-22 09:21:13 UTC
Created attachment 346264 [details, diff]
fix build fail due missing pt directory
Comment 9 Pacho Ramos gentoo-dev 2013-05-24 21:11:56 UTC
But it's also incompatible with mono-3 :S
Comment 10 Pacho Ramos gentoo-dev 2013-07-21 07:19:45 UTC
dropped