Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432874 - www-plugins/gnash-0.8.10-r2[kde] fails to build with gcc-4.7
Summary: www-plugins/gnash-0.8.10-r2[kde] fails to build with gcc-4.7
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chí-Thanh Christopher Nguyễn
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.7
  Show dependency tree
 
Reported: 2012-08-26 15:23 UTC by Andreas Sturmlechner
Modified: 2012-10-16 00:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnash-0.8.10-r2 build.log (gnash-build.log,524.00 KB, text/plain)
2012-08-26 15:23 UTC, Andreas Sturmlechner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2012-08-26 15:23:50 UTC
Created attachment 322278 [details]
gnash-0.8.10-r2 build.log

Building current stable gnash version fails with gcc-4.7, see log attached.
Comment 1 Andreas Sturmlechner gentoo-dev 2012-08-26 15:37:04 UTC
A WORKSFORME fix can be found in bug 432876.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2012-09-24 12:07:30 UTC

*** This bug has been marked as a duplicate of bug 423675 ***
Comment 3 Andreas Sturmlechner gentoo-dev 2012-09-30 09:18:59 UTC
I need to reopen this bug because the gnash package found in portage still fails to build without the upstream patch for gcc-4.7.
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2012-09-30 19:36:46 UTC
Works fine here.  What USE flags?
Comment 5 Andreas Sturmlechner gentoo-dev 2012-09-30 20:21:39 UTC
The following USE-flags were set (not much has changed since the attached build log):

X agg dbus egl ffmpeg gtk kde nls nsplugin opengl sdl sdl-sound ssl vaapi

The error seems to happen within the kde4 code.
Comment 6 Andreas Sturmlechner gentoo-dev 2012-09-30 21:20:50 UTC
Indeed, builds with USE="-kde".
Comment 7 Andreas Sturmlechner gentoo-dev 2012-10-02 07:55:57 UTC
Anyway, just to make sure it doesn't get lost: Some time ago I've posted the upstream fix twice, both in the -unrelated- bug 423675 and in my other bug 432876 for gnash, I thought that was enough duplicity already.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-10-16 00:26:37 UTC
Fixed in CVS.