Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432462 - net-im/jabber-base should not provide /var/run/jabber directory
Summary: net-im/jabber-base should not provide /var/run/jabber directory
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: keepdir-var-run_lock
  Show dependency tree
 
Reported: 2012-08-23 16:14 UTC by Alexander Tsoy
Modified: 2020-10-11 22:31 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Tsoy 2012-08-23 16:14:26 UTC
There is a symlink /var/run -> /run in latest stage3 tarballs.

$ tar tvf stage3-amd64-20120621.tar.bz2 ./var/run
lrwxrwxrwx root/root         0 2012-06-21 06:45 ./var/run -> /run

Since /run is mounted as tmpfs it is a bad idea to create directories in /var/run by ebuild. Any directories in /run or /var/run should be created by init scripts.

Reproducible: Always
Comment 1 Larry the Git Cow gentoo-dev 2020-10-11 22:31:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0363f00331c4ea0e2a664303569adc8ec66ddf7e

commit 0363f00331c4ea0e2a664303569adc8ec66ddf7e
Author:     Conrad Kostecki <conikost@gentoo.org>
AuthorDate: 2020-10-11 22:06:52 +0000
Commit:     Conrad Kostecki <conikost@gentoo.org>
CommitDate: 2020-10-11 22:28:52 +0000

    net-im/jabber-base: bump to EAPI=7, migrate to GLEP 81
    
    Also dropping '/var/run/jabber' from default install, since this
    directory should be created by each jabber service upon start.
    
    Closes: https://bugs.gentoo.org/432462
    Closes: https://bugs.gentoo.org/520552
    Closes: https://bugs.gentoo.org/670286
    Package-Manager: Portage-3.0.8, Repoman-3.0.1
    Signed-off-by: Conrad Kostecki <conikost@gentoo.org>

 net-im/jabber-base/jabber-base-0.01-r2.ebuild | 42 +++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)