Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430478 - sys-boot/plymouth-0.8.6.1 version bump
Summary: sys-boot/plymouth-0.8.6.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Enrico Tagliavini
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 359483 428146 439786
  Show dependency tree
 
Reported: 2012-08-08 17:25 UTC by Leho Kraav (:macmaN @lkraav)
Modified: 2013-03-10 19:50 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
plymouth 0.8.8 ebuild with systemd support (plymouth-0.8.8.ebuild,2.18 KB, text/plain)
2012-12-15 18:50 UTC, Enrico Tagliavini
Details
plymouth 0.8.8 ebuild with systemd support (plymouth-0.8.8-r1.ebuild,2.45 KB, text/plain)
2012-12-16 13:54 UTC, Enrico Tagliavini
Details
plymouth 0.8.8 ebuild with systemd support (plymouth-0.8.8-r1.ebuild,2.34 KB, text/plain)
2013-01-22 10:10 UTC, Enrico Tagliavini
Details
plymouth 0.8.8 ebuild with systemd support (plymouth-0.8.8-r1.ebuild,2.40 KB, text/plain)
2013-01-24 22:27 UTC, Enrico Tagliavini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leho Kraav (:macmaN @lkraav) 2012-08-08 17:25:10 UTC
copying 0.8.4::gentoo ebuild has some troubles:

 * QA Notice: Excessive files found in the / partition
 * /mnt/datapool/tmp/portage/sys-boot/plymouth-0.8.6.1/image/lib/libply.la
 * /mnt/datapool/tmp/portage/sys-boot/plymouth-0.8.6.1/image/lib/libply-splash-core.la

 * ERROR: sys-boot/plymouth-0.8.6.1 failed:
 *   static archives (*.a) and libtool library files (*.la) do not belong in /


Reproducible: Always
Comment 1 Leho Kraav (:macmaN @lkraav) 2012-08-08 17:36:49 UTC
Something's up with prune_libtool_files() failing for this ebuild as well, related discussion at [1]. In the meanwhile, I took the find line from bug 421197 and that let the build process finish.

73     # prune_libtool_files() from eutils.eclass fails wrt #421197
74     find "${ED}" -name '*.la' -exec rm -f {} +    

 [1]: http://archives.gentoo.org/gentoo-dev/msg_931b73f7debbbd23204d2b7ab5c69d61.xml
Comment 2 Enrico Tagliavini 2012-12-15 18:50:06 UTC
Created attachment 332396 [details]
plymouth 0.8.8 ebuild with systemd support

This is an ebuild for the lastest version of plymouth. The code for .la removal has been removed. For me portage just do it right, and should do on all version from stable to git, if not it is a portage bug.

Systemd USE has been added, when used plymouth will install unit files. I'm not sure if systemd is a build dep or not.... I don't think so, that's why systemd is not in the deps.

A note: if you use dmcrypt don't use plymouth. It will be impossible to type your password if you use the splash. This works for systemd.

There is also some problem in the prepare step I still have to figure out.

If this package is as unmaintained as it looks, I might be able to maintain it if there is a proxy. Drop me an email in case.
Comment 3 Enrico Tagliavini 2012-12-16 13:22:17 UTC
Also please note there is a bug if using systemd: udevadm and systemd-tty-ask-password-agent must be linked in /bin cause it looks for them there. I still have to have a look at the code an patch it
Comment 4 Enrico Tagliavini 2012-12-16 13:54:58 UTC
Created attachment 332478 [details]
plymouth 0.8.8 ebuild with systemd support

Ok this should solve the problem described in comment #3 .

But I wonder why --with-system-root-install is used. IIRC now separate /usr is no more supported so we can remove this. It is a log more clear to have systemd units in /usr/lib/systemd instead of /lib/systemd. It works anyway, so for now I will leave it as is.
Comment 5 Leho Kraav (:macmaN @lkraav) 2012-12-25 12:53:27 UTC
Hmmm, dmcrypt password prompt has worked for me in earlier builds. Your 0.8.8 ebuild is otherwise working well on another machine, I will give it a spin on my crypted laptop a bit later.
Comment 6 Enrico Tagliavini 2012-12-29 18:11:47 UTC
DM crypt with LUKS? Strange for me it didn't worked. Well I have a strange config, maybe something wrong by my side
Comment 7 Enrico Tagliavini 2013-01-22 10:10:06 UTC
Created attachment 336458 [details]
plymouth 0.8.8 ebuild with systemd support

Version bump to support udev 197. udevadm binary has been moved back to /bin from /usr/bin .

This bug has been reported more then 5 months ago, and the current portage version is broken and obsolete. No answer from the maintainer.

This package is at all effect not maintained. Again I offer to maintain it, but since I am not a gentoo developer I need a proxy. I maintained ati-drivers (with X11 team proxying me) for almost 4 years.

If no other solution can be found to fix this package, please remove it from portage.
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2013-01-24 15:47:39 UTC
@proxy-maint — seems like Alex has no way to work/test this right now, and gave me the green light to drop this to m-n.

That said, if Enrico is up to proxy-maintain this, I don't see a reason to drop it to m-n first, if you can set him up.

Thanks guys.
Comment 9 Enrico Tagliavini 2013-01-24 22:27:41 UTC
Created attachment 336776 [details]
plymouth 0.8.8 ebuild with systemd support

And I also have a new revision of the ebuild: inherit systemd eclass, make gtk optional (but enabled by default since desktop users usually want this, but embedded or other corner case might prefer to have the dep stripped).
Comment 10 Enrico Tagliavini 2013-03-10 15:58:41 UTC
Mhm so I'm the new maintainer.... thank you :).

Can this ebuild be merged to the tree finally? Should I ask to someone?
Comment 11 Pacho Ramos gentoo-dev 2013-03-10 18:23:24 UTC
(In reply to comment #10)
> Mhm so I'm the new maintainer.... thank you :).
> 
> Can this ebuild be merged to the tree finally? Should I ask to someone?

proxy-maint people are CCed, hopefully they will take care when have enough time... if it gets stalled, please ping again here
Comment 12 Maxim Koltsov gentoo-dev 2013-03-10 18:26:03 UTC
(In reply to comment #10)
> Mhm so I'm the new maintainer.... thank you :).
> 
> Can this ebuild be merged to the tree finally? Should I ask to someone?

Hi, i will help you maintain this, as i'm using plymouth. What ebuild do you want me to commit?
Comment 13 Enrico Tagliavini 2013-03-10 18:46:44 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > Mhm so I'm the new maintainer.... thank you :).
> > 
> > Can this ebuild be merged to the tree finally? Should I ask to someone?
> 
> Hi, i will help you maintain this, as i'm using plymouth. What ebuild do you
> want me to commit?

Hi Maxim, the ebuild attached to this bug should work attachement #336776 from comment #9 . This should close at least 2 bugs, hopefully three.

Thank you :)

(In reply to comment #11)
> proxy-maint people are CCed, hopefully they will take care when have enough
> time... if it gets stalled, please ping again here

Thank you Pacho
Comment 14 Maxim Koltsov gentoo-dev 2013-03-10 18:59:41 UTC
Any particular reason to drop keywords?
Comment 15 Enrico Tagliavini 2013-03-10 19:25:47 UTC
(In reply to comment #14)
> Any particular reason to drop keywords?

Oh my.... so much time has passed I did even forgotten why I did that. No just add them back indeed. Note: I just test on amd64 and with systemd as init system
Comment 16 Maxim Koltsov gentoo-dev 2013-03-10 19:43:26 UTC
I commited it, thanks. Feel free to contact me in future.
Comment 17 Enrico Tagliavini 2013-03-10 19:50:22 UTC
(In reply to comment #16)
> I commited it, thanks. Feel free to contact me in future.

Will do, thank you :)