Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 428146 - sys-boot/plymouth-0.8.4 with x11-libs/libdrm-2.4.37 - .../work/plymouth-0.8.4/src/plugins/renderers/drm/ply-renderer-nouveau-driver.c:45:27: fatal error: nouveau_drmif.h: No such file or directory
Summary: sys-boot/plymouth-0.8.4 with x11-libs/libdrm-2.4.37 - .../work/plymouth-0.8.4...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Enrico Tagliavini
URL:
Whiteboard:
Keywords:
: 461320 (view as bug list)
Depends on: 430478
Blocks:
  Show dependency tree
 
Reported: 2012-07-26 08:06 UTC by Martin Jansa
Modified: 2013-04-11 13:55 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,42.98 KB, text/plain)
2012-07-27 08:35 UTC, Martin Jansa
Details
build log (build.log,40.91 KB, text/plain)
2012-10-10 10:40 UTC, Attila Stehr
Details
emerge --info (emerge--info.txt,15.95 KB, text/plain)
2012-10-10 10:42 UTC, Attila Stehr
Details
Ebuild with nouveau support disabled (plymouth-0.8.8-r1.ebuild,2.27 KB, text/plain)
2013-03-12 11:27 UTC, Enrico Tagliavini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Jansa 2012-07-26 08:06:38 UTC
make[5]: Entering directory `/tmp/tmpfs/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4_build/src/plugins/renderers/drm'
  CC       drm_la-plugin.lo
  CC       drm_la-ply-renderer-nouveau-driver.lo
  CC       drm_la-ply-renderer-libkms-driver.lo
/tmp/tmpfs/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4/src/plugins/renderers/drm/ply-renderer-nouveau-driver.c:45:27: fatal error: nouveau_drmif.h: No such file or directory
compilation terminated.
make[5]: *** [drm_la-ply-renderer-nouveau-driver.lo] Error 1
make[5]: *** Waiting for unfinished jobs....

x11-libs/libdrm-2.4.37 doesn't install nouveau_drmif.h like 2.4.35 did
[ebuild   R    ] sys-boot/plymouth-0.8.4  USE="libkms pango -debug -gdm -openrc -static-libs" VIDEO_CARDS="nouveau -intel -radeon" 0 kB
[ebuild   R    ] x11-libs/libdrm-2.4.37  USE="libkms -static-libs" VIDEO_CARDS="nouveau (-exynos) -intel (-omap) -radeon -vmware" 0 kB

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-07-26 17:44:33 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 Martin Jansa 2012-07-27 08:35:35 UTC
Created attachment 319358 [details]
build.log
Comment 3 Martin Jansa 2012-07-27 08:36:10 UTC
Portage 2.2.0_alpha120 (default/linux/amd64/10.0/desktop/kde, gcc-4.7.1, glibc-2.16.0, 3.5.0-gentoo x86_64)
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-AMD_FX-tm-8120_Eight-Core_Processor-with-gentoo-2.1
Timestamp of tree: Fri, 27 Jul 2012 08:00:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo portage-local
Installed sets: @mykde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA RTCW-ETEULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10 AdobeFlash-10.1 google-chrome Oracle-BCLA-JavaSE AdobeFlash-10.3 skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -O2 -pipe -fomit-frame-pointer -march=bdver1 -mtune=bdver1 -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx -D__USE_POSIX199309 "
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -O2 -pipe -fomit-frame-pointer -march=bdver1 -mtune=bdver1 -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx -D__USE_POSIX199309 "
DISTDIR="/tmp/data/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="cs en en_GB en_US"
MAKEOPTS="-j8"
PKGDIR="/tmp/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/tmpfs"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi aio alsa amd64 amr apache2 avahi bash-completion berkdb bidi bluetooth branding bzip2 cairo ccache cdda cdparanoia cdr cdrom cgi cli consolekit cracklib crypt cups curl cxx dbus declarative dga dri dts dvb dvd dvdr emboss enca encode exif fam fbcon ffmpeg firefox flac flash fmod fontconfig ftp gallium gd gif gkrellm glib glut gnutls gpgme gpm gps gstreamer gzip iconv icq imagemagick imap imlib innodb ipv6 irc irda jabber java java5 java6 javascript joystick jpeg kde kipi kpathsea kqemu krb4 kvm lame lcms libcaca libkms libnotify libwww linuxthreads-tls lirc live lm_sensors logrotate mad maildir matroska mime mmx mng modules mozilla mp3 mp4 mpeg mplayer mudflap multilib mysql mysqli ncurses network nls nntp nocd nptl nsplugin nspluginwrapper ogg openal opencore-amr opengl openmp oss pam pango pcre pdf phonon php pic plasma png policykit pop portaudio posix ppds pppd pulseaudio python3 qt3support qt4 readline rss rsync rtc samba sasl screen sdl semantic-desktop session silc slang smartcard smime smtp sndfile sockets spell sse sse2 ssh ssl startup-notification stream subtitles subversion svg svgz symlink sysfs tcpd theora threads tiff truetype udev udisks unicode upower usb utempter uudeview v4l v4l2 vde vdpau vdr videos vim vim-pager vorbis webkit wxwidgets wxwindows x264 xanim xcb xcomposite xinetd xml xmlreader xmlrpc xorg xosd xpm xscreensaver xsl xv xvid zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth biosdevname mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs en en_GB en_US" LIRC_DEVICES="devinput" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler ruby soa visualweb webcommon websvccommon xml dlight enterprise" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm armeb i386 x86_64" RUBY_TARGETS="ruby19 jruby" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="vesa nv v4l nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Martin Jansa 2012-07-27 09:26:14 UTC
It looks like it was removed from libdrm long time ago:
http://cgit.freedesktop.org/mesa/drm/commit/include/drm?id=3a87b1f497cc201a6c37fcd779019560ab7746ae

and latest plymouth is still including that
http://cgit.freedesktop.org/plymouth/tree/src/plugins/renderers/drm/ply-renderer-nouveau-driver.c
Comment 5 Attila Stehr 2012-10-10 10:40:02 UTC
Created attachment 326174 [details]
build log

make[5]: Entering directory `/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4_build/src/plugins/renderers/x11'
  CC       x11_la-plugin.lo
  CCLD     x11.la
make[5]: Leaving directory `/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4_build/src/plugins/renderers/x11'
Making all in drm
make[5]: Entering directory `/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4_build/src/plugins/renderers/drm'
  CC       drm_la-plugin.lo
  CC       drm_la-ply-renderer-nouveau-driver.lo
/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4/src/plugins/renderers/drm/ply-renderer-nouveau-driver.c:45:27: fatal error: nouveau_drmif.h: No such file or directory
compilation terminated.
make[5]: *** [drm_la-ply-renderer-nouveau-driver.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4/src/plugins/renderers/drm/plugin.c: In function 'find_driver_for_device':
/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4/src/plugins/renderers/drm/plugin.c:425:12: warning: ignoring return value of 'asprintf', declared with attribute warn_unused_result
make[5]: Leaving directory `/var/tmp/portage/sys-boot/plymouth-0.8.4/work/plymouth-0.8.4_build/src/plugins/renderers/drm'
Comment 6 Attila Stehr 2012-10-10 10:42:42 UTC
Created attachment 326176 [details]
emerge --info

package.mask contains:

# default MASK overlays
*/*::sunrise
*/*::bitcoin
*/*::v-fox
*/*::multimedia
*/*::sabayon
*/*::paddymac
#*/*::arx-libertatis
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-10-16 21:43:51 UTC
For nouveau_drmif.h, plymouth will need to depend on <libdrm-2.4.34[video_cards_nouveau]
Comment 8 Xake 2013-02-07 11:16:42 UTC
(In reply to comment #7)
> For nouveau_drmif.h, plymouth will need to depend on
> <libdrm-2.4.34[video_cards_nouveau]

I would give this the thumbs down, VIDEO_CARDS="" USE="libkms" works just as well...
Comment 9 Pacho Ramos gentoo-dev 2013-03-10 20:51:47 UTC
Just bumped version should fix this
Comment 10 Martin Jansa 2013-03-12 10:03:53 UTC
[ebuild   R    ] x11-libs/libdrm-2.4.42  USE="libkms -static-libs" VIDEO_CARDS="nouveau (-exynos) -intel (-omap) -radeon -vmware" 0 kB
[ebuild     U  ] sys-boot/plymouth-0.8.8 [0.8.4] USE="libkms pango systemd%* -debug -gdm -gtk% -openrc -static-libs" VIDEO_CARDS="nouveau* -intel -radeon" 0 kB

fails the same

Removing nouveau from plymouth's VIDEO_CARDS works.

# emerge --info
Portage 2.2.0_alpha166 (default/linux/x86/13.0/desktop/kde, gcc-4.7.2, glibc-2.17, 3.8.2-gentoo i686)
=================================================================
System uname: Linux-3.8.2-gentoo-i686-AMD_FX-tm-8120_Eight-Core_Processor-with-gentoo-2.2
KiB Mem:    16361156 total,    517260 free
KiB Swap:    5242876 total,   5188100 free
Timestamp of tree: Tue, 12 Mar 2013 06:00:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo portage-local
Installed sets: @system
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA RTCW-ETEULA PUEL dlj-1.1 skype-eula AdobeFlash-10.1 Oracle-BCLA-JavaSE AdobeFlash-10.3 skype-4.0.0.7-copyright AdobeFlash-11.x"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -O2 -pipe -fomit-frame-pointer -march=bdver1 -mtune=bdver1 -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash 
/etc/terminfo" 
CXXFLAGS="-O2 -march=i686 -pipe -O2 -pipe -fomit-frame-pointer -march=bdver1 -mtune=bdver1 -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx"
DISTDIR="/tmp/data/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz/distfiles/"
LANG="en_US"   
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j8" 
PKGDIR="/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/tmpfs"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi aiglx aio alsa amr apache2 bash-completion berkdb bidi bluetooth branding bzip2 cairo ccache cdda cdparanoia cdr cdrom cgi cli consolekit cracklib crypt curl cxx dba dbus declarative dga dio dri dts dvb dvd dvdr emboss encode exif fam fbcon ffmpeg firefox flac flash fmod font-server ftp gb gd gif gkrellm glib glut gnutls gpg2-experimental gpgme gpm gzip iconv icq imagemagick imap imlib innodb ipv6 irc irda jabber java java5 javascript jikes joystick jpeg kdeenablefinal kdehiddenvisibility kipi kpathsea kqemu krb4 lame lcms libcaca libnotify libwww linuxthreads-tls lirc live lm_sensors logrotate mad maildir matroska mime mng modules mozilla mozsvg mp3 mp4 mpeg mudflap mysql mysqli ncurses network nls nntp nocd nptl nsplugin nvidia ogg openal opengl openmp opera oss pam pango pcre pdf phonon php pic plasma png policykit pop posix ppds python3 qt3support qt4 readline rss rsync rtc samba sasl screen sdl semantic-desktop session silc slang smartcard smime smtp sndfile sockets spell ssh ssl startup-notification stream subversion svg svgz symlink sysfs systemd tcpd tetex threads tiff truetype udev udisks unicode upower usb utempter uudeview v4l v4l2 vdpau vdr videos vim vorbis wxwidgets wxwindows x264 x86 xanim xcb xcomposite xinerama xinetd xml xmlreader xmlrpc xosd xpm xscreensaver xsl xv xvid zip zlib zvbi" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth biosdevname mdraid syslog systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-32" INPUT_DEVICES="evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs en en_US en_GB" LIRC_DEVICES="devinput" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"  
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 11 Andre Reinke 2013-03-12 10:11:35 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > For nouveau_drmif.h, plymouth will need to depend on
> > <libdrm-2.4.34[video_cards_nouveau]
> 
> I would give this the thumbs down, VIDEO_CARDS="" USE="libkms" works just as
> well...

I can confirm that compiling runs fine when USE="libkms" VIDEO_CARDS="". I can *NOT* confirm plymouth works fine after that. Plymouth suddenly starts in the middle of boot process instead of the beginning after loading dracut's initramfs.

So, NO, it's still not working for me.
Comment 12 Enrico Tagliavini 2013-03-12 11:21:43 UTC
*** Bug 461320 has been marked as a duplicate of this bug. ***
Comment 13 Enrico Tagliavini 2013-03-12 11:27:39 UTC
Created attachment 341792 [details]
Ebuild with nouveau support disabled

Please try this ebuild. I can't field test it since I have no nouveau card. Maxim, if this is reported working, please upload it to the main three. Thank you
Comment 14 Andrius Štikonas 2013-03-12 12:16:40 UTC
(In reply to comment #11)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > For nouveau_drmif.h, plymouth will need to depend on
> > > <libdrm-2.4.34[video_cards_nouveau]
> > 
> > I would give this the thumbs down, VIDEO_CARDS="" USE="libkms" works just as
> > well...
> 
> I can confirm that compiling runs fine when USE="libkms" VIDEO_CARDS="". I
> can *NOT* confirm plymouth works fine after that. Plymouth suddenly starts
> in the middle of boot process instead of the beginning after loading
> dracut's initramfs.
> 
> So, NO, it's still not working for me.

Plymouth starting late is a different problem. It stopped working for plymouth > 0.8.6.1. Plymouth 0.8.6.1 works fine on nouveau.

I suspect that http://cgit.freedesktop.org/plymouth/commit/?id=6fac021e66c97c950a1ddeccf57c11d183187239 causes late start.
Comment 15 Enrico Tagliavini 2013-04-11 09:12:22 UTC
Well I guess we have no choice but bumping it blindly at this point. Should work anyway. At least it doesn't regress for non-nouveau drivers here.

Maxim you can bump it to the tree. Thank you
Comment 16 Andrius Štikonas 2013-04-11 10:21:29 UTC
Actually Plymouth starts late for non nouveau drivers as well. It is probably the problem in dracut but it doesn't seem that anybody is working to fix that.

Version 0.8.6.1 works fine with all drivers. It would have been better to use that version for now.
Comment 17 Enrico Tagliavini 2013-04-11 10:39:26 UTC
(In reply to comment #16)
> Actually Plymouth starts late for non nouveau drivers as well. It is
> probably the problem in dracut but it doesn't seem that anybody is working
> to fix that.
> 
> Version 0.8.6.1 works fine with all drivers. It would have been better to
> use that version for now.

Well plymouth starts when the initramfs / init system starts it. So if it does start late it is not a plymouth bug [and anyway not realted to this bug]. Feel free to open a new one and add me to the CC list, I'm anyway involved. If there is no bug about it, it is unlikely someone will work on it ;).

That said I might have a suggestion for you with the lastest version of plymouth we have in tree.

Looking at the code of plymouth dracut module:

if getargbool 1 plymouth.enable && getargbool 1 rd.plymouth -d -n rd_NO_PLYMOUTH; then

it seems you must pass plymouth.enable and rd.plymouth, or maybe plymouth.enable=1 and rd.plymouth=1 in the kernel command line [so from grub usually]. Mind trying?

Also: if you want 0.8.6.1 it should be easy. Just rename the current ebuild to the right version in you local overlay.
Comment 18 Andrius Štikonas 2013-04-11 11:42:39 UTC
No that's not the problem. The problem is caused by that commit I mentioned in comment 14. plymouthd was moved from /bin/plymouthd to /sbin/plymouthd.

I have now replaced bin with sbin in /usr/lib64/dracut/50plymouth and everything works (no extra arguments are necessary).

Maybe a patch can be created to fix this? (But note that plymouth still stays in /bin/plymouth, only plymouthd was moved.)
Comment 19 Enrico Tagliavini 2013-04-11 13:08:44 UTC
(In reply to comment #18)
> No that's not the problem. The problem is caused by that commit I mentioned
> in comment 14. plymouthd was moved from /bin/plymouthd to /sbin/plymouthd.
> 
> I have now replaced bin with sbin in /usr/lib64/dracut/50plymouth and
> everything works (no extra arguments are necessary).
> 
> Maybe a patch can be created to fix this? (But note that plymouth still
> stays in /bin/plymouth, only plymouthd was moved.)

Ok I can confirm there is a problem in dracut. The plymouth module looks ok to me, but the inst is not apparently. The generated initramfs is not consistent. Open a bug for dracut in the gentoo bugzilla, and also in the upstream one.
Comment 20 Andrius Štikonas 2013-04-11 13:28:34 UTC
OK, I've filled #465518 and informed upstream by email (they asked me to do so). Could this bug be closed now?
Comment 21 Enrico Tagliavini 2013-04-11 13:30:53 UTC
(In reply to comment #20)
> OK, I've filled #465518 and informed upstream by email (they asked me to do
> so). Could this bug be closed now?

thanks. No, this bug will be closed when the ebuild without the nouveau USE enabled will be bumped to the tree
Comment 22 Maxim Koltsov gentoo-dev 2013-04-11 13:54:55 UTC
Ebuild without nouveau use commited as plymouth-0.8.8-r1. Thanks, Enrico.
Comment 23 Enrico Tagliavini 2013-04-11 13:55:49 UTC
(In reply to comment #22)
> Ebuild without nouveau use commited as plymouth-0.8.8-r1. Thanks, Enrico.

Thank you to you Maxim :)