Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430428 - net-analyzer/ntop-5.0.1 version bump
Summary: net-analyzer/ntop-5.0.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 2 votes (vote)
Assignee: Netmon Herd
URL: http://www.ntop.org/products/ntop/
Whiteboard:
Keywords: PATCH
Depends on: 415743
Blocks:
  Show dependency tree
 
Reported: 2012-08-08 09:44 UTC by teidakankan
Modified: 2013-07-04 12:48 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ntop-5.0.1-gentoo.patch (ntop-5.0.1-gentoo.patch,5.34 KB, patch)
2012-08-25 16:46 UTC, Jeroen Roovers (RETIRED)
Details | Diff
added the semicolon (ntop-5.0.1-gentoo.patch,5.34 KB, patch)
2012-10-12 18:05 UTC, Florian Klink
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description teidakankan 2012-08-08 09:44:27 UTC
http://sourceforge.net/projects/ntop/files/ntop/Stable/ntop-5.0.tar.gz/download

2012-07-17 	39.6 MB

Reproducible: Always




See 'http://www.ntop.org/ntop/ntop-5-0-released/' for change related NEWS.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-25 16:46:03 UTC
Created attachment 322200 [details, diff]
ntop-5.0.1-gentoo.patch
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-25 16:47:34 UTC
Comment on attachment 322200 [details, diff]
ntop-5.0.1-gentoo.patch

In globals-core.c a semicolon is missing.
Comment 3 Florian Klink 2012-10-12 18:05:07 UTC
Created attachment 326388 [details, diff]
added the semicolon
Comment 4 Florian Klink 2012-10-13 01:20:22 UTC
When I just try to copy the ebuild for 4.1.0 to 5.0.1 (and use the patch from attachment 326388 [details, diff]), the build fails with:

x86_64-pc-linux-gnu-gcc: ./nDPI/src/lib/.libs/libndpi.a: No such file or directory

So there is still something wrong...
Comment 5 Anton Bolshakov 2012-10-30 16:13:01 UTC
you need to compile the embedded nDPI lib too:

--- ntop-4.1.0.ebuild	2012-06-12 11:02:00.000000000 +0800
+++ ntop-5.0.1.ebuild	2012-10-31 00:09:12.221112683 +0800
@@ -60,6 +60,11 @@
 		ac_cv_lib_xml2_xmlCheckVersion=no \
 		ac_cv_lib_gdome_gdome_di_saveDocToFile=no
 
+	cd ./nDPI
+	econf
+	emake
+	cd ..
+
 	econf \
 		$(use_enable snmp) \
 		$(use_with ssl) \
@@ -77,6 +82,7 @@
 		die "failed to prepare /var/lib/ntop dir"
 	insinto /var/lib/ntop
 	gunzip 3rd_party/GeoIPASNum.dat.gz
+	gunzip 3rd_party/GeoLiteCity.dat.gz
 	local f
 	for f in GeoIPASNum.dat GeoLiteCity.dat; do
 		# Don't install included GeoIP files if newer versions are available
Comment 6 Anton Bolshakov 2012-11-01 21:41:44 UTC
I have filed an upstream's bug report:
https://www.ntop.org/bugzilla3/show_bug.cgi?id=273
Comment 7 Pacho Ramos gentoo-dev 2012-12-31 18:11:52 UTC
Could gdome2 dependency be reviewed on this version? (bug 415743)
Comment 8 Jeremy Sermersheim 2013-01-11 16:41:42 UTC
i can confirm that using the suggestions in comment 3 and comment 5, i have a working ntop version 5.0.1

thanks!
Comment 9 Alex Xu (Hello71) 2013-04-26 02:22:11 UTC
(In reply to comment #6)
> I have filed an upstream's bug report:
> https://www.ntop.org/bugzilla3/show_bug.cgi?id=273

Why oh why does viewing bugs require an account?
Comment 10 Ari Entlich 2013-05-19 21:43:34 UTC
Is there any movement happening here?
Comment 11 Jack 2013-05-19 23:13:19 UTC
I don't use it heavily, but I also have a working ntop 5.0.1 since 23 April.
Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2013-07-04 12:48:09 UTC
+*ntop-5.0.1 (04 Jul 2013)
+
+  04 Jul 2013; Lars Wendler <polynomial-c@gentoo.org> -ntop-4.0.1.ebuild,
+  +ntop-5.0.1.ebuild, -files/ntop-4.0.1-gentoo.patch,
+  +files/ntop-5.0.1-gentoo.patch:
+  Non-maintainer commit: Version bump (fixes bug #430428). Removed old.
+

Thanks for all the help.