Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 428282 - net-wireless/bluez-4.99 expected specifier-qualifier-list before ‘typeof’ in bluetooth.h
Summary: net-wireless/bluez-4.99 expected specifier-qualifier-list before ‘typeof’ in ...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Pacho Ramos
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-07-27 09:54 UTC by W. Trevor King
Modified: 2013-10-12 06:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Log of failing build. (build.log,25.70 KB, text/plain)
2012-07-27 09:54 UTC, W. Trevor King
Details
emerge --info (emerge.info,4.94 KB, text/plain)
2012-07-27 09:55 UTC, W. Trevor King
Details
Patch from Debian (http://patch-tracker.debian.org/patch/series/view/bluez/4.101-1/09_fix_ftbfs_with_c99.patch) (09_fix_ftbfs_with_c99.patch,700 bytes, patch)
2012-07-27 09:56 UTC, W. Trevor King
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description W. Trevor King 2012-07-27 09:54:59 UTC
Created attachment 319370 [details]
Log of failing build.

While emerging app-mobilephone/obexpushd-9999 from the my wtk overlay I ran into:

  cd /var/tmp/portage/app-mobilephone/obexpushd-9999/work/obexpushd-9999_build/src && /usr/bin/x86_64-pc-linux-gnu-gcc  -D_GNU_SOURCE -DUSE_LIBGCRYPT -DHAVE_SDPLIB -DUSB_GADGET_SUPPORT -DENABLE_TCPWRAP -DUSE_XATTR -DOPENOBEX_TCPOBEX=1 -DDEFINITIONS  -DNDEBUG -O2 -march=native -pipe  -std=c99 -I/var/tmp/portage/app-mobilephone/obexpushd-9999/work/obexpushd-9999/src -I/var/tmp/portage/app-mobilephone/obexpushd-9999/work/obexpushd-9999_build/src    -o CMakeFiles/obexpushd.dir/obexpushd.c.o -c /var/tmp/portage/app-mobilephone/obexpushd-9999/work/obexpushd-9999/src/obexpushd.c
  In file included from /var/tmp/portage/app-mobilephone/obexpushd-9999/work/obexpushd-9999/src/obexpushd.c:18:0:
  /usr/include/bluetooth/bluetooth.h: In function ‘bt_get_le64’:
  /usr/include/bluetooth/bluetooth.h:159:9: error: expected specifier-qualifier-list before ‘typeof’
  /usr/include/bluetooth/bluetooth.h:159:9: error: called object ‘typeof(__p)’ is not a function
  /usr/include/bluetooth/bluetooth.h:159:9: error: ‘struct <anonymous>’ has no member named ‘__v’

This seems to be the same as Debian's 661879 [1], which they fixed by patching bluez [2].


[1]: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661879
[2]: http://patch-tracker.debian.org/patch/series/view/bluez/4.101-1/09_fix_ftbfs_with_c99.patch
Comment 1 W. Trevor King 2012-07-27 09:55:25 UTC
Created attachment 319372 [details]
emerge --info
Comment 3 W. Trevor King 2012-07-27 17:56:04 UTC
I can confirm that the patch does fix the issue for me.

The patch made it into the upstream mailing list back in March, but doesn't seem to be included in their repository yet.  I've bumped them, and will report back on what I hear.
Comment 4 Pacho Ramos gentoo-dev 2012-09-05 17:56:06 UTC
It could be a gcc bug per:
https://bugzilla.redhat.com/show_bug.cgi?id=786966#c5
Comment 5 Tiziano Müller gentoo-dev 2012-10-28 18:52:00 UTC
reassigning to pacho (thanks!) since I stepped down as maintainer for bluez
Comment 6 Pacho Ramos gentoo-dev 2012-11-18 14:08:25 UTC
(In reply to comment #4)
> It could be a gcc bug per:
> https://bugzilla.redhat.com/show_bug.cgi?id=786966#c5

But no idea about what gcc version includes a fix for that
Comment 7 W. Trevor King 2012-11-18 16:20:38 UTC
(In reply to comment #3)
> I've bumped them, and will report back on what I hear.

Thanks Pacho for pushing this forward!  Upstream threads (so others don't need to dig through Gmane):

http://thread.gmane.org/gmane.linux.bluez.kernel/20372  (2012-01-16)
http://thread.gmane.org/gmane.linux.bluez.kernel/22306  (2012-03-05)
http://thread.gmane.org/gmane.linux.bluez.kernel/27931  (2012-07-29)
Comment 8 Pacho Ramos gentoo-dev 2013-02-12 19:32:06 UTC
Still valid with gcc-4.6.3?
Comment 9 W. Trevor King 2013-02-12 21:43:00 UTC
(In reply to comment #8)
> Still valid with gcc-4.6.3?

Yeah, I got the same error using gcc-4.6.3 and bluez-4.101-r5.
Comment 10 Pacho Ramos gentoo-dev 2013-10-03 06:12:33 UTC
And with gcc-4.7.3-r1?
Comment 11 W. Trevor King 2013-10-11 23:00:44 UTC
(In reply to Pacho Ramos from comment #10)
> And with gcc-4.7.3-r1?

I'll let you know once something in the 4.7 series stabilizes ;).
Comment 12 Pacho Ramos gentoo-dev 2013-10-12 06:07:44 UTC
It's in progress :)
https://bugs.gentoo.org/show_bug.cgi?id=467274