Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 426514 - x11-drivers/xf86-video-virtualbox-4.1.12 - /usr/src/linux-3.3.8-gentoo/arch/x86/include/asm/unistd.h:16:29: fatal error: asm/unistd_64.h: No such file or directory
Summary: x11-drivers/xf86-video-virtualbox-4.1.12 - /usr/src/linux-3.3.8-gentoo/arch/x...
Status: RESOLVED DUPLICATE of bug 424816
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alessio Cassibba (X-Drum)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-14 05:00 UTC by Kent Fredric (IRC: kent\n)
Modified: 2013-10-03 20:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info and emerge -pqv (report,4.38 KB, text/plain)
2012-07-14 05:00 UTC, Kent Fredric (IRC: kent\n)
Details
build.log (build.log,61.94 KB, text/plain)
2012-07-14 05:01 UTC, Kent Fredric (IRC: kent\n)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) gentoo-dev 2012-07-14 05:00:25 UTC
Created attachment 318112 [details]
emerge --info and emerge -pqv

I managed to find one bug similar to this ( bug #344783 ), but the suggestion of "just make clean and then make modules prepare" don't seem to be sufficient.

I've encountered this bug twice now, in 2 separate setups, but the current one is inside a VBox VM.

The only thing I can think of that would be a likely candidate for a cause would be that I use KBUILD_OUTPUT= , which is one of the more frequently broken kernel module compilation features. 


I tried downgrading linux-headers just in case it was related, but no.
Comment 1 Kent Fredric (IRC: kent\n) gentoo-dev 2012-07-14 05:01:08 UTC
Created attachment 318114 [details]
build.log
Comment 2 Tomoh K. 2012-08-29 07:45:40 UTC
This bug maybe a duplicate of bug 424816.
I encountered the same error while emerging xf86-video-virtualbox with a separated kernel build directory.
/usr/src/linux-3.5.0-gentoo/arch/x86/include/asm/unistd.h:26:29: fatal error: asm/unistd_64.h: No such file or directory

In my case, the patch in bug 424816 solved the problem.
Comment 3 Ben Kohler gentoo-dev 2013-10-03 20:20:48 UTC

*** This bug has been marked as a duplicate of bug 424816 ***