Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 344783 - =app-emulation/virtualbox-modules-3.2.10 fails to compile
Summary: =app-emulation/virtualbox-modules-3.2.10 fails to compile
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-09 09:00 UTC by Pavel Shirov
Modified: 2011-10-20 04:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Shirov 2010-11-09 09:00:42 UTC
* Preparing vboxdrv module
make -j3 HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS= KERN_DIR=/usr/src/linux KERNOUT=/lib/modules/2.6.34-gentoo-r12/build all 
*** Building 'vboxdrv' module ***
make[1]: Entering directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv'
make KBUILD_VERBOSE= -C /usr/src/linux SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv modules
make[2]: Entering directory `/usr/src/linux-2.6.34-gentoo-r12'
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/SUPDrvSem.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/SUPDrv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.o
In file included from include/linux/gfp.h:4,
                 from include/linux/slab.h:12,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/../SUPDrvInternal.h:100,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:33:
include/linux/mmzone.h:18:30: error: generated/bounds.h: Нет такого файла или каталога
include/linux/mmzone.h:252:5: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:254:7: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:256:7: warning: "MAX_NR_ZONES" is not defined
In file included from include/linux/gfp.h:4,
                 from include/linux/slab.h:12,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/../SUPDrvInternal.h:100,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:33:
include/linux/mmzone.h:294: ошибка: ‘MAX_NR_ZONES’ не описан в этой области (не в функции)
In file included from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/linux/the-linux-kernel.h:78,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:34:
include/linux/mm.h:457:63: warning: "NR_PAGEFLAGS" is not defined
include/linux/mm.h:505:62: warning: "NR_PAGEFLAGS" is not defined
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.o] Ошибка 1
make[3]: *** Ожидание завершения заданий...
In file included from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/include/internal/iprt.h:52,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.c:32:
include/linux/mmzone.h:18:30: error: generated/bounds.h: Нет такого файла или каталога
include/linux/mmzone.h:252:5: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:254:7: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:256:7: warning: "MAX_NR_ZONES" is not defined
In file included from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/include/internal/iprt.h:52,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.c:32:
include/linux/mmzone.h:294: ошибка: ‘MAX_NR_ZONES’ не описан в этой области (не в функции)
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.o] Ошибка 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv] Ошибка 2
make[2]: Leaving directory `/usr/src/linux-2.6.34-gentoo-r12'
make[1]: *** [vboxdrv] Ошибка 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv'
make: *** [all] Ошибка 2
emake failed
 * ERROR: app-emulation/virtualbox-modules-3.2.10 failed:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=  KERN_DIR=/usr/src/linux KERNOUT=/lib/modules/2.6.34-gentoo-r12/build all

# emerge --info =app-emulation/virtualbox-modules-3.2.10
Portage 2.1.9.24 (default/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r3, 2.6.34-gentoo-r12 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r12-i686-Pentium-R-_Dual-Core_CPU_E5200_@_2.50GHz-with-gentoo-1.12.14
Timestamp of tree: Tue, 09 Nov 2010 05:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.4.6, 2.5.4-r4, 2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13::<unknown repository>, 2.65-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.34 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA IBM-J1.6 dlj-1.1 AdobeFlash-10.1 PUEL"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openfire/resources/security/ /usr/share/X11/xkb /usr/share/config /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror2.corbina.ru/gentoo-distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ http://gentoo.supp.name/ http://gentoo.mirror.pw.edu.pl/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ http://gentoo.tiscali.nl/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.ru.gentoo.org/gentoo-portage"
USE="X acl berkdb bzip2 cli cracklib crypt cxx dbus dri fortran gdbm git glitz hal iconv icq iproute2 jabber jpeg jpeg2k kde mmx mng modules mudflap mysql ncurses nls nptl nptlonly nsplugin opengl openmp optimization oscar pam pcre perl png pppd python qt3support qt4 readline redland samba semantic-desktop session speex sqlite sse sse2 ssl ssse3 subversion svg sysfs tcpd threads tiff unicode vnc webkit x86 xcomposite xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Pavel Shirov 2010-11-09 09:09:26 UTC
Forgot about locale settings and didn't noticed it before posting. Here is the build log copy in english:

*** Building 'vboxdrv' module ***
make[1]: Entering directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv'
make KBUILD_VERBOSE= -C /usr/src/linux SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv modules
make[2]: Entering directory `/usr/src/linux-2.6.34-gentoo-r12'
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/SUPDrvSem.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/SUPDrv.o
In file included from include/linux/gfp.h:4,
                 from include/linux/slab.h:12,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/../SUPDrvInternal.h:100,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:33:
include/linux/mmzone.h:18:30: error: generated/bounds.h: No such file or directory
include/linux/mmzone.h:252:5: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:254:7: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:256:7: warning: "MAX_NR_ZONES" is not defined
In file included from include/linux/gfp.h:4,
                 from include/linux/slab.h:12,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/../SUPDrvInternal.h:100,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:33:
include/linux/mmzone.h:294: error: 'MAX_NR_ZONES' undeclared here (not in a function)
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.o
In file included from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/linux/the-linux-kernel.h:78,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.c:34:
include/linux/mm.h:457:63: warning: "NR_PAGEFLAGS" is not defined
include/linux/mm.h:505:62: warning: "NR_PAGEFLAGS" is not defined
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/include/internal/iprt.h:52,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.c:32:
include/linux/mmzone.h:18:30: error: generated/bounds.h: No such file or directory
include/linux/mmzone.h:252:5: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:254:7: warning: "MAX_NR_ZONES" is not defined
include/linux/mmzone.h:256:7: warning: "MAX_NR_ZONES" is not defined
In file included from include/linux/gfp.h:4,
                 from include/linux/kmod.h:22,
                 from include/linux/module.h:13,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/include/internal/iprt.h:52,
                 from /var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.c:32:
include/linux/mmzone.h:294: error: 'MAX_NR_ZONES' undeclared here (not in a function)
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv/r0drv/alloc-r0drv.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.34-gentoo-r12'
make[1]: *** [vboxdrv] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/virtualbox-modules-3.2.10/work/vboxdrv'
make: *** [all] Error 2
emake failed
Comment 2 Pavel Shirov 2010-11-09 13:40:29 UTC
Ok this was caused by missing autogenerated headers in my gentoo-sources tree (I've did 'make clean'). So 'cd /usr/src/linux && make modules_prepare' fixed this issue, but it wasn't really obvious.
I wonder if there are some way to make this more straightforward or at least add some checks and warnings...
Comment 3 katabami 2011-05-20 07:40:59 UTC
Let me comment as a non-expert user. Some packages build kernel modules, and I think they should be more informative: 
* if it needs some header files like this, it should have the line
 [[ -e /usr/src/linux/include/generated/bounds.h ]] || die "Do cd /usr/src/linux && make modules_prepare"
 Probably it should be prvided as a function in linux-mod.eclass.
* it should einfo "Remember that you have to emerge ${PN} each time you upgrade to a new kernel; modules from former installation won't be deleted."

I don't know the general case, but this may better be a linux-mod.eclass bug. If you like, I'd open a seperate bug, but I can't state technical details.

Thanks a lot for maintaining Gentoo.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2011-09-23 07:32:02 UTC
app-emulation/virtualbox-modules-3.2.10 is no longer in the tree...
Comment 5 katabami 2011-10-20 04:27:59 UTC
This is a doc bug, and independent of ebuild versions. If you don't fix it, you may receive identical reports again. Please read the comment #3.

Thanks anyway. I leave the status unchaged.