Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426222 - sys-apps/portage: autounmask could handle USE conflicts better
Summary: sys-apps/portage: autounmask could handle USE conflicts better
Status: CONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on: 425558
Blocks: autounmask
  Show dependency tree
 
Reported: 2012-07-11 22:33 UTC by Zac Medico
Modified: 2019-09-23 01:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
test case for USE=icu conflict involving libxml2, qt-webkit, and chromium (test_autounmask_use_conflict.py,1.33 KB, text/plain)
2012-07-11 22:33 UTC, Zac Medico
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2012-07-11 22:33:38 UTC
Created attachment 317962 [details]
test case for USE=icu conflict involving libxml2, qt-webkit, and chromium

The attached test case results in the following output, even though the only workable solution is to enable USE=icu for all involved packages:

emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libxml2:2[!icu?]".
!!! One of the following packages is required to complete your request:
- dev-libs/libxml2-2.8.0::test_repo (Change USE: -icu)
- x11-libs/qt-webkit-4.8.2::test_repo (Change USE: +icu)
(dependency required by "x11-libs/qt-webkit-4.8.2" [ebuild])
(dependency required by "x11-libs/qt-webkit" [argument])

If we disable the "autounmask_breakage" code from bug #368429, then we get the following output which is confusing because the test case already has USE=icu enabled for libxml2:

emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libxml2[icu]".
!!! One of the following packages is required to complete your request:
- dev-libs/libxml2-2.8.0::test_repo (Change USE: +icu)
(dependency required by "www-client/chromium-19.0.1084.52" [ebuild])
(dependency required by "www-client/chromium" [argument])