Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421417 - sci-electronics/kicad-99999999 - .../work/kicad-99999999/include/common.h:50:9: error: #error "You must use '--with-gnomeprint' or '--with-gtkprint' in your wx library configuration."
Summary: sci-electronics/kicad-99999999 - .../work/kicad-99999999/include/common.h:50:...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 474324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-16 14:36 UTC by Yixun Lan
Modified: 2013-10-12 20:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (build.log,501.80 KB, text/plain)
2012-06-16 14:37 UTC, Yixun Lan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yixun Lan gentoo-dev 2012-06-16 14:36:22 UTC
I think gentoo dev may not care about the live ebuild, but still would like to log this bug here, mainly for status tracking

/var/build/portage/sci-electronics/kicad-99999999/work/kicad-99999999/include/common.h:50:9: error: #error "You must use '--with-gnomeprint' or '--with-gtkprint' in your wx library configuration."


Reproducible: Always




Portage 2.2.0_alpha110_p35 (default/linux/x86/10.0, gcc-4.7.1, glibc-2.15-r2, 3.5.0-rc2 i686)
=================================================================
System uname: Linux-3.5.0-rc2-i686-Intel-R-_Core-TM-2_Quad_CPU_Q8200_@_2.33GHz-with-gentoo-2.1
Timestamp of tree: Fri, 15 Jun 2012 00:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.1.5, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22.52.0.3
sys-devel/gcc:            4.5.3-r2, 4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo xfce-dev enlightenment-niifaq dilfridge seden dustin bleeding-edge sunrise local gentoo-android gentoo-zh systemd ofree
Installed sets: 
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openfire/resources/security/ /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -fprefetch-loop-arrays "
DISTDIR="/home/ftp/locals"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news nostrip parallel-fetch parallel-install parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.163.com/gentoo http://mirrors.xmu.edu.cn/gentoo http://ftp.twaren.net/Linux/Gentoo http://mirror.averse.net/pub/gentoo "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US zh zh_CN"
MAKEOPTS="-j7 -l7"
PKGDIR="/mnt/source/gentoo-package"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/build"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/xfce-dev /var/lib/layman/gentoo-zh /var/lib/layman/systemd /var/lib/layman/ofree"
SYNC="rsync://sabayon/gentoo-portage"
USE="3dnow X acl alsa bash-completion berkdb bzip2 cairo cli cracklib crypt cups cxx dbus doc dri fortran gdbm gpm iconv imap introspection ipv6 jpeg jpeg2k libnotify maildir mmx modules mp3 mudflap mysql ncurses nls nptl opengl openmp pam pcre png pppd python readline session sse sse2 sse3 ssl ssse3 svg syslog tcpd truetype unicode vorbis x264 x86 xml xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias threads proxy_connect proxy_ftp proxy_http log proxy version" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US zh zh_CN" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev vesa intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Yixun Lan gentoo-dev 2012-06-16 14:37:27 UTC
Created attachment 315517 [details]
full build log
Comment 2 Arvernux 2012-07-07 20:05:00 UTC
Same problem here. Found a solution with this https://lists.launchpad.net/kicad-developers/msg07833.html

- emerge libgnomeprintui
- USE="gnome" emerge wxGTK
- emerge kicad
Comment 3 Jeroen Roovers gentoo-dev 2013-06-22 14:30:11 UTC
*** Bug 474324 has been marked as a duplicate of this bug. ***
Comment 4 Jeroen Roovers gentoo-dev 2013-06-22 14:30:45 UTC
  22 Jun 2012; Rafael G. Martins <rafaelmartins@gentoo.org> metadata.xml:
  Dropped to maintainer-needed
Comment 5 Pacho Ramos gentoo-dev 2013-10-12 20:54:29 UTC
+  12 Oct 2013; Pacho Ramos <pacho@gentoo.org> -kicad-20120119_p3256.ebuild,
+  -kicad-99999999.ebuild, metadata.xml:
+  Drop old and live version (as last one cannot be maintained properly
+  downstream now that the package is orphan)
+