Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 474324 - sci-electronics/kicad - In file included from .../work/stable_2013-05-18_BZR4017/3d-viewer/3d_aux.cpp:32:0: .../work/stable_2013-05-18_BZR4017/include/common.h:51:9: error: #error "You must use '--with-gnomeprint' or '--with-gtkprint' in your wx library
Summary: sci-electronics/kicad - In file included from .../work/stable_2013-05-18_BZR4...
Status: RESOLVED DUPLICATE of bug 421417
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-22 14:20 UTC by Jan-Erik Skata
Modified: 2013-06-22 14:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,949.92 KB, text/x-log)
2013-06-22 14:21 UTC, Jan-Erik Skata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Erik Skata 2013-06-22 14:20:02 UTC
There is not really any error messages

Generating index page...
Generating page index...
Generating module index...
Generating namespace index...
Generating namespace member index...
Generating annotated compound index...
Generating alphabetical compound index...
Generating hierarchical class index...
Generating member index...
Generating file index...
Generating file member index...
Generating example index...
finalizing index lists...
lookup cache used 65536/65536 hits=621361 misses=82197
finished...
make[3]: Leaving directory `/var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build/CMakeFiles 
Built target doxygen-docs
make[2]: Leaving directory `/var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build'
/usr/bin/cmake -E cmake_progress_start /var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build/CMakeFiles 0
make[1]: Leaving directory `/var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build'
 * ERROR: sci-electronics/kicad-20130518 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sci-electronics/kicad-20130518'`,
 * the complete build log and the output of `emerge -pqv '=sci-electronics/kicad-20130518'`.
 * The complete build log is located at '/var/log/portage/sci-electronics:kicad-20130518:20130622-141255.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/sci-electronics/kicad-20130518/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-electronics/kicad-20130518/temp/environment'.
 * Working directory: '/var/tmp/portage/sci-electronics/kicad-20130518/work/kicad-20130518_build'
 * S: '/var/tmp/portage/sci-electronics/kicad-20130518/work/stable_2013-05-18_BZR4017'

Reproducible: Always




Portage 2.1.12.9 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.8.0-gentoo x86_64)
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    12293328 total,   4065752 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Sat, 22 Jun 2013 12:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.2.5, 3.3.2
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-portage
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LANG="sv_FI.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dlloader dri dts dvb dvd dvdr dvdread emboss enblend encode exif fam firefox flac fortran gdbm gif gimp gpm gtk gtk2 hal iconv java jp2 jpeg jpeg2k kde kipi lcms libnotify mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pango pcre pdf phonon pic plasma png policykit ppds qt3support qt4 readline sdl session sift spell sse sse2 ssl startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vorbis win32codecs wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia fbdev v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jan-Erik Skata 2013-06-22 14:21:29 UTC
Created attachment 351652 [details]
Build log
Comment 2 Jeroen Roovers gentoo-dev 2013-06-22 14:30:11 UTC

*** This bug has been marked as a duplicate of bug 421417 ***