Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418311 - dev-lua/lualdap-1.1 - Simple interface from Lua to an LDAP client
Summary: dev-lua/lualdap-1.1 - Simple interface from Lua to an LDAP client
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Tony Vroon
URL: http://www.keplerproject.org/lualdap/
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks: 358969
  Show dependency tree
 
Reported: 2012-05-30 23:26 UTC by Dennis Schridde
Modified: 2015-02-24 11:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
lualdap-1.1.0.ebuild (lualdap-1.1.0.ebuild,1.11 KB, text/plain)
2012-05-30 23:26 UTC, Dennis Schridde
Details
lualdap-1.1.0.ebuild (lualdap-1.1.0.ebuild,1.01 KB, text/plain)
2012-05-31 01:40 UTC, Dennis Schridde
Details
lualdap-1.1.0-destdir.patch (lualdap-1.1.0-destdir.patch,511 bytes, patch)
2012-05-31 01:40 UTC, Dennis Schridde
Details | Diff
lualdap-1.1.0-lua-5.1.patch (lualdap-1.1.0-lua-5.1.patch,604 bytes, patch)
2012-05-31 01:41 UTC, Dennis Schridde
Details | Diff
lualdap-1.1.0-openldap-2.3.patch (lualdap-1.1.0-openldap-2.3.patch,2.02 KB, patch)
2012-05-31 01:41 UTC, Dennis Schridde
Details | Diff
lualdap-1.1.0.ebuild (lualdap-1.1.0.ebuild,1.02 KB, text/plain)
2012-05-31 02:03 UTC, Dennis Schridde
Details
lualdap-1.1.0.ebuild (lualdap-1.1.0.ebuild,1.03 KB, text/plain)
2012-05-31 02:14 UTC, Dennis Schridde
Details
lualdap-1.1.0-openldap-2.3.patch (lualdap-1.1.0-openldap-2.3.patch,2.06 KB, patch)
2012-05-31 02:15 UTC, Dennis Schridde
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2012-05-30 23:26:26 UTC
DESCRIPTION="Simple interface from Lua to an LDAP client"
HOMEPAGE="http://www.keplerproject.org/lualdap"

Ebuild attached.

Reproducible: Always
Comment 1 Dennis Schridde 2012-05-30 23:26:51 UTC
Created attachment 313645 [details]
lualdap-1.1.0.ebuild
Comment 2 Dennis Schridde 2012-05-31 01:40:17 UTC
Created attachment 313653 [details]
lualdap-1.1.0.ebuild

Changes compared to the last version of the ebuild:
* Install to Lua CMod dir instead of into libdir (determined by pkg-config), because Lua searches modules only in the former
* Also use pkg-config to determine the include dir for Lua
* Document the dependency on pkg-config using DEPEND
* Fix LUA_VERSION_NUM (501 instead of 510 is correct for 5.1)
* Add compatibility patch for lua-5.1 (luaL_openlib is not available anymore)
* Add compatibility patch for openldap-2.3 (several functions were deprecated)
Comment 3 Dennis Schridde 2012-05-31 01:40:59 UTC
Created attachment 313655 [details, diff]
lualdap-1.1.0-destdir.patch
Comment 4 Dennis Schridde 2012-05-31 01:41:14 UTC
Created attachment 313657 [details, diff]
lualdap-1.1.0-lua-5.1.patch
Comment 5 Dennis Schridde 2012-05-31 01:41:29 UTC
Created attachment 313659 [details, diff]
lualdap-1.1.0-openldap-2.3.patch
Comment 6 Dennis Schridde 2012-05-31 01:44:34 UTC
P.S: lualdap-1.1.0-openldap-2.3.patch was written according to [1], which Google found as the last traces of a howto pointed to by [2].

I tested the module and the most basic operation (creating a connection to the server) works.

[1] http://tr.opensuse.org/OpenLDAP_2.3_libldap_upgrade_howto
[2] http://www.mail-archive.com/openldap-software@openldap.org/msg05292.html
Comment 7 Jeroen Roovers gentoo-dev 2012-05-31 01:49:51 UTC
Comment on attachment 313653 [details]
lualdap-1.1.0.ebuild

DEPEND=foo
RDEPEND=$DEPEND
DEPEND=bar

?
Comment 8 Dennis Schridde 2012-05-31 02:03:15 UTC
Created attachment 313663 [details]
lualdap-1.1.0.ebuild

(In reply to comment #7)
> Comment on attachment 313653 [details]
> lualdap-1.1.0.ebuild
> 
> DEPEND=foo
> RDEPEND=$DEPEND
> DEPEND=bar
> 
> ?
Thanks for spotting that!
Comment 9 Dennis Schridde 2012-05-31 02:14:18 UTC
Created attachment 313665 [details]
lualdap-1.1.0.ebuild

Changes:
* Pass CFLAGS=-ansi as the original config did - should help in creating patches that upstream accepts
Comment 10 Dennis Schridde 2012-05-31 02:15:05 UTC
Created attachment 313667 [details, diff]
lualdap-1.1.0-openldap-2.3.patch

Changes:
* strdup is POSIX.1-2001 and hence not ANSI/C90 compliant.
Comment 11 Dennis Schridde 2014-01-26 01:30:26 UTC
This package is still searching for a maintainer.
Comment 12 Tony Vroon gentoo-dev 2015-02-24 10:02:18 UTC
+*lualdap-1.1.0 (24 Feb 2015)
+
+  24 Feb 2015; Tony Vroon <chainsaw@gentoo.org> +lualdap-1.1.0.ebuild,
+  +files/lualdap-1.1.0-destdir.patch, +files/lualdap-1.1.0-lua-5.1.patch,
+  +files/lualdap-1.1.0-openldap-2.3.patch, +metadata.xml:
+  Initial commit. Ebuild and all patches by Dennis "devurandom" Schridde in bug
+  #418311.

Dennis, thank you for your contribution to Gentoo Linux. I have taken maintainership of this package and aim to CC you on any bug reports so we can work on things together.
Sorry for how long this took to be picked up!
Comment 13 Dennis Schridde 2015-02-24 11:45:34 UTC
Thanks!

I think it would be sensible to write an eclass to aid in pkg-config backed Lua building (e.g. #512260) and building for multiple versions of Lua (e.g. bug #534150). In addition some support for slingshot based buildsystems (e.g. bug #369549) might be helpful. Would you like to help me with that?