Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417163 - sys-apps/portage-2.2.0_alpha107: slot conflict display is too verbose when showing "installed) pulled in by"
Summary: sys-apps/portage-2.2.0_alpha107: slot conflict display is too verbose when sh...
Status: CONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2012-05-22 20:11 UTC by Vladimir Berezhnoy
Modified: 2013-01-14 09:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
example.txt (portage-verbose.txt,35.44 KB, text/plain)
2012-05-22 20:11 UTC, Vladimir Berezhnoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Berezhnoy 2012-05-22 20:11:38 UTC
Created attachment 312749 [details]
example.txt

Please see example below, the part with "(x11-libs/qt-qt3support-4.8.0::gentoo, installed) pulled in by" is way too verbose, it's about 200 lines of useless information, though I didn't even use the -v flag. It's so big that I cannot even post it to bugzilla.
Comment 1 Zac Medico gentoo-dev 2012-05-22 20:53:30 UTC
The reason that it shows so many atoms here is that the "kde" flag was removed from the IUSE in qt-qt3support-4.8.1 and later versions.

In some cases, it can be very useful to have an exhaustive list of packages, so that the USE dependencies can be fixed to stop requiring a flag such as "kde". So, I'll have to think about how to make a compromise that's less verbose but doesn't omit potentially useful information.
Comment 2 Vladimir Berezhnoy 2012-05-22 21:02:36 UTC
That is undoubtful that there must be an option for portage to display maximum possible information since it can help in resolving problems, but this should be controlled by verbosity. So we should see some important info and errors/warnings in default mode, but in verbose we should see all info. As of me, portage should use the system which is used in ssh, when multiple -v increase verbosity.
Comment 3 Zac Medico gentoo-dev 2012-05-22 21:21:36 UTC
I would prefer not to use a "hide useful information by default" approach, because typically, people who receive these kinds of errors need this information in order to solve the conflict.
Comment 4 Vladimir Berezhnoy 2012-05-22 21:31:20 UTC
(In reply to comment #3)
> I would prefer not to use a "hide useful information by default" approach,
> because typically, people who receive these kinds of errors need this
> information in order to solve the conflict.

For example I got this message, and it gives me exactly no information about what should I do to resolve the problem, nor does it give me any hint why I see all those 200 lines of some text. I'm not a gentoo dev, but more like a typical user with just about 8 years of gentoo experience and some recent changes in portage are very much frustrating for me.
Well, ok, a typical user may figure out that he may need to put this into bugzilla, but guess what? he will fail to do this because even bugzilla will refuse to accept such a long comment.
One last thing, why not make it look like this: >=x11-libs/qt-qt3support-4.7.4:4[accessibility,kde] required by kde-base/killbots-4.8.0::gentoo, kde-base/ktux-4.8.0::gentoo, kde-base/kephal-4.8.0::gentoo and so on.
Comment 5 Zac Medico gentoo-dev 2012-05-22 21:48:14 UTC
(In reply to comment #4)
> For example I got this message, and it gives me exactly no information about
> what should I do to resolve the problem, nor does it give me any hint why I
> see all those 200 lines of some text.

Maybe you don't understand the message, but those who do understand it will probably welcome the information. If that information isn't shown by default, then they'll have to ask you to run the command again with different options in order to get the information that they need to help you.

> I'm not a gentoo dev, but more like a
> typical user with just about 8 years of gentoo experience and some recent
> changes in portage are very much frustrating for me.
> Well, ok, a typical user may figure out that he may need to put this into
> bugzilla, but guess what? he will fail to do this because even bugzilla will
> refuse to accept such a long comment.

As you seem to know already, that's what attachments are for. Some things are just too big to be posted as bugzilla comments.

> One last thing, why not make it look like this:
> >=x11-libs/qt-qt3support-4.7.4:4[accessibility,kde] required by
> kde-base/killbots-4.8.0::gentoo, kde-base/ktux-4.8.0::gentoo,
> kde-base/kephal-4.8.0::gentoo and so on.

I like that idea.
Comment 6 Sebastian Luther (few) 2012-05-23 05:32:22 UTC
Does this message really come from the slot conflict handler? I thought only the block handler would do that.

And yes, I agree that 

x11-libs/qt-qt3support:4

  (x11-libs/qt-qt3support-4.8.0::gentoo, installed) pulled in by
    >=x11-libs/qt-qt3support-4.7.4:4[accessibility,kde] required by (kde-base/killbots-4.8.0::gentoo, installed)
 (and 200 more with the same problem)

is the better message. What information can you get out of this message? That some installed packages insist on those two use flags. The only way to fix that is play with the use flags x11-libs/qt-qt3support. The other 199 installed packages are irrelevant.
Comment 7 Zac Medico gentoo-dev 2012-05-23 07:13:29 UTC
(In reply to comment #6)
> Does this message really come from the slot conflict handler?

Yeah, I had an issue where a flag was removed from IUSE, and I was annoyed that it wouldn't tell me all the packages that needed to be fixed, so I changed the behavior here:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=6d3bae4d1d48033668107863bf30d483792350e9

> And yes, I agree that 
> 
> x11-libs/qt-qt3support:4
> 
>   (x11-libs/qt-qt3support-4.8.0::gentoo, installed) pulled in by
>     >=x11-libs/qt-qt3support-4.7.4:4[accessibility,kde] required by
> (kde-base/killbots-4.8.0::gentoo, installed)
>  (and 200 more with the same problem)
> 
> is the better message. What information can you get out of this message?

In some cases, it's useful to have the whole list, so you can go fix the broken dependencies. I suppose that we could hide it behind the --debug flag, but I didn't think that would be necessary, since this kind of thing doesn't happen very often.

> That some installed packages insist on those two use flags. The only way to
> fix that is play with the use flags x11-libs/qt-qt3support. The other 199
> installed packages are irrelevant.

No, in this case they actually went and fixed the deps in all 199 package, so that since kde-4.1.8 they no longer depend on the "kde" flag.
Comment 8 Sebastian Luther (few) 2012-05-23 08:10:00 UTC
(In reply to comment #7)
[...]
> No, in this case they actually went and fixed the deps in all 199 package,
> so that since kde-4.1.8 they no longer depend on the "kde" flag.

This is a broken idea and we shouldn't encourage people to do that. Hardly anybody knows how to do that properly. If you want to fix such cases then prevent people from removing use flags like this.