Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 414817 - [Future EAPI] Support for make.defaults, use.force, use.stable.force, use.mask, use.stable.mask, package.use, package.use.force, package.use.stable.force, package.use.mask and package.use.stable.mask in ${repository_path}/profiles
Summary: [Future EAPI] Support for make.defaults, use.force, use.stable.force, use.mas...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: PMS/EAPI (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: PMS/EAPI
URL:
Whiteboard:
Keywords:
Depends on: 431078
Blocks: future-eapi
  Show dependency tree
 
Reported: 2012-05-06 03:01 UTC by Arfrever Frehtes Taifersar Arahesis
Modified: 2013-01-12 13:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis 2012-05-06 03:01:38 UTC
make.defaults, use.force, use.mask, package.use, package.use.force and package.use.mask placed directly in ${repository_path}/profiles should be supported. They would affect only ebuilds from given repository.
Comment 1 Arfrever Frehtes Taifersar Arahesis 2012-09-06 07:57:38 UTC
Additionally this feature should affect use.stable.force, use.stable.mask, package.use.stable.force and package.use.stable.mask.