Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412135 - app-text/poppler-0.16.7 and 0.20.2: pdftops creates postscript files which don't print on Brother MFC-8720N
Summary: app-text/poppler-0.16.7 and 0.20.2: pdftops creates postscript files which do...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Maciej Mrozowski
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard: tracking upstream
Keywords: PATCH
: 398043 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-15 20:37 UTC by Markus Lischka
Modified: 2013-08-24 15:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ubuntu patch to fix Brother printing issues (10_fix-a4-page-shift-on-brother-ps-printers.patch,729 bytes, text/plain)
2012-04-15 20:37 UTC, Markus Lischka
Details
Patch to fix Brother printing issues for poppler-0.20.2 (10_fix-a4-page-shift-on-brother-ps-printers.patch,499 bytes, patch)
2012-07-21 21:37 UTC, Markus Lischka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Lischka 2012-04-15 20:37:49 UTC
Created attachment 309081 [details]
Ubuntu patch to fix Brother printing issues

Printing on my Brother MFC-8720 fails if the printing application outputs PDF to cups (both 1.4.8-r1 and 1.5.2-r1). The problem can be traced back to the converted Postscript output by poppler's pstopdf.

The Postscript code created by pstopdf causes two problems:

1. If the printer was just turned on, the first printout fails with the following error page:

ERROR NAME;
   configurationerror
COMMAND;
   setpagedevice
OPERAND STACK;
   --dicttype--

2. Subsequent tries are successful, but the margins are wrong: the whole page is shifted upwards.


Both symptoms can be traced to one problematic line in the Postscript prolog inserted by pstopdf. Upstream's bugzilla lists two open bug reports related to this problem (bug #18711 <https://bugs.freedesktop.org/show_bug.cgi?id=18711>, bug #17952 <https://bugs.freedesktop.org/show_bug.cgi?id=17952>).

Current Ubuntu packages of poppler contain a small patch fixing this issue. The corresponding patch is attached, see Launchpad bug #293832 <https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/293832>.

I'd appreciate an official integration in the current poppler ebuild... Thanks in advance!
Comment 1 Andreas K. Hüttel gentoo-dev 2012-07-20 21:17:09 UTC
poppler-0.16 is not in the tree anymore. Do you still have this problem with poppler-0.18 or 0.20?
Comment 2 Markus Lischka 2012-07-21 14:38:52 UTC
I'm currently running stable app-text/poppler-0.18.4-r1 with exactly the same problems as reported for 0.16. The old patch still applies and fixes the problem for me.

So far, I did not try poppler-0.20 yet. There has been no progress on the referenced upstream bugs since April, so I guess the problem still exists in 0.20 as well. Let me know if it's worthwile to test out poppler-0.20.
Comment 3 Andreas K. Hüttel gentoo-dev 2012-07-21 16:47:32 UTC
Please try poppler-0.20. It should be fixed there imho.
Comment 4 Markus Lischka 2012-07-21 21:37:15 UTC
Created attachment 318864 [details, diff]
Patch to fix Brother printing issues for poppler-0.20.2

Tested poppler-0.20.2: It fixes only on of the two mentioned problems...

1. The first page after turning on the printer still fails with the same error.
2. Subsequent pages are successfully printed with correct margins.

To get a correct printout after turning on the printer, version 0.20.2 still needs the "Policies" line removed. Attached is a slightly modified patch for version 0.20.2 that fixes the remaining problem no. 1.
Comment 5 Andreas K. Hüttel gentoo-dev 2012-08-23 20:29:24 UTC
*** Bug 398043 has been marked as a duplicate of this bug. ***
Comment 6 Markus Lischka 2012-11-25 21:17:48 UTC
Just installed app-text/poppler-0.20.4 and tested this issue again: The problem still exists as described in comment 4, the patch for poppler-0.20.2 still applies and fixes the bug.
Comment 7 Andreas K. Hüttel gentoo-dev 2013-03-09 19:08:18 UTC
From the upstream bug report:

Stefan Brüns 2013-01-14 22:37:58 UTC
The fragment is syntactically correct, but it may be semantically wrong.
From PLRM 3 (p433 ff):
/PageSize 6 :
 Select the next larger available medium but do not adjust the page.
This might lead to an error if there is no pagesize larger than requested.
@Andreas: What pagesizes are available? Which pagesize did you request?
Comment 8 Andreas K. Hüttel gentoo-dev 2013-08-24 15:17:11 UTC
(In reply to Andreas K. Hüttel from comment #7)
> From the upstream bug report:
> 
> Stefan Brüns 2013-01-14 22:37:58 UTC
> The fragment is syntactically correct, but it may be semantically wrong.
> From PLRM 3 (p433 ff):
> /PageSize 6 :
>  Select the next larger available medium but do not adjust the page.
> This might lead to an error if there is no pagesize larger than requested.
> What pagesizes are available? Which pagesize did you request?

Wee need your help here, otherwise we cannot do anything.