Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410699 - www-servers/apache-2.4.1-r2 /etc/init.d/apache2 start complains about Config variable ${SVN_REPOS_LOC} is not defined
Summary: www-servers/apache-2.4.1-r2 /etc/init.d/apache2 start complains about Config ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2012-04-03 19:39 UTC by Juergen Rose
Modified: 2015-05-08 19:01 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-04-03 19:39:57 UTC
Running '/etc/init.d/apache2 restart', it complains about:

root@moose:/root(8)# /etc/init.d/apache2 restart
 * Stopping apache2 ...
[Tue Apr 03 21:35:32.734051 2012] [core:warn] [pid 10311:tid 140313226966848] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
[Tue Apr 03 21:35:32.736603 2012] [core:warn] [pid 10311:tid 140313226966848] AH00111: Config variable ${SVN_REPOS_LOC} is not defined                                                                            [ ok ]
 * Starting apache2 ...
[Tue Apr 03 21:35:34.942849 2012] [core:warn] [pid 10336:tid 140010782402368] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
[Tue Apr 03 21:35:34.942928 2012] [core:warn] [pid 10336:tid 140010782402368] AH00111: Config variable ${SVN_REPOS_LOC} is not defined                                                                            [ ok ]
root@moose:/root(9)# 


Reproducible: Always




root@moose:/root(12)# emerge --info
Portage 2.1.10.55 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r2, 3.3.0-gentoo x86_64)
=================================================================
System uname: Linux-3.3.0-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Tue, 03 Apr 2012 16:00:01 +0000
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3::sage-on-gentoo, 3.2.2-r1
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.4
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo x11 arcon bicatali sage-on-gentoo science java-overlay sunrise x-portage x-cpan g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/arcon /var/lib/layman/bicatali /var/lib/layman/sage-on-gentoo /var/lib/layman/science /var/lib/layman/java-overlay /var/lib/layman/sunrise /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib glpk gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdrive kerberos kpathsea kqemu kvm ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mkl mmx mmxext mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 sse4 ssl ssse3 startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xattr xcb xemacs xext xft xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Orlitzky gentoo-dev 2012-04-03 20:21:29 UTC
See bug 410607 for the larger issue.
Comment 2 Andreas Sturmlechner gentoo-dev 2012-10-13 22:55:24 UTC
I've just upgraded to apache-2.4.3 and got the same trouble:

 * apache2 has detected an error in your setup:
[Sun Oct 14 00:23:42.746236 2012] [core:warn] [pid 5272:tid 140626338662208] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
[Sun Oct 14 00:23:42.746353 2012] [core:warn] [pid 5272:tid 140626338662208] AH00111: Config variable ${SVN_REPOS_LOC} is not defined
apache2: Syntax error on line 153 of /etc/apache2/httpd.conf: Syntax error on line 4 of /etc/apache2/modules.d/70_mod_php5.conf: Cannot load modules/libphp5.so into server: /usr/lib64/apache2/modules/libphp5.so: undefined symbol: unixd_config
Comment 3 Juergen Rose 2012-10-21 11:28:25 UTC
To Comment2: The issues with libphp5.so and unixd_config
disappeared for after adding 
 authn_core
 authz_core
 lbmethod_byrequests
 slotmem_shm
 unixd
to APACHE2_MODULES in make.conf and reemerging apache-2.4.3, php-5.4.7 and virtual/httpd-php-5.4-r1.
Comment 4 turtle 2013-01-06 09:38:43 UTC
I can confirm this bug.
Its Gentoo specific
/usr/portage/dev-vcs/subversion/subversion
/etc/apache2/modules.d/47_mod_dav_svn.conf
Comment 5 Christophe PEREZ 2013-03-04 21:51:59 UTC
confirmed with apache 2.4.4-r1.
Nothing done ?
Comment 6 Andreas Sturmlechner gentoo-dev 2013-03-04 22:05:25 UTC
Yes, same here, suggestion from comment 3 didn't help.
Comment 7 Timo Rothenpieler 2013-05-08 15:19:33 UTC
Seems like apache realy wants to replace variables in its configuration, even if the variable is in a comment and inside a disabled block.
I got rid of the warning by removing the commented out example from /etc/apache2/modules.d/47_mod_dav_svn.conf
Comment 8 mordjah 2013-11-08 18:35:36 UTC
Ran acrossed this while troubleshooting an unrelated issue. The problem appears to be shell expansion related.. if you escape the curly braces apache parses it just fine. if you replace with $\{SVN_REPOS_LOC\} or $SVN_REPOS_LOC it works as intended.
Comment 9 Massimo Balestra 2013-11-27 04:43:10 UTC
I confirm that comment 8 works.
If you edit the file modules.d/47_mod_dav_svn.conf and remove the curly braces  or escape them the warning disappears.
Comment 10 Julian Reich 2015-03-29 08:36:59 UTC
This bug was probably fixed upstream in Apache httpd 2.4.11: <https://bz.apache.org/bugzilla/show_bug.cgi?id=56503>.
Comment 11 Andreas Sturmlechner gentoo-dev 2015-03-31 22:32:21 UTC
Yes, looks good to me, got it running now. (though, looks like an upgrade 2.2 to 2.4 should trigger a php rebuild?)
Comment 12 Pacho Ramos gentoo-dev 2015-05-08 19:01:17 UTC
should be fixed in 2.4.12