Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410453 - www-apache/mod_perl does not build against www-servers/apache2-2.4.1-r2
Summary: www-apache/mod_perl does not build against www-servers/apache2-2.4.1-r2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: apache-2.4-stable
  Show dependency tree
 
Reported: 2012-04-01 17:22 UTC by Sean McGovern
Modified: 2015-05-08 18:59 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mod_perl-2.0.5-r1302463.ebuild (mod_perl-2.0.5-r1302463.ebuild,5.36 KB, text/plain)
2012-04-03 17:57 UTC, Martin Jansa
Details
mod_perl-2.0.5-r1302463.patch (mod_perl-2.0.5-r1302463.patch,47.37 KB, patch)
2012-04-03 17:57 UTC, Martin Jansa
Details | Diff
mod_perl-2.0.5-r1302463-dirty-hacks-to-build-it.patch (mod_perl-2.0.5-r1302463-dirty-hacks-to-build-it.patch,3.91 KB, patch)
2012-04-03 17:57 UTC, Martin Jansa
Details | Diff
mod_perl-2.0.5-r1302463-use-client_ip-client_add-instead-of-remote_ip-remote.patch (mod_perl-2.0.5-r1302463-use-client_ip-client_add-instead-of-remote_ip-remote.patch,1.37 KB, patch)
2012-04-03 17:58 UTC, Martin Jansa
Details | Diff
mod_perl-2.0.5-r1302463-use-log.level-instead-of-loglevel.patch (mod_perl-2.0.5-r1302463-use-log.level-instead-of-loglevel.patch,870 bytes, patch)
2012-04-03 17:58 UTC, Martin Jansa
Details | Diff
mod_perl-2.0.5-r1302463-bundled-Apache-Test.patch (mod_perl-2.0.5-r1302463-bundled-Apache-Test.patch,2.53 KB, patch)
2012-04-03 17:58 UTC, Martin Jansa
Details | Diff
mod_perl-2.0.5-r1302463-ConstantsTable.pm-drop-OPT_INCNOEXEC.patch (mod_perl-2.0.5-r1302463-ConstantsTable.pm-drop-OPT_INCNOEXEC.patch,814 bytes, patch)
2012-04-03 18:00 UTC, Martin Jansa
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sean McGovern 2012-04-01 17:22:17 UTC
The following 2 modules current do not build against the recently updated apache2 ebuild.

At the very least, /usr/sbin/apxs is missing execute bits -- but even when these are manually restored the build still fails.

Reproducible: Always

Steps to Reproduce:
1. emerge apache2
2. emerge mod_perl or mod_wsgi


Actual Results:  
Ebuilds fail.

Expected Results:  
Ebuilds should succeed.
Comment 1 Klemen Mihevc 2012-04-01 21:25:48 UTC
something similar with mod_python, mod_geoip2 and i think even php 5.3.10-r2 (dont remember exactly and cant check since i reverted back to 2.2.22)
Comment 2 Jeroen Roovers gentoo-dev 2012-04-02 02:44:56 UTC
Please file a separate bug for www-apache/mod_wsgi.
Comment 3 Martin Jansa 2012-04-03 16:00:19 UTC
I've tried to build mod_perl from svn trunk and from httpd24 branch and it's still depending on removed remote_ip and remote_addr..

See this thread for details
http://mail-archives.apache.org/mod_mbox/perl-modperl/201203.mbox/%3CCAJiMZ97mkhKe9OQX9Rm9doFn9GDcRf8U3ASoHpJUVpo=-aa-MQ@mail.gmail.com%3E

So maybe apache-2.4* should be masked a bit longer...
Comment 4 Martin Jansa 2012-04-03 17:57:14 UTC
Created attachment 307641 [details]
mod_perl-2.0.5-r1302463.ebuild
Comment 5 Martin Jansa 2012-04-03 17:57:42 UTC
Created attachment 307643 [details, diff]
mod_perl-2.0.5-r1302463.patch
Comment 6 Martin Jansa 2012-04-03 17:57:58 UTC
Created attachment 307645 [details, diff]
mod_perl-2.0.5-r1302463-dirty-hacks-to-build-it.patch
Comment 7 Martin Jansa 2012-04-03 17:58:27 UTC
Created attachment 307647 [details, diff]
mod_perl-2.0.5-r1302463-use-client_ip-client_add-instead-of-remote_ip-remote.patch
Comment 8 Martin Jansa 2012-04-03 17:58:40 UTC
Created attachment 307649 [details, diff]
mod_perl-2.0.5-r1302463-use-log.level-instead-of-loglevel.patch
Comment 9 Martin Jansa 2012-04-03 17:58:58 UTC
Created attachment 307651 [details, diff]
mod_perl-2.0.5-r1302463-bundled-Apache-Test.patch
Comment 10 Martin Jansa 2012-04-03 18:00:43 UTC
Created attachment 307653 [details, diff]
mod_perl-2.0.5-r1302463-ConstantsTable.pm-drop-OPT_INCNOEXEC.patch
Comment 11 Martin Jansa 2012-04-03 18:00:55 UTC
I've built it successfully with couple of dirty hacks and apache-backuppc works for me.. so I'll attach my patches here if someone finds them usefull...
Comment 12 Martin Jansa 2012-06-07 12:30:08 UTC
All patches except first one (mod_perl-2.0.5-r1302463.patch) still do apply to newly added mod_perl-2.0.7 and provide working mod_perl for apache-2.4 (still using it mostly for apache-backuppc)
Comment 13 Gregg Casillo 2013-02-25 18:57:24 UTC
Any updates on any mod_perl ebuild that will build with the latest apache ebuilds? I'm concerned about falling behind with apache versions, and I need mod_perl for my work. Thanks.
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-08-12 22:12:06 UTC
I've added mod_perl-2.0.8 to my overlay. I got it working with apache-2.4 based on the debian work and thanks to Gregor Herrmann <gregoa@debian.org>.

http://git.overlays.gentoo.org/gitweb/?p=dev/jmbsvicetto.git;a=tree;f=www-apache/mod_perl;h=127de13d9bf9dae418e8d7ffce20e29b28b80383;hb=refs/heads/master
Comment 15 Sean McGovern 2013-10-15 17:09:21 UTC
I don't use Apache on Gentoo anymore, so I don't need to track this bug. Can it be reassigned?
Comment 16 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2013-10-15 18:49:52 UTC
(In reply to Sean McGovern from comment #15)
> I don't use Apache on Gentoo anymore, so I don't need to track this bug. Can
> it be reassigned?

You're the reporter, not the assignee. The reporter cannot be changed, sorry.
Comment 17 Michael Orlitzky gentoo-dev 2014-05-28 03:11:19 UTC
Nobody ever opened another bug for mod_wsgi; for what it's worth, that was fixed with a version bump in bug #510938.
Comment 18 Sergiy Borodych 2014-06-02 07:23:33 UTC
There is no such version (mod_perl-2.0.5) in portage anymore. Vote for close.
Comment 19 Dan Goodliffe 2014-06-02 07:29:18 UTC
I think this issue persists with 2.0.8 in the main portage tree.
I've been using the ebuild from Jorge's overlay in comment 14 for some time now.
Comment 20 Sergiy Borodych 2014-06-02 07:42:52 UTC
Seems like I was wrong.
Even in ebuild still present:
 DEPEND="<www-servers/apache-2.4
Comment 21 Pacho Ramos gentoo-dev 2014-06-09 11:37:41 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #14)
> I've added mod_perl-2.0.8 to my overlay. I got it working with apache-2.4
> based on the debian work and thanks to Gregor Herrmann <gregoa@debian.org>.
> 
> http://git.overlays.gentoo.org/gitweb/?p=dev/jmbsvicetto.git;a=tree;f=www-
> apache/mod_perl;h=127de13d9bf9dae418e8d7ffce20e29b28b80383;hb=refs/heads/
> master

Anything blocking this from being moved to the tree?
Comment 22 Tomáš Mózes 2014-11-12 08:13:41 UTC
Tested with apache 2.4.10 and perl 5.20.

--- mod_perl-2.0.8.ebuild      2014-11-09 23:01:19.000000000 +0100
+++ mod_perl-2.0.8-r1.ebuild    2014-11-12 09:09:24.227455575 +0100
@@ -81,6 +81,10 @@
        rm -rf Apache-{Test,Reload,SizeLimit}/ lib/Bundle/
        sed -i -e 's:^Apache-\(Reload\|SizeLimit\|Test\).*::' \
                -e 's:^lib/Bundle/Apache2.pm::' MANIFEST || die
+
+       # 410453
+       epatch "${FILESDIR}/use-client_ip-client_add-instead-of-remote_ip-remote.patch"
+       epatch "${FILESDIR}/use-log.level-instead-of-loglevel.patch"
 }
 
 src_configure() {
@@ -97,6 +101,7 @@
                INSTALLDIRS=vendor \
                MP_USE_DSO=1 \
                MP_APXS=${APXS} \
+               MP_APR_CONFIG=/usr/bin/apr-1-config \
                ${myargs} || die
 }
Comment 23 Pacho Ramos gentoo-dev 2014-12-16 09:43:08 UTC
(In reply to Tomas Mozes from comment #22)
[...]               -e 's:^lib/Bundle/Apache2.pm::' MANIFEST || die
> +
> +       # 410453
> +       epatch
> "${FILESDIR}/use-client_ip-client_add-instead-of-remote_ip-remote.patch"
> +       epatch "${FILESDIR}/use-log.level-instead-of-loglevel.patch"
>  }

Where are this patches coming from? Are the ones from this bug? (look to be for 2.0.5)

I have seen most distributions are relying on Debian packages for this... and they have now a 2.0.9 snapshot
Comment 24 Tomáš Mózes 2014-12-16 13:29:46 UTC
(In reply to Pacho Ramos from comment #23)
> (In reply to Tomas Mozes from comment #22)
> [...]               -e 's:^lib/Bundle/Apache2.pm::' MANIFEST || die
> > +
> > +       # 410453
> > +       epatch
> > "${FILESDIR}/use-client_ip-client_add-instead-of-remote_ip-remote.patch"
> > +       epatch "${FILESDIR}/use-log.level-instead-of-loglevel.patch"
> >  }
> 
> Where are this patches coming from? Are the ones from this bug? (look to be
> for 2.0.5)

Yes
Comment 25 Pacho Ramos gentoo-dev 2014-12-16 14:33:51 UTC
@idl0r, what option do you think is better? The Debian snapshot or applying that two patches?
Comment 26 Pacho Ramos gentoo-dev 2015-05-08 18:59:06 UTC
+*mod_perl-2.0.8-r1 (08 May 2015)
+
+  08 May 2015; Pacho Ramos <pacho@gentoo.org>
+  +files/use-client_ip-client_add-instead-of-remote_ip-remote.patch,
+  +files/use-log.level-instead-of-loglevel.patch, +mod_perl-2.0.8-r1.ebuild,
+  -mod_perl-2.0.7-r1.ebuild:
+  Support apache 2.4 (#410453)
+