Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409819 - app-misc/screen-4.0.3-r4 fails to build due to missing utmp.h on FreeBSD-9.0
Summary: app-misc/screen-4.0.3-r4 fails to build due to missing utmp.h on FreeBSD-9.0
Status: RESOLVED DUPLICATE of bug 393039
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords: Bug
Depends on:
Blocks:
 
Reported: 2012-03-27 03:54 UTC by Richard Yao
Modified: 2012-12-03 18:44 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-misc/screen-4.0.3-r4 build.log from failure (build.log,11.06 KB, text/plain)
2012-03-27 03:54 UTC, Richard Yao
Details
Screen Patches from FreeBSD 9 Ports (fbsd9-ports-bash-patches.txz,148.41 KB, application/octet-stream)
2012-03-28 03:57 UTC, Richard Yao
Details
patch to solve build error (screen-4.0.3-freebsd-utmpx.patch,1.18 KB, patch)
2012-05-16 04:34 UTC, Naohiro Aota
Details | Diff
patch for screen.h (409819.patch,299 bytes, patch)
2012-11-17 17:34 UTC, Yuta SATOH
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao gentoo-dev 2012-03-27 03:54:06 UTC
Created attachment 306813 [details]
app-misc/screen-4.0.3-r4 build.log from failure

It seems possible to get this working using the patches from FreeBSD ports, although I am not sure if having a different patchset for Gentoo/FreeBSD is the right thing to do.

# emerge --info
Portage 2.2.0_alpha93 (default/bsd/fbsd/x86/9.0, gcc-4.6.2, freebsd-lib-9.0, 9.0-RELEASE i386)
=================================================================
System uname: FreeBSD-9.0-RELEASE-i386-32bit-ELF
Timestamp of tree: Tue, 27 Mar 2012 03:30:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:         4.2_p24
dev-lang/python:         2.7.2-r3, 3.2.2-r1
dev-util/ccache:         3.1.7
dev-util/pkgconfig:      0.26
sys-apps/baselayout:     2.1
sys-apps/openrc:         0.9.9.3
sys-devel/autoconf:      2.68
sys-devel/automake:      1.9.6-r3, 1.11.3
sys-devel/binutils:      2.20.1-r1
sys-devel/gcc:           4.5.3-r2, 4.6.2
sys-devel/gcc-config:    1.6
sys-devel/libtool:       2.4.2
sys-devel/make:          3.82-r3
sys-freebsd/freebsd-lib: 9.0 (virtual/os-headers)
Repositories: gentoo local_overlay
Installed sets: 
ACCEPT_KEYWORDS="x86-fbsd ~x86-fbsd"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-gentoo-freebsd9.0"
CFLAGS="-O2 -pipe -march=amdfam10 -mcx16 -msahf -mpopcnt -mabm --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=amdfam10"
CHOST="i686-gentoo-freebsd9.0"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=amdfam10 -mcx16 -msahf -mpopcnt -mabm --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=amdfam10"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg ccache chflags distlocks ebuild-locks fixlafiles news noinfo parallel-fetch parallel-install preserve-libs protect-owned sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=amdfam10 -mcx16 -msahf -mpopcnt -mabm --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=amdfam10"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext acl berkdb cli cracklib crypt cups cxx dri gdbm iconv ipv6 java5 java6 modules ncurses nls nptlonly oss pam pcre perl python readline session sse3 sse4a ssl sysfs tcpd unicode x86-fbsd xorg zfs zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="FreeBSD" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="FreeBSD" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="BSD" VIDEO_CARDS="apm ark chips cirrus cyrix dummy i128 intel mach64 mga neomagic nv r128 radeon rendition s3 s3virge savage siliconmotion sis tga trident tseng vmware fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Richard Yao gentoo-dev 2012-03-28 03:57:56 UTC
Created attachment 306923 [details]
Screen Patches from FreeBSD 9 Ports

I am attaching the patch set from FreeBSD 9's ports tree.
Comment 2 Naohiro Aota gentoo-dev 2012-05-16 04:34:12 UTC
Created attachment 311929 [details, diff]
patch to solve build error

The patch above contains too much fix. Just to solve this build issue, you need only this patch. It worked fine with my x86 G/FreeBSD-9.0. Please review and apply.

Thanks.
Comment 3 Yuta SATOH 2012-11-17 17:34:12 UTC
Created attachment 329736 [details, diff]
patch for screen.h

(In reply to comment #2)
> Created attachment 311929 [details, diff] [details, diff]
> patch to solve build error
> 
> The patch above contains too much fix. Just to solve this build issue, you
> need only this patch. It worked fine with my x86 G/FreeBSD-9.0. Please
> review and apply.
> 
> Thanks.

I has been tested on amd64-fbsd.

naota's patch is successfully compiled.
However, it does not operate normally.

Additional patch is needed for it to work properly.
I'll attach it.
Comment 4 Peter Stuge 2012-11-17 19:20:24 UTC
I can confirm that the two patches make screen-4.0.3-r7 build and work fine on my Gentoo-FreeBSD-9.0.

I've published a modified ebuild in my overlay 'stuge' which is included in the layman list.
Comment 5 Jeroen Roovers gentoo-dev 2012-12-03 18:44:56 UTC

*** This bug has been marked as a duplicate of bug 393039 ***