Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 393039 - app-misc/screen on Gentoo/FBSD9 - os.h:275:20: error: utmp.h: No such file or directory
Summary: app-misc/screen on Gentoo/FBSD9 - os.h:275:20: error: utmp.h: No such file or...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords:
: 409819 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-03 17:00 UTC by Tibor Vago
Modified: 2019-10-11 17:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
screen-4.0.3-fbsd9.patch (screen-4.0.3-fbsd9.patch,421 bytes, patch)
2011-12-03 17:21 UTC, Tibor Vago
Details | Diff
screen-4.0.3-r4.ebuild (screen-4.0.3-r4.ebuild,5.21 KB, text/plain)
2011-12-03 17:35 UTC, Tibor Vago
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tibor Vago 2011-12-03 17:00:35 UTC
>>> Compiling source in /var/tmp/portage/app-misc/screen-4.0.3-r4/work/screen-4.0.3 ...
gmake -j1 
CPP="sparc64-gentoo-freebsd9.0-gcc -E " srcdir=. sh ./osdef.sh
In file included from osdef0.c:23:
os.h:275:20: error: utmp.h: No such file or directory
AWK=gawk CC="sparc64-gentoo-freebsd9.0-gcc -w -O2 -mcpu=ultrasparc3 -mtune=ultrasparc3 -fno-strict-aliasing -pipe -I/usr/src/sys -DMAXWIN=100 -DNONETHACK" srcdir=. sh ./comm.sh
sparc64-gentoo-freebsd9.0-gcc -c -I. -I.    -w -O2 -mcpu=ultrasparc3 -mtune=ultrasparc3 -fno-strict-aliasing -pipe -I/usr/src/sys -DMAXWIN=100 -DNONETHACK screen.c
In file included from screen.h:25,
                 from screen.c:81:
os.h:275:20: error: utmp.h: No such file or directory
In file included from screen.h:153,
                 from screen.c:81:
display.h:187: error: field 'd_utmp_logintty' has incomplete type
In file included from screen.h:154,
                 from screen.c:81:
window.h:247: error: field 'w_savut' has incomplete type
gmake: *** [screen.o] Error 1
emake failed
Comment 1 Tibor Vago 2011-12-03 17:21:05 UTC
Created attachment 294611 [details, diff]
screen-4.0.3-fbsd9.patch

screen compiles with this simple patch on freebsd9.
Comment 2 Tibor Vago 2011-12-03 17:35:36 UTC
Created attachment 294617 [details]
screen-4.0.3-r4.ebuild

ebuild to apply the attached patch.
Comment 3 Jeroen Roovers gentoo-dev 2012-12-03 18:44:56 UTC
*** Bug 409819 has been marked as a duplicate of this bug. ***
Comment 4 Peter Stuge 2012-12-03 19:52:08 UTC
As mentioned in bug 409819 I have a screen-4.0.3-r7.ebuild in my overlay 'stuge' (included in the layman list) with the two patches from that bug.

Instead of disabling UTMP completely like the patch in this bug, they make things work by using UTMPX instead of UTMP, on FreeBSD. The ebuild is tested to build and the binary works well on my Gentoo/FreeBSD system.
Comment 5 Dmitri Bogomolov 2013-02-27 10:05:57 UTC
Interestingly, this bug is still "UNCONFIRMED". Why? What kind of confirmation is needed?
Comment 6 droidz2a111 2014-02-11 21:00:15 UTC
https://409819.bugs.gentoo.org/attachment.cgi?id=311929

This patch makes app-misc/screen-4.0.3-r8 compile but it will not run.
I created the /run/screen directory and running the program created /run/screen/S-user1/33091.pts-4.gfbsd-1

ls -al /run/screen/S-user1/33091.pts-4.gfbsd-1
prwx------  1 user1  wheel  0 Feb 11 20:54 /run/screen/S-user1/33091.pts-4.gfbsd-1

ls -al /run
drwxrwxrwx   4 root  wheel  512 Feb 11 20:54 screen
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-11 17:37:29 UTC
*-fbsd is gone.